Subject: RE: [AVT] I-D ACTION:draft-ietf-avt-uncomp-video-01.txt

From: "Gary Sullivan" <[email-masked]>
Date: Thu, 7 Nov 2002 18:54:34 -0800

This can get kind of elaborate.  Just defining uncompressed video
includes specifying at least all of the following:

1) color primaries (there are several variants of these)
2) white point (D65 or Illuminant C or others)
3) transfer characteristics ("gamma") (there are quite a
   few variations of this)
4) matrix coefficients (note that there are several
   different standard definitions of YCbCr, for example)
5) scaling (e.g., 8-bit luma normally is scaled down to occupy
   235 levels rather than 255)
6) offsets (black is not usually at zero, white not usually at
   max representable value, neutral chroma is often 128 rather
   than zero, etc.)
7) rounding method
8) bit depth (8/10/12/...)
9) sampling structure (4:4:4, 4:2:2, at least two
   distinct variations of 4:2:0, 4:1:1)
10) interlace/progressive
12) timing

And that's just what springs to mind quickly.

Best Regards,

Gary Sullivan

+> -----Original Message-----
+> From: Ivan R. Judson [mailto:[email-masked]] 
+> Sent: Thursday, November 07, 2002 6:15 PM
+> To: 'Chuck Harrison'; [email-masked]
+> Cc: [email-masked]; [email-masked]
+> Subject: RE: [AVT] I-D ACTION:draft-ietf-avt-uncomp-video-01.txt
+> 
+> 
+> 
+> I was thinking about this on my 2+ hour drive home tonight 
+> (lots of time
+> to ponder)...
+> 
+> There is a raw payload format already, so why not consider augmenting
+> the raw payload with a mechanism to specify a data description, YUV,
+> YCbCr, RGB, DVI-D, are all really just different in a) color space
+> and/or b) data packing.  Perhaps raw should be extended to support
+> different raw (=? Uncompressed) formats?
+> 
+> Just a thought,
+> 
+> --Ivan
+> 
+> ..........
+> Ivan R. Judson .~. http://www.mcs.anl.gov/~judson
+> Futures Laboratory .~.  630 252 0920
+> Argonne National Laboratory .~. 630 252 6424 Fax
+>  
+> 
+> > -----Original Message-----
+> > From: [email-masked] [mailto:[email-masked]] On 
+> > Behalf Of Chuck Harrison
+> > Sent: Thursday, November 07, 2002 6:07 PM
+> > To: [email-masked]
+> > Cc: [email-masked]; [email-masked]
+> > Subject: Re: [AVT] I-D ACTION:draft-ietf-avt-uncomp-video-01.txt
+> > 
+> > 
+> > Philippe, all,
+> > 
+> > [email-masked] wrote:
+> > > 
+> > > Hi all,
+> > > 
+> > > we think this draft is cool.
+> > > 
+> > > [...]
+> > > Planar is when the Luminance and chrominance "planes" are 
+> > separated. 
+> > > The rational is to save memory access since in most 
+> implementations 
+> > > handling the YUV420 format an image is stored in memory 
+> as 3 arrays 
+> > > (one for luminance, 2 for each chrominance)
+> > 
+> > Another way to support "planar" formats would be to open 3 
+> > parallel monochrome sessions: one for Y, one for Cr, one for 
+> > Cb.  Note that the raster resolution on the chroma sessions 
+> > would naturally be one-half of the luma session.
+> > 
+> > You'd probably packetize the Y on 16-pixel pgroups and the 
+> > CrCb on 8-pixel pgroups to keep each line of a macroblock 
+> > together in partial ALF style...
+> > 
+> > I haven't thought much about the plusses and minuses of this 
+> > planar approach but I thought I'd toss it out there for discussion.
+> > 
+> > BTW has anybody looked at the LBL "Visipult" UDP 
+> > packetization that they used to win the SC2001 network 
+> > bandwidth challenge? It has some similarities to the 
+> > uncompressed-video draft. (And stay tuned for SC2002 next 
+> > week in Baltimore!)
+> > 
+> > Cheers,
+> >   Chuck
+> > _______________________________________________
+> > Audio/Video Transport Working Group
+> > [email-masked]
+> > https://www1.ietf.org/mailman/listinfo/avt
+> > 
+> 
+> _______________________________________________
+> Audio/Video Transport Working Group
+> [email-masked]
+> https://www1.ietf.org/mailman/listinfo/avt
+> 
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Chuck Harrison <[email-masked]>
Date: Thu, 07 Nov 2002 19:21:27 -0800

Hi, Gary,

Section 6 of draft-ietf-avt-uncomp-video-01.txt starts on this.
The two citations there (SPTE 286M and ISO CD22028-1) are worth
a gander. 286M covers a lot of ground in the predefined header
fields, and CD22028-1 has some good ideas for complete color
specifications but is not yet reduced to practice.

286M predates the unified SMPTE metadata dictionary, and might
best be used for inspiration rather than as a direct model.

Clearly the range of possible SDP parameters is pretty wide.

Cheers,
  Chuck

Gary Sullivan wrote:
> [...]