Subject: Re: [AVT] draft-ietf-avt-mpeg4-simple-04.txt and video packets

From: [email-masked]
Date: Tue, 12 Nov 2002 18:42:42 +0100

Julien,

Your client can tell using the RTP time stamps:
it does not change for packets transporting fragments of the same AU.

regards,

Philippe Gentric
Software Architect
Philips MP4Net
[email-masked]
http://www.mpeg-4.philips.com

                      "Julien Boeuf"                                                                                                   
                      <julien@resonate             To:  <[email-masked]>                                                                 
                      -mp4.com>                    cc:  (bcc: Philippe Gentric/MP4-SUR/CE/PHILIPS)                                     
                      Sent by:                     Subject:   [AVT] draft-ietf-avt-mpeg4-simple-04.txt and video packets               
                      [email-masked]                                                                                                 
                      rg                           Classification:                                                                     

                      12/11/2002 15:19                                                                                                 

Hi,

I'm trying to define a new mode in this draft for transport of MPEG-4 video
using video packets which are mapped to RTP packets.
Here's my problem: I'd like to put the AU numbers in the RTP Packets
otherwise the client won't be able to tell if it has lost a complete AU or
just some video packets as shown in the example below:

Server    Client
AU3
    VP1 -> VP1
    VP2 -> VP2
    VP3 -> VP3

AU4
    VP4 -> LOST
    VP5 -> LOST

AU5
    VP6 -> LOST
    VP7 -> VP7

AU6
    VP8 -> VP8
...

I wish I could use the AU-Index field in the AU-Header part but it is said
that this one is associated with the associated Access Unit (fragment) and
if I understand well, in my case, this one is redundant with the Sequence
Number of the packet. Am I right? If so, I think I can use the
auxiliary-data to do what I want.

I have another question regarding the use of this draft for scalable video.
It would be nice, I think, to have another SDP Parameter which indicated the
layer of the video for a particular rtpmap. Would this be possible?

Thanks a lot,

    Julien.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Julien Boeuf" <[email-masked]>
Date: Tue, 12 Nov 2002 20:53:04 +0100

Hi Philippe,

----- Original Message -----
From: <[email-masked]>
To: "Julien Boeuf" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, November 12, 2002 6:42 PM
Subject: Re: [AVT] draft-ietf-avt-mpeg4-simple-04.txt and video packets

| Julien,
|
| Your client can tell using the RTP time stamps:
| it does not change for packets transporting fragments of the same AU.
Sorry if I did not explain well. In my example, if you just use the
RTPTimeStamps, the client has no way to see that he actually lost AU4... In
video, generally, the AUs haven't got the same duration (cts(n+1) - cts(n)).
For him AU4 and AU5 can be the same AU. Am I right or missing something?

Thanks,

    Julien.

|
| Hi,
|
| I'm trying to define a new mode in this draft for transport of MPEG-4
video
| using video packets which are mapped to RTP packets.
| Here's my problem: I'd like to put the AU numbers in the RTP Packets
| otherwise the client won't be able to tell if it has lost a complete AU or
| just some video packets as shown in the example below:
|
| Server    Client
| AU3
|     VP1 -> VP1
|     VP2 -> VP2
|     VP3 -> VP3
|
| AU4
|     VP4 -> LOST
|     VP5 -> LOST
|
| AU5
|     VP6 -> LOST
|     VP7 -> VP7
|
| AU6
|     VP8 -> VP8
| ...
|
| I wish I could use the AU-Index field in the AU-Header part but it is said
| that this one is associated with the associated Access Unit (fragment) and
| if I understand well, in my case, this one is redundant with the Sequence
| Number of the packet. Am I right? If so, I think I can use the
| auxiliary-data to do what I want.
|
| I have another question regarding the use of this draft for scalable
video.
| It would be nice, I think, to have another SDP Parameter which indicated
the
| layer of the video for a particular rtpmap. Would this be possible?
|
| Thanks a lot,
|
|     Julien.
|
|
|
|
| _______________________________________________
| Audio/Video Transport Working Group
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/avt
|
|
|
|
| _______________________________________________
| Audio/Video Transport Working Group
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/avt
|