Subject: [AVT] RTP without RTCP & Lip Sync

From: "Tom Morrison - Columbus" <[email-masked]>
Date: Wed, 4 Dec 2002 12:38:21 -0500

I have been following this conversation (and
have gone back into the archives to try to 
figure something out), and I must've have missed 
something?

I am trying to synchronize H.323 RTP Streams
being "reflected" to non-H.323 Terminals that
can receive these Audio/Video RTP Payloads.

We are having problems with the synchronization
because none of the H.323 endpoints are sending
H.225 MaxSkewIndication and the RTP timestamps
don't seem to correlate well enough for the 
non-H.323 Terminals to get good lip-sync out of 
what is being received.

What am I missing. Is there an additional step needed
before the "reflection" occurs (like some type of
clock skew calculation). Is there a "single" way
to determine this?

I am confused and would appreciate some clarification
(and some pointes to the <MWPP "implementation guidelines>
that John Lazzaro has indicated he is working on)?

thank you for any insight you have!

Sincerely,

Tom Morrison

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Stephen Casner <[email-masked]>
Date: Mon, 9 Dec 2002 19:49:20 -0800 (PST)

> non-H.323 Terminals to get good lip-sync out of

How are the RTP timestamps being correlated?  You didn't mention it in
the body of your message, but your subject line suggests that no RTCP
packets are being sent.  The timestamps in RTCP Sender Report packets
are the means by which the timestamps should be correlated.

> clock skew calculation). Is there a "single" way

If the streams (including timestamps) are not being modified by the
reflection, then I don't see how it introduces any problem.  If the
delay through the reflector is not the same for audio and video then
systems that try to synchronize simply based on the arrival time of
the packets are going to be out of sync.

                                                        -- Steve