Subject: RE: [AVT] New draft-ietf-avt-mpeg4-simple-07

From: Franceschini Guido <[email-masked]>
Date: Wed, 26 Feb 2003 11:27:11 +0100

Jan,
 
unfortunately I have to disagree with the text you modified with respect to Colin's text.
I am fine with supporting early implementations, but the wording used is, IMHO, not suitable. More specifically you wrote:
 
   If the "constantDuration" parameter is not present, then Access 
   Units are assumed to have a variable duration, unless the AU-Index 
   is present and coded with the value 0 in each RTP packet. 
 
How can a receiver implement the rule above? Should it observe 1, 10, 1000 or infinite packets before determining that the "AU-Index is present and coded with the value 0 in each RTP packet" ?
 
What is the exact legacy that you want to support ? Maybe there is a different mechanism to support it. For example, a specific mode definition might IMPLY a specific "constantDuration" value, without writing this explicitely in the SDP.
Best regards

Guido Franceschini 

TILAB - Multimedia Division 
Via G.Reiss Romoli 274 
I-10148 Torino, Italy 
tel + 39 011 228 6137 
fax + 39 011 228 6299 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 26, 2003 3:03 AM
To: [email-masked]
Cc: [email-masked]
Subject: [AVT] New draft-ietf-avt-mpeg4-simple-07

Dear all, 

This is to let you know that I just submitted draft-ietf-avt-mpeg4-simple-07 for upload to the IETF. For your convenience I attached the draft to this email. 

Compared to -06 there are several editorial improvements. In addition, all comments provided by Colin are incorporated with one small difference. Colin suggested the following text on interleaving in 3.2.3.2 (page 17): 

    If the "constantDuration" parameter is not present, then Access Units
   are assumed to have a variable duration. In this case, the transmitter
   MUST use the AU-Index to encode the index information required for
   re-ordering, and the receiver MUST use that value to determine the
   index of the first AU in the RTP packet. ... 

I changed this to the following text, in order to accomodate "early implementations" that do not use the constantDuration parameter when transmitting constant duration AUs. 

   If the "constantDuration" parameter is not present, then Access 
   Units are assumed to have a variable duration, unless the AU-Index 
   is present and coded with the value 0 in each RTP packet. When 
   transmitting Access Units of variable duration, then the 
   "constantDuration" parameter MUST NOT be present, and the 
   transmitter MUST use the AU-Index to encode the index information 
   required for re-ordering, and the receiver MUST use that value to 
   determine the index of each AU in the RTP packet. ... 

From my perspective the document is ready now. All known comments are incorporated (Colin and Steve thanks for your help !) and therefore I think we are done, unless any further issues are identified. 

Best regards / Groeten,

Jan 

-----------------------------------------------------------
Jan van der Meer
Philips - MP4Net
Prof Holstlaan 4
Building WDB-1
P.O. Box 80021
5600 JZ Eindhoven
The Netherlands
Phone +31 402 735 774
Fax +31 402 735 545

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]. Thank you
====================================================================

---

From: Colin Perkins <[email-masked]>
Date: Wed, 26 Feb 2003 10:18:32 -0500

Guido,

--> Franceschini Guido writes:
>I am fine with supporting early implementations, but the wording used 
>is, IMHO, not suitable. More specifically you wrote:
>
>How can a receiver implement the rule above? Should it observe 1, 10, 
>1000 or infinite packets before determining that the "AU-Index is 
>present and coded with the value 0 in each RTP packet" ?

One packet is sufficient.  If the Access Units have variable duration, the
AU-Index will never be zero, if they have fixed duration it will always be
zero. The rest of the paragraph you quoted makes this explicit.

>What is the exact legacy that you want to support ? Maybe there is a 
>different mechanism to support it. For example, a specific mode 
>definition might IMPLY a specific "constantDuration" value, without 
>writing this explicitely in the SDP.

Not if it wishes to comply with this specification.

Colin
_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt