Subject: [AVT] RTCP unicast feedback for measurement applications?

From: Fiandra Riccardo <[email-masked]>
Date: Mon, 3 Feb 2003 11:23:25 +0100

Gents,
I was interested in the "RTCP Extensions for Single-Source Multicast
Sessions with Unicast Feedback" draft.
Actually, I was wondering if it is also targeted to have a very large and
distribuited network measurement framework.
Where multicast receivers (thousands) use RTCP to send report to a
measurement collector about packet loss, jitter, or other.
I see really many advantages on that for e2e measurements, especially in a
scenario where thousands of receivers are always connected to the network
and cannot send multicast (common scenario for an operator, even without
SSM...).

My questions are:
-Was this a scenario of application when writing the draft?
-In this case, could I use the RTCP channel multicasted to the receivers to
control them?
-Do you see any extension possible also for ptp rtp connections (forward
rtcp reports to another device?)

Tanx in advance for any feedback

Riccardo

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 3 Feb 2003 09:18:15 -0500

Hello;

I see no reason why you could not use unicast RTCP for measurement 
applications

- we do this already with our prototype unicast RTCP
- the NLANR multicast beacon uses unicast reports (although not rtcp, 
alas) to
respond back to the beacon server, which is how

http://beaconserver.accessgrid.org:9999/

gets generated.

> -Was this a scenario of application when writing the draft?

It was in my mind when reviewing it. In any case, Internet protocols are 
not restricted
to uses thought of in advance !

> -In this case, could I use the RTCP channel multicasted to the 

Why not ?

> rtcp reports to another device?)

The danger here is denial of service attacks (if you are sending 50 mbps 
of reports to somewhere,
and I can re-direct this to point somewhere else, we have  a big DOS 
problem).

> Tanx in advance for any feedback
                                  Regards
                                  Marshall Eubanks

T.M. Eubanks
Multicast Technologies, Inc.
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
  Status of Multicast on the Web  :
  http://www.multicasttech.com/status/index.html

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 3 Feb 2003 09:18:15 -0500

Hello;

gets generated.

Why not ?

                                  Regards
                                  Marshall Eubanks

T.M. Eubanks