Subject: Re: [AVT] I-D ACTION:draft-ietf-avt-rtp-h264-05.txt

From: [email-masked]
Date: Tue, 27 Apr 2004 13:41:44 +0200

AVTers, authors,

I have found this draft pretty advanced, I have a few questions

there is the text related to parameter sets that I do not fully understand,
it is distributed across 1.2 (which is fine) and 6.1 at 8.4
and I suspect section 6.1 needs to be revisited/merged
due to the new dedicated section 8.4 ?

both in section 6.1 and section 8.4 there is the concept of:

"an RTP session whose parameter sets were already changed by control protocol messages during the lifetime of the RTP session"

Now apart from the fact that there seem to be a duplication here between 6.1 and 8.4,
I have to admit this got me a headache to understand (and actually I am not sure I got it ?)

Can we strcuture this a bit by explaining that there are 3 ways to send parameters sets:

(1) out of band before RTP session starts

(2) out of band during RTP session

(3) in band (of course, during RTP session)

If yes , Would it be possible that what you want to express is that:

(A) parameter sets are transmitted using either (1) or (3) or (1+2) or (1+3),

(B) (1) and (1+2) are the RECOMMENDED way to do it

(C) (3) and (1+3) are only for some specific applications and are NOT RECOMMENDED

(D) in all cases (2) and (3) MUST NOT be used together in the same session

Is this is what you wanted to express ?

regards,

PS: in section 8.4 there is a typo in the word "specificaion"

Philippe Gentric
Chief Architect
Philips Software
[email-masked]
http://www.software.philips.com

                                                                                                                                       
                                                   To:   [email-masked]                                                         
                                                   cc:   [email-masked]                                                                  
                                                    (bcc: Philippe Gentric/SUR/PSW/PHILIPS)                                            
                                                   Subject:    [AVT] I-D ACTION:draft-ietf-avt-rtp-h264-05.txt                         
               [email-masked]                                                                                                
                                                   Classification:                                                                     
               Sent by:                                                                                                                
               [email-masked]                                                                                                      
                                                                                                                                       
               26/04/2004 21:25                                                                                                        

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Working Group of the IETF.

             Title                         : RTP payload Format for H.264 Video
             Author(s)         : S. Wenger, et al.
             Filename          : draft-ietf-avt-rtp-h264-05.txt
             Pages                         : 68
             Date                    : 2004-4-26

This memo describes an RTP Payload format for the ITU-T
Recommendation H.264 video codec.  This codec was designed as a
joint project of the Video Coding Experts Group (VCEG) of ITU-T and
the Moving Picture Experts Group (MPEG) of ISO/IEC.  Recommendation
H.264 was approved by ITU-T on May 2003, and the approved draft
specification is available for public review.  ISO/IEC
International Standard 14496-10 will be technically identical to
ITU-T Recommendation H.264.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-h264-05.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
             "get draft-ietf-avt-rtp-h264-05.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
             [email-masked].
In the body type:
             "FILE /internet-drafts/draft-ietf-avt-rtp-h264-05.txt".

NOTE:        The mail server at ietf.org can return the document in
             MIME-encoded form by using the "mpack" utility.  To use this
             feature, insert the command "ENCODING mime" before the "FILE"
             command.  To decode the response(s), you will need "munpack" or
             a MIME-compliant mail reader.  Different MIME-compliant mail readers
             exhibit different behavior, especially when dealing with
             "multipart" MIME messages (i.e. documents which have been split
             up into multiple messages), so check your local documentation on
             how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
ftp://[email-masked]/internet-drafts/draft-ietf-avt-rtp-h264-05.txt

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 30 Apr 2004 17:33:39 +0200

Hi Philippe,

Thanks for the review. Below I try to answer your questions.

> due to the new dedicated section 8.4 ?

I can agree that at least the  following bullet:

"   o Sequence and picture parameter set NAL units MUST NOT be sent in
       an RTP session whose parameter sets were already changed by
       control protocol messages during the lifetime of the RTP session.

       Informative note: In many applications, parameter sets can be
       conveyed before establishing an RTP session by using the optional
       parameter-sets MIME parameter in an SDP description.  Thus, when
       no control protocol is used to convey parameter sets during the
       RTP session, the use of sequence and picture parameter set NAL
       units within the RTP packet stream is allowed in these
       applications."

should be removed in favour of the new section 8.4. I think we missed to 
review this fully for consistency. I do think that the next bullet 
concerning handling of NALUs in gateways belong here, although it talks 
a little bit about parameter sets.

> "an RTP session whose parameter sets were already changed by control 
> protocol messages during the lifetime of the RTP session"
> 

Yes, that is what we try to express in section 8.4. Plus a few things 
other in regards to how to add parameter sets to avoid problems, and the 
usage of reliable protocols. I will take your input that it is hard to 
read and try to structure the section better.

> PS: in section 8.4 there is a typo in the word "specificaion"

I will take care of this.

If more people has comments they are appreciated if they can be sent no 
later than monday. I will try to do a update in the beginning of the 
next week, and submit that as soon as possible.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]