Subject: RE: [AVT] Comments on draft-ietf-avt-hc-mpls-reqs-00.txt

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 29 Apr 2004 13:53:33 +0200

Colin, Kristofer, and others,

> > Comment 1:
> > **********
> > When reordering is discussed in section 3, it is not made clear how 
> > the HC scheme is supposed to handle reordering. Is the requirement 
> > that the decompressor should be able to correctly decompress all 
> > reordered packets, or is it enough that it can ensure no 
> > incorrectly decompressed packets will be forwarded, i.e. avoid
> > context damage? I assume that correct decompression is the intention,
> > but it could be made more clear.
> 
> I would suggest that the requirement is that packet 
> reordering MUST NOT cause incorrectly decompressed packets
> to be forwarded on from the decompressor. We would clearly
> like a solution that lets the decompressor correctly
> decompress reordered packets, but that's an optimisation
> rather than a hard requirement.

What does a use of MUST NOT in this context actually mean? Does
it mean the compressed (or uncompressed) header must be protected
by a CRC of infinite size? Seriously, I agree with the content of
your comment, not forwarding incorrect packets is the hard 
requirement. However, this example just makes me more convinced we
should not use 2119 keywords in this document, but instead write
what we actually mean our intentions are. 

Cheers,
/L-E

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Thu, 29 Apr 2004 13:11:34 +0100

> what we actually mean our intentions are.

In this context, I really don't care whether the draft says "MUST NOT" 
or "must not"... The intent is clear in either case.

Colin