Subject: RE: [AVT] The use of RFC 2190 vs. RFC 2429 for transporting H.263 video?

From: "Gary Sullivan" <[email-masked]>
Date: Sun, 28 Nov 2004 20:55:10 -0800

Polycom & Tandberg -- you probably know how to answer your company-specific part of this.

It is probably true that there are still some systems that use the legacy format, so it may still be useful to support RFC 2190 in a system (in fact it might even be mandatory in ITU-T systems, I'm not sure).  However, it is also clear that RFC 2429 is preferred.

Best Regards,

Gary Sullivan

+> -----Original Message-----
+> From: [email-masked] [mailto:[email-masked]] On 
+> Behalf Of Ross Finlayson
+> Sent: Friday, November 26, 2004 1:41 PM
+> To: [email-masked]
+> Subject: [AVT] The use of RFC 2190 vs. RFC 2429 for 
+> transporting H.263 video?
+> 
+> The first paragraph of RFC 2429 notes that it is preferred 
+> over the older 
+> RFC 2190 payload format - even for transporting the 1996 
+> version of H.263.
+> 
+> However, today I read a claim that several legacy H.323 
+> videoconferencing 
+> systems (the names Polycom and Tandberg were mentioned) 
+> still use the older 
+> RFC 2190 payload format when sending H.263, and that some (perhaps 
+> different) videoconferencing systems will receive only the 
+> RFC 2190 payload 
+> format, and do not understand the RFC 2429 payload format 
+> ("video/H263-1998") at all.
+> 
+> Can anyone confirm (or deny) this claim?  Basically, I'd 
+> like to know 
+> whether RFC 2190 is something that I (as an implementor of RTP-based 
+> software) should still be concerned with, or whether I can 
+> get away with 
+> supporting only RFC 2429?
+> 
+> 	Ross.
+> 
+> 
+> _______________________________________________
+> Audio/Video Transport Working Group
+> [email-masked]
+> https://www1.ietf.org/mailman/listinfo/avt
+> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Dave Lindbergh <[email-masked]>
Date: Mon, 29 Nov 2004 08:55:32 -0500

Hi all,

Speaking for Polycom, our equipment does both RFC 2190 and RFC 
2429.  Mostly RFC 2190 is used when transporting baseline H.263.

The main reason we continue to do this is to support older gear that did 
RFC 2190 only.

--Dave

At 11:55 PM 11/28/2004, Gary Sullivan wrote:
>It is probably true that there are still some systems that use the legacy 
>format, so it may still be useful to support RFC 2190 in a system (in fact 
>it might even be mandatory in ITU-T systems, I'm not sure).  However, it 
>is also clear that RFC 2429 is preferred.
>
>Best Regards,
>
>Gary Sullivan
>

----------
Dave Lindbergh
Polycom, Inc.
100 Minuteman Road
Andover MA 01810  USA
Voice: +1 978 292 5366
Email: [email-masked]
H.320, H.323 video by arrangement