Subject: [AVT] Exceptional treatment of E bit for state events in 2833bis

From: Tom Taylor <[email-masked]>
Date: Wed, 10 Nov 2004 14:51:32 -0500

draft-ietf-avt-rfc2833bis-05.txt section 2.5.1.2 contains the following text 
regarding the setting of 'E' (end) bits for events that are states:

       Sending of a packet with the "E" bit set is OPTIONAL if the packet
       reports two events which are defined as mutually exclusive states, or
       if the final packet for one state is immediately followed by a packet
       reporting a mutually exclusive state.  (For events defined as states,
       the appearance of a mutually exclusive state implies the end of the
       previous state.)

This is a small optimization at the potential expense of a bunch of extra code.  I 
really don't see it as worth the effort.  I propose to delete it unless someone 
makes a good case otherwise.

Comments?

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel Networks
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Kevin A. Noll" <[email-masked]>
Date: Wed, 10 Nov 2004 15:54:26 -0500

I agree with removing this paragraph. The optimization doesn't get you
anything considering that you still have to handle the case where the
packet(s) with the E-bit set are lost in transit.

--kan--
--
Kevin A. Noll, KD4WOZ
CCIE, CCDP
Perfect Order, Inc.		
[email-masked]
717-796-1936

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom
Taylor
Sent: Wednesday, November 10, 2004 2:52 PM
To: [email-masked]
Subject: [AVT] Exceptional treatment of E bit for state events in 2833bis

This is a small optimization at the potential expense of a bunch of extra
code.  I 
really don't see it as worth the effort.  I propose to delete it unless
someone 
makes a good case otherwise.

Comments?