Subject: [AVT] need some help

From: rahul agrawal <[email-masked]>
Date: Sat, 6 Nov 2004 07:15:42 +0000 (GMT)

sir/mam,

        this is request that please you help me.
        I am studying in M.Tech and working on VoIP.
        I am trying to improve voice quality,so for
        this i measure the voice quality, howmuch 
        it will improve, so take  MOS(mean opinion  
        score), i am trying to implement subjective  
        method that is one human listeners panel  
        listen quality, and give their opinion on.  
        for this  i need some persons which know 
        about this.that means i cant implement this  
         method.

        i found first SNR for voice siganland  
        compare , but its not  relaible ao pls tell 
        me another method to measure voice quality 
        that its .

[email-masked] wrote:Send avt mailing list submissions to
[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
https://www1.ietf.org/mailman/listinfo/avt
or, via email, send a message with subject or body 'help' to
[email-masked]

You can reach the person managing the list at
[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of avt digest..."

Today's Topics:

1. Re: Comments on draft-ietf-avt-rtcp-xr-mib-00.txt
(Magnus Westerlund)

----------------------------------------------------------------------

Message: 1
Date: Fri, 05 Nov 2004 13:56:30 +0100
From: Magnus Westerlund 
Subject: Re: [AVT] Comments on draft-ietf-avt-rtcp-xr-mib-00.txt
To: "Romascanu, Dan \(Dan\)" 
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii; format=flowed

Hi Dan,

I have a comment on the below.

Romascanu, Dan (Dan) wrote:
> 
> 3. At the last IETF meeting we discussed about the relationship between 
> RTCP XR MIB and RAQMON, and decided to include a 'Relationship to 
> RAQMON' section, which is now only a place-holder. I suggested to the 
> editors the following text:
> 
> */'The Real-time Application QoS monitoring (RAQMON) Framework 
> [RAQMON-FRAMEWORK - provide reference here to_ 
> _] 
> defines an architecture that extends the Remote Monitoring (RMON) family 
> of applications for monitoring of application QoS in real-time, and an 
> extensible data model with objects carried between RAQMON data sources 
> and RAQMON collectors. The RAQMON work is more generic, and 
> complementary in concept to RTCP-XR, covering a wider range of 
> applications running concurrently, while RTCP-XR focuses on QoS 
> monitoring of media traffic in VoIP./*//

Although one of the RTCP XR types has received substantially more 
interest, the RTCP XR is not limited to VoIP. It is a general framework 
which is currently populated with the following different reporting blocks:
4.1. Loss RLE Report Block. . . . . . . . . . . . . . . . . . 9
4.2. Duplicate RLE Report Block . . . . . . . . . . . . . . . 16
4.3. Packet Receipt Times Report Block. . . . . . . . . . . . 18
4.4. Receiver Reference Time Report Block . . . . . . . . . . 20
4.5. DLRR Report Block. . . . . . . . . . . . . . . . . . . . 21
4.6. Statistics Summary Report Block. . . . . . . . . . . . . 22
4.7. VoIP Metrics Report Block. . . . . . . . . . . . . . . . 25

Thus, I can also provide some more comments of the document:

MW1: The XR MIB needs to be defined in such a way that it can easily be 
extended if more report types are created.

MW2: THE XR MIB should define structures for all the currently defined 
XR report blocks.

MW3: The security consideration section also seems to be a bit strange, 
is it mostly copy and pasted from the RTP MIB?

MW4: rtcpXrVoipSessionIdentifier OBJECT-TYPE
SYNTAX OCTET STRING
STATUS optional
DESCRIPTION
"Unique identifier for this session. Where a billing record
correlation identifer is not available for a particular call,
another identifier such as SSRC can be used."
::= { rtcpXrVoipEntry 3 }

How can the SSRC be a session identifier?

MW5: How is sessions with more than a single destination handled?

MW6: rtcpXrVoipVocoderType OBJECT-TYPE
SYNTAX OCTET STRING
STATUS current
DESCRIPTION
"Vocoder type used on this call."
::= { rtcpXrVoipEntry 10 }

rtcpXrVoipFrameSize OBJECT-TYPE
SYNTAX INTEGER
STATUS current
DESCRIPTION
"Companion information to vocoder type. This represents the
size of the frames within the RTP packets at the time the
information is capture."
::= { rtcpXrVoipEntry 11 }

First, is multiple instances allowed? A session may consist of multiple 
media codecs and/or configurations of a codec. Also how is the vocoder 
type expressed. What is the string? The RTP payload MIME type with its 
parameters? Maybe one should consider to make this definition a bit more 
generic to fit any media encoding format? Thus it can potentially be 
re-used?

MW7: rtcpXrVoipSampleRate OBJECT-TYPE
SYNTAX OCTET STRING
STATUS current
DESCRIPTION
"Companion information to vocoder type. This represents the
rate at which the frames where sampled.
::= { rtcpXrVoipEntry 12 }

Which rate are you talking about here? The audio sample rate, or the 
rate with which frames are produced?

MW8: All references can not be normative, a lot of these must be 
informative ones.

MW9: Run a spellchecker over the description texts.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB | Phone +46 8 4048287
Torshamsgatan 23 | Fax +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

------------------------------

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

End of avt Digest, Vol 7, Issue 6
*********************************

Yahoo! India Matrimony: Find your life partneronline.

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Alan Clark" <[email-masked]>
Date: Sat, 6 Nov 2004 07:07:40 -0500

Rahul

You want to run an ACR subjective listening test?  You can start by
downloading (for free) ITU-T P.800 from the www.itu.int web site.  You would
also need suitable listening material .. you can either purchase this from
the ITU, download for free from the Open Speech Repository (hosted on
www.voiptroubleshooter.com) or record some material yourself.

Regards

Alan

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of rahul
agrawal
  Sent: Saturday, November 06, 2004 2:16 AM
  To: [email-masked]
  Subject: [AVT] need some help

  sir/mam,