Subject: [AVT] Comments on draft-ietf-avt-rtp-3gpp-timed-text-07.txt

From: "Rey Jose" <[email-masked]>
Date: Thu, 2 Dec 2004 12:35:10 +0100

Colin,

Thanks for the comments!

I have a question. You say:

> 
> "Section 3 notes that the RTP timestamp rate is the value of 
> the "timescale" parameter in the Media Header Box. Because 
> the timestamp rate affects the synchronisation accuracy and 
> RTCP statistics, I think this draft needs to give guidance on 
> how that parameter is chosen when the file is constructed."
> 

Part of this concern is addressed in the text describing live-streaming with a quote from RTP:

"The resolution of the clock MUST be sufficient for the desired synchronization accuracy and for measuring packet arrival jitter (one tick per video frame is typically not sufficient)" 

Now, I want to understand better what's being asked: 

1.- Regarding the synchronisation of different RTP streams: is this actually a matter to be dealt with in the payload format? Isn't this rather a matter of the creator of the 3GP file?? I.e. in a 3GP file containing several tracks, these should be synchronised anyway so no special care is taken for RTP. For the case of a text track sent together with other RTP streams (not coming from the same 3GP file), would the quote above be enough? 

2.- Regarding RTCP statistics, for all cases, why is the quote above not enough? 

If this is not sufficient, I'll be glad to add more text on this. Can you or someone point me to a document that deals with the same/similar problem for getting a better idea of what's asked? 

Thanks,

---------------------------------------------
Jose Rey              mailto:[email-masked]
P R D C G - Panasonic R&D Center Germany GmbH
Phone/Fax: +49(0)6103766-134/166
--------------------------------------------- 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 7 Dec 2004 12:52:35 +0000

Jose,

On 2 Dec 2004, at 11:35, Rey Jose wrote:
> "The resolution of the clock MUST be sufficient for the desired 
> synchronization accuracy and for measuring packet arrival jitter (one 
> tick per video frame is typically not sufficient)"
>
> 1.- Regarding the synchronisation of different RTP streams: is this 
> actually a matter to be dealt with in the payload format? Isn't this 
> rather a matter of the creator of the 3GP file?? I.e. in a 3GP file 
> containing several tracks, these should be synchronised anyway so no 
> special care is taken for RTP. For the case of a text track sent 
> together with other RTP streams (not coming from the same 3GP file), 
> would the quote above be enough?
>

The quote is enough, but your draft states that it applies only to live 
streaming. You need to restructure the text to make it clear that the 
talk about synchronisation accuracy applies both when choosing a clock 
rate for live streaming, and when creating a 3GPP timed text file.

Colin