Subject: RE: [AVT] Request for WG Last-Call for draft-ietf-avt-rtp-3gpp-timed-text-07.txt

From: "Rey Jose" <[email-masked]>
Date: Thu, 2 Dec 2004 14:43:18 +0100

Colin,

> Section 3.1.2 (first paragraph on page 21) states that a 
> maximum of 64 dynamic SIDX are allowed at any moment, but 
> allows a range of 0-127.  
> Suggest either allowing 127 active values, or reducing the 
> allowable range, or adding an explanatory note to clarify.

This has the following reason: If you allow 127 values, then when a reordered packet with a new sample description arrives, it is discarded.  E.g. last packet received is SIDX=5, thus the only invalid value would be SIDX=6, e.g. Now a reordered packet arrives with a new description, SIDX=9. It will be mistakingly discarded, because the SIDX=9 is marked "valid" at that moment and the valid sample descriptions shall not be re-written.  Therefore, a "guard interval" is introduced. Agreed it should be rare to use so many sample descriptions but nevertheless, a mechanism is provided for that case. As for the "guard interval" value, we found 64 as 128/2 simple enough while still meeting the expected maximum number of sample descriptions. Besides that, there's no other motivation for choosing 64 or other value. I'll add a similar explanation if that's fine with you into the Annex.  Comments?

Thanks,

José

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Colin Perkins <[email-masked]>
Date: Tue, 7 Dec 2004 12:46:32 +0000

Jose,

On 2 Dec 2004, at 13:43, Rey Jose wrote:
> This has the following reason: If you allow 127 values, then when a 
> reordered packet with a new sample description arrives, it is 
> discarded.  E.g. last packet received is SIDX=5, thus the only invalid 
> value would be SIDX=6, e.g. Now a reordered packet arrives with a new 
> description, SIDX=9. It will be mistakingly discarded, because the 
> SIDX=9 is marked "valid" at that moment and the valid sample 
> descriptions shall not be re-written.  Therefore, a "guard interval" 
> is introduced. Agreed it should be rare to use so many sample 
> descriptions but nevertheless, a mechanism is provided for that case. 
> As for the "guard interval" value, we found 64 as 128/2 simple enough 
> while still meeting the expected maximum number of sample 
> descriptions. Besides that, there's no other motivation for choosing 
> 64 or other value. I'll add a similar explanation if that's fine with 
> you into the Annex.  Comments?

Adding this would be helpful.

Thanks,
Colin