Subject: [AVT] RE: Comments on draft-ietf-avt-rtp-3gpp-timed-text-12.txt

From: "Rey Jose" <[email-masked]>
Date: Wed, 16 Mar 2005 18:41:07 +0100

Magnus,

> "If you mean, if Timed Text is used in an mpeg-4 systems 
> context, yes, there is a spec. nearing completion.
> There is a tentative allocation of streamtype and so on at 
> <http://www.mp4ra.org/object.html>.  And the code-point for 
> 3GPP timed text is defined within the text stream setup. "
> 
> However, I don't see why the ObjectTypeIndication=0x08 used 
> in MPEG-4 systems  should be mentioned here??
> 

Would this satisy your request?

".. , an RTP packet that uses this payload format is identical to and RTP packet using RFC 3640 conveying TTUs according to ISO/IEC 14496-17.  In particular, MPEG-4 Part 17 specifies that when using RFC 3640 for transporting timed text streams, the "streamType" parameter value when shall be 0x0D and the value of the "objectTypeIndication" in "config" shall be 0x08.  "

Cheers,

José

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 17 Mar 2005 07:26:49 +0100

Hi Jose,

See below.

>>3GPP timed text is defined within the text stream setup. "

Is the below mentioned code-points still tentative? In that case it is 
dangerous to mention the actual code-points. Then I would be very 
explicit about what reference to go look up for finding the number.

>>in MPEG-4 systems  should be mentioned here??

The reason is that I would like to be clear on which configuration of 
the RFC 3640 payload format that has an content that matches this 
payload format. Instead of a general hand waving that it is.

> ".. , an RTP packet that uses this payload format is identical to and RTP packet using RFC 3640 conveying TTUs according to ISO/IEC 14496-17.  In particular, MPEG-4 Part 17 specifies that when usin…

Looks reasonable, can you use another word then lower case "shall" to 
indicate that this is the fact? I agree that this should be informative, 
however using the lower case version is easily misunderstood.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]