Subject: RE: [AVT] Follow up to AVT meeting - RTCP XR MIB vs RTP MIB

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Wed, 30 Mar 2005 11:07:50 +0200

Mark,

Installing multiple MIB modules is not a problem, but redundancies should be avoided. If you are already aware about some, you may want to point it specifically to the authors. 

Alan seems to be saying that the RTP MIB and RTCP-XR MIB are completely separate entities and that applications may install and use them independently one of the other. Even if we agree that this is the case, there will be deployment scenarios where both will be used, and we need to avoid redundant objects and ease the usage of the applications that would use both. This is what the 'relationship' section should clarify. 

Regards,

Dan

> -----Original Message-----
> From: Mark Baugher [mailto:[email-masked]]
> Sent: 30 March, 2005 1:26 AM
> To: Romascanu, Dan (Dan)
> Cc: Magnus Westerlund; Alan Clark; Colin Perkins; Amy 
> Pendleton; Avt@Ietf. Org
> Subject: Re: [AVT] Follow up to AVT meeting - RTCP XR MIB vs RTP MIB
> 
> 
> Dan
> On Mar 29, 2005, at 7:23 AM, Romascanu, Dan ((Dan)) wrote:
> 
> > Actually this is not necessarily a bad thing. The MIB module should 
> > reflect what is manageable by SNMP, and this may be a subset of the 
> > whole protocol functionality. The scope is to create SNMP 
> agents that 
> > can be implemented in host, network devices or applications and be 
> > used by management applications for interoperable 
> management. Small is 
> > good in many cases.
> >
> > The question on the table is whether the RTCP-XR MIB and 
> the RTP MIB 
> > have any dependencies.
> 
> My concern is with redundancies and the need to install multiple 
> flavors of RTP MIBs to get a complete protocol-management solution.
> 
> Mark
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Mark Baugher <[email-masked]>
Date: Wed, 30 Mar 2005 07:51:21 -0800

Dan
   I pointed out what I thought were redundancies to Alan yesterday on 
this list.

Mark
On Mar 30, 2005, at 1:07 AM, Romascanu, Dan ((Dan)) wrote:

> Mark,
>
> Installing multiple MIB modules is not a problem, but redundancies 
> should be avoided. If you are already aware about some, you may want 
> to point it specifically to the authors.
>
> Alan seems to be saying that the RTP MIB and RTCP-XR MIB are 
> completely separate entities and that applications may install and use 
> them independently one of the other. Even if we agree that this is the 
> case, there will be deployment scenarios where both will be used, and 
> we need to avoid redundant objects and ease the usage of the 
> applications that would use both. This is what the 'relationship' 
> section should clarify.
>
> Regards,
>
> Dan
>
>
>

---

From: "Alan Clark" <[email-masked]>
Date: Wed, 30 Mar 2005 15:58:57 -0500

Mark

You pointed out yesterday that the two documents have the same section 2.1,
which basically says that they both relate to RTP sessions, senders and
receivers.

There may be a small number of common elements in the tables, for example
source/dest IP address, UDP port and SSRC, however the commonality doesn't
extend much beyond that.  The XR MIB has been designed for a specific
application and a number of implementors have been providing useful
feedback.  We don't want implementors to HAVE to implement the RTP MIB in
order to implement the RTCP XR MIB - if we try and build in any dependencies
then this would be the consequence (which I'm sure you aren't advocating).

I suggest that section 2 of the XR MIB be updated to clarify the
relationship between the two MIBs and if we identify any common objects then
the XR MIB can point out the relationship.

Regards

Alan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Mark Baugher
Sent: Wednesday, March 30, 2005 10:51 AM
To: Romascanu, Dan (Dan)
Cc: Magnus Westerlund; Colin Perkins; Avt@Ietf. Org; Amy Pendleton
Subject: Re: [AVT] Follow up to AVT meeting - RTCP XR MIB vs RTP MIB

Dan

Mark