Subject: RE: [AVT] Audio and Video with TFRC

From: "Phelan, Tom" <[email-masked]>
Date: Mon, 21 Mar 2005 09:47:01 -0500

Hi Alejandro,

See inline ...

Tom Phelan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Alejandro Cabrera Obed
> Sent: Friday, March 18, 2005 1:52 PM
> To: AVT Lista
> Subject: [AVT] Audio and Video with TFRC
> 
> 
> Hi people !!!
> 
> I'm still studying the mechanism to transmit HDTV video over IP, using
> TFRC, with some hypothesis I take.
> 
> But suppose I want to add audio (specifically AC-3 with 386 Kbps),
> Ladan told me I have to create a new RTP independent session, and I
> know I have to synchronize both video and audio sessions with RTCP and
> timestamps.
> 
> But in this scenario I have a question:
> 
> Is it possible to send at the same time unicast video (RTP Payload
> Format for Uncompressed Video) and audio (RTP Payload Format for AC-3
> Streams) and use a separate RTP Profile for TCP Friendly Rate Control
> for both flows in order to get congestion control ??? Or do you know
> about any possible problem ???

I'm afraid I can't parse what you're asking for.  Is it -- Can you send two separate RTP streams, each with its own independent TFRC congestion state?  Yes, of course.  With that, the two streams behave independently, as far as congestion control.  This is an advantage in that the audio stream won't be penalized for the video stream's greater needs, but a disadvantage in that TFRC chooses the tradeoff between audio and video needs.

Or is the question -- Can you send two RTP streams with the same (shared) TFRC congestion state?  I'm not sure how Ladan's RTP profile works for this, but with DCCP, it's a least theoretically possible (we haven't yet specified how RTP is encapsulated in DCCP, but multiple streams in one connection is something I think we should investigate).  With this you'd have the possible disadvantage that audio will be penalized for video's greater needs, but you'd also be able to flexibly trade off the total allowed rate between audio and video.

> 
> Special thanks again !!! Greetings !!!
> 
> -- 
> Alejandro Cabrera Obed
> [email-masked]
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/avt
> 

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Alejandro Cabrera Obed <[email-masked]>
Date: Mon, 21 Mar 2005 12:52:42 -0300

OK Tom, thanks....my scenario is the first you describe: "send two
separate RTP streams, each with its own independent TFRC congestion
state".

I'd use two buffers -one for video and the other for audio- and then I
have to do the synchronization between this two media flows. But I
thought maybe the TFRC applied in each flow can affect the correct
media synchronization, because the video stream is more sensible to
congestion than the audio stream, but maybe this problem can be solved
by adjusting the audio y video buffer sizes.

Greetings,

Alejandro

-- 
Alejandro Cabrera Obed
[email-masked]