Subject: [AVT] [Fwd: Last Call: draft-wing-behave-symmetric-rtprtcp (Common Local Transmit and Receive Ports (Symmetric RTP)) to Informational RFC]

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Feb 2007 22:09:19 +0100

Hi,

This document has been raised before in both AVT and BEHAVE WG. I have 
chosen to AD sponsor this document for publication as informational 
status because it seems to be of general interest. You have 4 weeks to 
provide any comments on the document.

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

Subject: Last Call: draft-wing-behave-symmetric-rtprtcp (Common Local Transmit and Receive Ports (Symmetric RTP)) to Informational RFC
From: The IESG <[email-masked]>
To: IETF-Announce <[email-masked]>
Date: Mon, 12 Feb 2007 15:44:51 -0500
List-Id: ietf-announce.ietf.org

The IESG has received a request from an individual submitter to consider
the following document:

- 'Common Local Transmit and Receive Ports (Symmetric RTP) '
   <draft-wing-behave-symmetric-rtprtcp-01.txt> as an Informational RFC

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2007-03-12. Exceptionally, 
comments may be sent to [email-masked] instead. In either case, please 
retain the beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-wing-behave-symmetric-rtprtcp-01.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=13165&rfc_flag=0

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf-announce

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 12 Feb 2007 15:27:55 -0600

Thanks for doing this Magnus.

I have one comment. I think we should add as a last statement at the end
of 
section 3 "Recommended usage" that says something like:

"It is therefore RECOMMENDED that symmetric RTP and symmetric RTCP
always 
be used for bi-directional RTP media streams."

Otherwise, the draft doesn't specifically recommend anything.

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]] 
> Sent: Monday, February 12, 2007 13:09
> To: IETF AVT WG; [email-masked]
> Subject: [BEHAVE] [Fwd: Last Call: 
> draft-wing-behave-symmetric-rtprtcp (Common Local Transmit 
> and Receive Ports (Symmetric RTP)) to Informational RFC]
> 
> Hi,
> 
> This document has been raised before in both AVT and BEHAVE 
> WG. I have chosen to AD sponsor this document for publication 
> as informational status because it seems to be of general 
> interest. You have 4 weeks to provide any comments on the document.
> 
> Magnus Westerlund
>

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 13 Feb 2007 21:17:08 +0100

There has been raised a comment that this document should contain a 
normative recommendation on using symmetric ports. However to make this 
happen the document would need to be a BCP. I am willing to consider 
this but would like to have AVT and Behave WG participant's view on 
doing this before progressing down that road and updating the IETF last 
call. So please provide comments by Tuesday 20th of Feb on this issue.

Best Regards

Magnus

Magnus Westerlund skrev:
> ------------------------------------------------------------------------
> 
> Ämne:
> Last Call: draft-wing-behave-symmetric-rtprtcp (Common Local Transmit 
> and Receive Ports (Symmetric RTP)) to Informational RFC
> Från:
> The IESG <[email-masked]>
> Datum:
> Mon, 12 Feb 2007 15:44:51 -0500
> Till:
> IETF-Announce <[email-masked]>
> 
> Till:
> IETF-Announce <[email-masked]>
> 
> 
> ------------------------------------------------------------------------
> 
> Behave mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/behave

-- 

Magnus Westerlund

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 13 Feb 2007 12:44:07 -0800

Per Francois's suggestion, the following new text would be placed at the end
of section 3 of draft-wing-behave-symmetric-rtprtcp:

  "For these reasons it is RECOMMENDED that symmetric RTP and 
   symmetric RTCP always be used for bi-directional RTP media 
   streams." 

-d

> Sent: Tuesday, February 13, 2007 12:17 PM
> To: Magnus Westerlund
> Cc: [email-masked]; IETF AVT WG
> Subject: Re: [BEHAVE] [Fwd: Last Call: 
> draft-wing-behave-symmetric-rtprtcp(Common Local Transmit and 
> Receive Ports (Symmetric RTP)) toInformational RFC]
> 
> WG. I have

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 13 Feb 2007 13:26:22 -0800

Some NATs will close down NAT bindings after some number of seconds if there
is only outside->inside traffic and no inside->outside traffic on that same
5-tuple.  If you were to encounter such a NAT with the optimization you
describe below, the RTP traffic from the TURN server would stop after
awhile.  I suppose you could work around that NAT behavior, and still do
this optimization technique, if you were to send some sort of outgoing
traffic (inside->outside) to your own TURN server.

-d

> From: David Barrett [mailto:[email-masked]] 
> Sent: Tuesday, February 13, 2007 12:55 PM
> To: 'Dan Wing'; 'Magnus Westerlund'
> Cc: [email-masked]; 'IETF AVT WG'
> Subject: RE: [BEHAVE] [Fwd: Last 
> Call:draft-wing-behave-symmetric-rtprtcp(Common Local 
> Transmit andReceive Ports (Symmetric RTP)) toInformational RFC]
> 
> Though I think it's still a good recommendation, one thing I 
> found when
> working on iGlance was the case where two users were each 
> behind a different
> TURN relay server.
> 
> With symmetric RTP (if I understand correctly), for me to 
> send a packet to
> you I need to send it up to my TURN server, which forwards it 
> to your TURN
> server, which sends it to you.  Ideally I'd send it to your 
> TURN server
> direct, and cut out one relay.
> 
> The problem with this is it means our RTP isn't strictly 
> symmetric -- I
> receive from one place (my TURN server), but send to another 
> (your TURN
> server).
> 
> Am I misunderstanding how symmetric RTP works?  Perhaps this 
> is too minor a
> point to discuss here, however.
> 
> -david
> 
> > From: Dan Wing [mailto:[email-masked]]
> > Sent: Tuesday, February 13, 2007 12:44 PM
> > To: 'Magnus Westerlund'
> > Cc: [email-masked]; 'IETF AVT WG'
> > Subject: RE: [BEHAVE] [Fwd: Last Call:draft-wing-behave-symmetric-
> > rtprtcp(Common Local Transmit andReceive Ports (Symmetric RTP))
> > toInformational RFC]
> > 
> > Per Francois's suggestion, the following new text would be 
> placed at the
> > end

---

From: "David Barrett" <[email-masked]>
Date: Tue, 13 Feb 2007 12:54:40 -0800

Though I think it's still a good recommendation, one thing I found when
working on iGlance was the case where two users were each behind a different
TURN relay server.

With symmetric RTP (if I understand correctly), for me to send a packet to
you I need to send it up to my TURN server, which forwards it to your TURN
server, which sends it to you.  Ideally I'd send it to your TURN server
direct, and cut out one relay.

The problem with this is it means our RTP isn't strictly symmetric -- I
receive from one place (my TURN server), but send to another (your TURN
server).

Am I misunderstanding how symmetric RTP works?  Perhaps this is too minor a
point to discuss here, however.

-david

---

From: Colin Perkins <[email-masked]>
Date: Tue, 13 Feb 2007 22:37:09 +0000

Magnus, Dan,

The draft is good, and adding this text will improve it. Go ahead any  
publish it...

Colin

-- 
Colin Perkins
http://csperkins.org/

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 26 Feb 2007 16:10:24 +0100

> call. So please provide comments by Tuesday 20th of Feb on this issue.

There has been no objections against making this into a BCP.

Dan can you please update your draft with the proposed requirement text.

Cheers

Magnus Westerlund

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 26 Feb 2007 11:24:45 -0800

Submitted.  

In the meantime, it is available here:
http://svn.resiprocate.org/rep/ietf-drafts/dwing/draft-wing-behave-symmetric
-rtprtcp-02.html
http://svn.resiprocate.org/rep/ietf-drafts/dwing/draft-wing-behave-symmetric
-rtprtcp-02.txt

Rfcdiff between -02 and -01 is:
http://tinyurl.com/33a3d8

-d

> Sent: Monday, February 26, 2007 7:10 AM
> To: Magnus Westerlund