Subject: Re: [AVT] Working group last call: JPEG-2000 payload format

From: Satoshi Futemma <[email-masked]>
Date: Wed, 06 Jun 2007 18:37:59 +0900

Dear Colin,

We, authors, think all issues would be solved.
How should we do next ?

About timestamp issues, I can understand Dave's claim,
but I think most case we can imagine now may be covered
by 90 kHz clock rate.

Even if it occurs to send media files with another clock rate,
all senders should convert its clock rate to 90 kHz in some way,
which is beyond the scope of the draft.

So, I don't feel it is necessary to change the draft.

Best Regards,

Futemma

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: "Boudani Ali" <[email-masked]>
Date: Tue, 26 Jun 2007 10:14:38 +0200

That seems fine to me. 

-----Original Message-----
From: Magnus Westerlund [mailto:[email-masked]] 
Sent: mardi 26 juin 2007 10:04
To: Colin Perkins
Cc: Dave Singer; Chuck Harrison; Boudani Ali; Le Dantec Claude; IETF AVT
WG
Subject: Re: [AVT] Working group last call: JPEG-2000 payload format

Colin Perkins skrev:
> Wrapping up, I believe the rough consensus is that the JPEG-2000 draft

> should be updated to allow non-90kHz timestamp rates, as follows:
> 
> - Senders and receivers MUST support a 90kHz RTP timestamp rate, and
MAY
>   support other rates.
> 
> - Senders SHOULD use 90kHz timestamp where possible, and the draft
needs to
>   be updated to include strong guidance on choosing the timestamp
rate, and
>   the implications of using a rate other than 90kHz.
> 
> - The timestamp rate MUST be negotiated. The offer/answer
considerations
>   should explain how this is done.
> 
> - Senders that wish to use a non-90kHz rate SHOULD also offer the same

> stream
>   using a 90kHz timestamp rate, with a different RTP payload type,
e.g.:
> 
>     m=video 5004 RTP/AVP 98 99
>     a=rtpmap:98 jpeg2000/90000
>     a=rtpmap:99 jpeg2000/27000000
> 
>   allowing graceful fallback to 90kHz if the receiver doesn't support 
> the high
>   rate.
> 
> To check the consensus, please reply to this message by the end of
this 
> week, stating if you agree or disagree with this proposal, and giving 
> your reasons. Please do this even if you believe you have already
stated 
> your preference.

I am fine with this. However, I think the SDP example should switch the 
priority order of the two payload formats to indicate that one does like

to use 27 MHz rather then 90k. So if including an example with this, 
change the m= line to:
m=video 5004 RTP/AVP 99 98

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM/M
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Le Dantec Claude" <[email-masked]>
Date: Tue, 26 Jun 2007 10:21:32 +0200

Dear All,

An email mentionning my address has been sent by mistake some weeks ago
.
As I am still receiving associated emails, please delete my name from
your distribution list.

Best regards,

Claude Le Dantec

-----Original Message-----
From: Magnus Westerlund [mailto:[email-masked]] 
Sent: mardi 26 juin 2007 10:04
To: Colin Perkins
Cc: Dave Singer; Chuck Harrison; Boudani Ali; Le Dantec Claude; IETF AVT
WG

MAY
needs to
rate, and
considerations

e.g.:
> this week, stating if you agree or disagree with this proposal, and 
> giving your reasons. Please do this even if you believe you have 
> already stated your preference.
> 

Cheers

Magnus Westerlund