Subject: Re: [AVT] I-D ACTION:draft-ietf-avt-tfrc-profile-09.txt

From: Colin Perkins <[email-masked]>
Date: Wed, 1 Aug 2007 11:43:21 +0100

On 26 Jul 2007, at 05:26, Randell Jesup wrote:
> Colin Perkins <[email-masked]> writes:
>> This is why I'm suggesting you use the RTP timestamp rate: it  
>> avoids  all
>> these issues with multiple clocks.
>
> But can't the RTP timestamp rate change in mid-stream?

Sure, but you have to deal with that whether or not you implement TFRC.

Thinking about this issue some more, though, it might be better to  
use units of 1/65536 seconds, to match the LSR and DLSR fields in  
RTCP RR packets?

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: Randell Jesup <[email-masked]>
Date: Wed, 01 Aug 2007 22:37:56 -0400

Colin Perkins <[email-masked]> writes:

>>> This is why I'm suggesting you use the RTP timestamp rate: it avoids
>>> all these issues with multiple clocks.
>>

Yeah, but I think it would throw a major additional wrench into TFRC
calculations - and no one would test it (nor test packet loss at the
transition point), and you'd have problems in practice.

>Thinking about this issue some more, though, it might be better to  use
>units of 1/65536 seconds, to match the LSR and DLSR fields in  RTCP RR
>packets?

Sure, that might make sense - depending on how many bits you have to play
with, and the range of times you need to deal with.

-- 
Randell Jesup, Worldgate (developers of the Ojo videophone), ex-Amiga OS team
[email-masked]
"The fetters imposed on liberty at home have ever been forged out of the weapons
provided for defence against real, pretended, or imaginary dangers from abroad."
		- James Madison, 4th US president (1751-1836)