Subject: [AVT] RE: RFC 4588...

From: "Jose Rey" <[email-masked]>
Date: Wed, 12 Sep 2007 09:59:11 +0200

Vikal,

> I can understand this to be a requirement only if multiple streams are sent on the 
> same port with different SSRC.

Exactly. That's the point: RFC 3550 does allow for several streams to be multiplexed on the same port. The typical example here is two cameras sending video from different angles, thus using different SSRCs but the same media. I recommend you take a look at the AVT mail archives.

Cheers,

José

________________________________

	From: vikal jain [mailto:[email-masked]] 
	Sent: Wednesday, September 12, 2007 9:27 AM
	To: [email-masked]; [email-masked]; [email-masked]
	Subject: RFC 4588...

	Hi,
	 
	I was going through the RFC and I have a doubt regrading association scheme in SSRC multiplexing. 
	 
	5.3.  Association at the Receiver
	Why the receiver MUST NOT have two outstanding requests for the same packet sequence number in two different original streams before the association is resolved.
	 
	I think it is not required as client knows that in case of SSRC multiplexing both the original and retransmission streams and no other streams would always be received on the same port with different SSRCs. So if i receive a packet with new SSRC on the same port I can easily conclude that it belongs to the retransmission stream and can associate it with original streams. 

	I can understand this to be a requirement only if multiple streams are sent on the same port with different SSRC.
	 
	I will be obliged to you if you could help me in clearing this doubt.
	 
	Regards,
	Vikal.

	________________________________

________________________________

	Why delete messages? Unlimited storage is just a click away. <http://in.rd.yahoo.com/tagline_mail_1/*http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/> 

Panasonic R&D Center Germany GmbH
63225 Langen, Hessen, Germany
Reg: AG Offenbach (Hessen) HRB 33974
Managing Director: Thomas Micke

_______________________________________________
Audio/Video Transport Working Group
[email-masked]
https://www1.ietf.org/mailman/listinfo/avt

---

From: vikal jain <[email-masked]>
Date: Wed, 12 Sep 2007 08:26:35 +0100 (BST)

Hi,

   

   
  Regards,
  Vikal.

       
---------------------------------
 Why delete messages? Unlimited storage is just a click away.

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 12 Sep 2007 17:35:53 +0200

vikal jain skrev:
> Why the receiver MUST NOT have two outstanding requests for the same
> packet sequence number in two different original streams before the
> association is resolved.
>  
> I think it is not required as client knows that in case of SSRC
> multiplexing both the original and retransmission streams and no other
> streams would always be received on the same port with different SSRCs.
> So if i receive a packet with new SSRC on the same port I can easily
> conclude that it belongs to the retransmission stream and can associate
> it with original streams.
>  
> I can understand this to be a requirement only if multiple streams are
> sent on the same port with different SSRC.

Yes, which is a basic use case for RTP. Multiple sources within a RTP
session is always allowed, and one can never know if there are a single
or multiple active sources in an RTP session unless additional
signalling indicates that. Thus this requirement needs to be there to
ensure that missasocaition does not happen in the receiver. In general
this should very rarely be limiting the performance of the receiver.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM/M
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------