Subject: Re: [AVT] FW: New Version Notification for draft-begen-avt-rtp-mpeg2ts-preamble-01

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 20 Jul 2009 07:56:00 -0700

If the information that the decoder needs is spread over a 5-second period, it will add up to your time to start decoding. RAMS is eliminating some part of this delay, but the burst packets are the original RTP packets formatted as retransmission packets. So, they are not modified. You are right, these can be decoded eventually as well. However, the preamble info will "prepare" the decoder and enable it to start decoding potentially much sooner. In other words, it will give the decoder the summary of that 5-second period.

It should be clear that sending the preamble is optional from RAMS perspective.

BR,
-acbegen

> -----Original Message-----
> From: zouzixuan [mailto:[email-masked]]
> Sent: Monday, July 20, 2009 2:31 AM
> To: Ali C. Begen (abegen); [email-masked]
> Subject: 转发: RE: RE: [AVT] FW: New Version Notification for draft-begen-avt-rtp-mpeg2ts-
> preamble-01
> 
> 
> Hi, Ali
> 
> > Sorry for the confusion. I meant that we have not strictly specified yet
> which TLVs are mandatory and which are optional. Clearly, some TLVs are
> required to make any sense out of the preamble information.
> 
> >-acbegen
> 
> Sorry, I probably did not express my doubts very clearly. What I'm asking is
> what's the necessity of having TLV format for these information, which have
> been in good shape as a part of MPEG2-TS standard. Any application compliant
> to MPEG2-TS spec would have no problem parsing them, no matter if these
> information were spreading through the TS stream or were simply sent as
> Preamble as RTP payload. From this point of view, I cannot see the need of
> defining the new format for doing delay elimination. Hope this time I made
> myself clear.
> 
> Best regards,
> Zou ZiXuan, Senior Research Staff
> Media & Communication Lab
> HUAWEI TECHNOLOGIES CO.,LTD.
> 
> Address: Huawei Industrial Base
> Bantian Longgang
> Shenzhen 518129, P.R.China
> Tel: +86 0755 28789364
> Fax: +86 0755 28788317
> E-mail: [email-masked]
> www.huawei.com
> ----------------------------------------------------------------------------
> ---------------------------------------------------------
> This e-mail and its attachments contain confidential information from
> HUAWEI, which
> is intended only for the person or entity whose address is listed above. Any
> use of the
> information contained herein in any way (including, but not limited to,
> total or partial
> disclosure, reproduction, or dissemination) by persons other than the
> intended
> recipient(s) is prohibited. If you receive this e-mail in error, please
> notify the sender by
> phone or email immediately and delete it!
> 
> 
> -----邮件原件-----
> 发件人: Ali C. Begen (abegen) [mailto:[email-masked]]
> 发送时间: 2009年7月19日 10:35
> 收件人: zouzixuan 61302
> 抄送: [email-masked]
> 主题: RE: RE: RE: [AVT] FW: New Version Notification for
> draft-begen-avt-rtp-mpeg2ts-preamble-01
> 
> Sorry for the confusion. I meant that we have not strictly specified yet
> which TLVs are mandatory and which are optional. Clearly, some TLVs are
> required to make any sense out of the preamble information.
> 
> -acbegen
> 
> > -----Original Message-----
> > From: zouzixuan 61302 [mailto:[email-masked]]
> > Sent: Saturday, July 18, 2009 10:03 PM
> > To: Ali C. Begen (abegen)
> > Cc: [email-masked]
> > Subject: 回复:RE: RE: [AVT] FW: New Version Notification for
> draft-begen-avt-rtp-mpeg2ts-
> > preamble-01
> >
> > Hi, Ali
> >     A bit confusing:) What you mean you have not specified it yet? Section
> 5 has very
> > detailed defintions of preamble format.
> >
> > Zou ZiXuan
> > Senior Research Engineer
> > Media & Communication Laboratory
> > Corporate Research Department
> > Huawei Technologies. Co.,Ltd
> >
> > Tel: 86 0755 28789364
> > Mobile: 86 13570871908
> >
> > ----- 原邮件 -----
> > 发件人: "Ali C. Begen (abegen)" <[email-masked]>
> > 日期: 星期六, 七月 18日, 2009 上午11:18
> > 主题: RE: RE: [AVT] FW: New Version Notification for
> draft-begen-avt-rtp-mpeg2ts-preamble-
> > 01
> > 收件人: zouzixuan 61302 <[email-masked]>
> > 抄送: [email-masked]
> >
> > > Hi Zou,
> > >
> > > We have not specified it yet, however, not all TLVs are required
> > > all the time. So, some fields will exist some times, and they
> > > won't exist other times. This makes defining a static payload
> > > impractical. At the end, we follow the mpeg2-ts spec as well.
> > >
> > > -acbegen
> > >
> > > > -----Original Message-----
> > > > From: zouzixuan 61302 [mailto:[email-masked]]
> > > > Sent: Friday, July 17, 2009 10:57 PM
> > > > To: Ali C. Begen (abegen)
> > > > Cc: [email-masked]
> > > > Subject: 回复:RE: [AVT] FW: New Version Notification for draft-
> > > begen-avt-rtp-mpeg2ts-
> > > > preamble-01
> > > >
> > > > Hi, Ali
> > > >     What's the benefit of having these key information in
> > > specific PLV format? I mean
> > > > these information have been well-defined by MPEG2-TS, so just
> > > having these information
> > > > intacted in TS format and sending them as Preamble (as RTP
> > > payload) to the Receiver
> > > > achieve the same purpose as you stated in the draft.
> > > >
> > > > Zou ZiXuan
> > > > Senior Research Engineer
> > > > Media & Communication Laboratory
> > > > Corporate Research Department
> > > > Huawei Technologies. Co.,Ltd
> > > >
> > > > Tel: 86 0755 28789364
> > > > Mobile: 86 13570871908
> > > >
> > > > ----- 原邮件 -----
> > > > 发件人: "Ali C. Begen (abegen)" <[email-masked]>
> > > > 日期: 星期五, 七月 17日, 2009 上午3:52
> > > > 主题: RE: [AVT] FW: New Version Notification for draft-begen-avt-
> > > rtp-mpeg2ts-preamble-01
> > > > 收件人: zouzixuan <[email-masked]>, [email-masked]
> > > >
> > > > > Yes. That was our initial plan (to define an RTCP message to carry
> > > > > this preamble stuff). Then, in one of the breakout sessions, we
> > > > > decided to define the payload format, however, the RTCP version
> > > > > may still become handy. So, I would like to get everybody's input
> > > > > on this.
> > > > >
> > > > > BR,
> > > > > -acbegen
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: zouzixuan [mailto:[email-masked]]
> > > > > > Sent: Thursday, July 16, 2009 8:05 AM
> > > > > > To: Ali C. Begen (abegen); [email-masked]
> > > > > > Subject: 答复: [AVT] FW: New Version Notification for draft-
> > > begen-
> > > > > avt-rtp-mpeg2ts-preamble-
> > > > > > 01
> > > > > >
> > > > > > Hi, Ali
> > > > > > 	In clause 11: "Should we also define an RTCP message
> > > containing the
> > > > > > Preamble?"
> > > > > > Are you asking if we need to have a RTCP message doing the same
> > > > > thing as RTP
> > > > > > (defined in this draft) does?
> > > > > >
> > > > > > Zou ZiXuan, Senior Research Staff
> > > > > > Media & Communication Lab
> > > > > > HUAWEI TECHNOLOGIES CO.,LTD.
> > > > > >
> > > > > > Address: Huawei Industrial Base
> > > > > > Bantian Longgang
> > > > > > Shenzhen 518129, P.R.China
> > > > > > Tel: +86 0755 28789364
> > > > > > Fax: +86 0755 28788317
> > > > > > E-mail: [email-masked]
> > > > > > www.huawei.com
> > > > > > -------------------------------------------------------------
> > > ----
> > > > > -----------
> > > > > > ---------------------------------------------------------
> > > > > > This e-mail and its attachments contain confidential information
> > > > > from> HUAWEI, which
> > > > > > is intended only for the person or entity whose address is
> > > > > listed above. Any
> > > > > > use of the
> > > > > > information contained herein in any way (including, but not
> > > > > limited to,
> > > > > > total or partial
> > > > > > disclosure, reproduction, or dissemination) by persons other
> > > > > than the
> > > > > > intended
> > > > > > recipient(s) is prohibited. If you receive this e-mail in error,
> > > > > please> notify the sender by
> > > > > > phone or email immediately and delete it!
> > > > > >
> > > > > >
> > > > > > -----邮件原件-----
> > > > > > 发件人: [email-masked] [mailto:[email-masked]] 代表
> Ali
> > > > > C. Begen
> > > > > > (abegen)
> > > > > > 发送时间: 2009年7月10日 23:53
> > > > > > 收件人: [email-masked]
> > > > > > 主题: [AVT] FW: New Version Notification for
> > > > > > draft-begen-avt-rtp-mpeg2ts-preamble-01
> > > > > >
> > > > > > I've submitted a new version for the mpeg2ts-preamble draft.
> > > > > Comments and
> > > > > > feedback are welcome. This draft will be presented along with
> > > > > the RAMS draft
> > > > > > in Stockholm.
> > > > > >
> > > > > > http://www.ietf.org/internet-drafts/draft-begen-avt-rtp-
> > > mpeg2ts-
> > > > > preamble-01.
> > > > > > txt
> > > > > >
> > > > > > Thanks.
> > > > > > -acbegen
> > > > > >
> > > > > > -----Original Message-----
> > > > > > From: IETF I-D Submission Tool [mailto:[email-masked]]
> > > > > > Sent: Friday, July 10, 2009 11:50 AM
> > > > > > To: Ali C. Begen (abegen)
> > > > > > Cc: Eric Friedrich (efriedri)
> > > > > > Subject: New Version Notification for
> > > > > > draft-begen-avt-rtp-mpeg2ts-preamble-01
> > > > > >
> > > > > >
> > > > > > A new version of I-D, draft-begen-avt-rtp-mpeg2ts-preamble-
> > > > > 01.txt has been
> > > > > > successfuly submitted by Ali Begen and posted to the IETF
> > > > > repository.>
> > > > > > Filename:         draft-begen-avt-rtp-mpeg2ts-preamble
> > > > > > Revision:         01
> > > > > > Title:                 RTP Payload Format for MPEG2-TS Preamble
> > > > > > Creation_date:         2009-07-10
> > > > > > WG ID:                 Independent Submission
> > > > > > Number_of_pages: 39
> > > > > >
> > > > > > Abstract:
> > > > > > Demultiplexing and decoding an MPEG2 Transport Stream (MPEG2-TS)
> > > > > > requires the knowledge of specific information about the
> > > transport> > > stream, which we refer to as the MPEG2-TS Preamble.
> > > While this
> > > > > > information is spread over different locations throughout the
> > > > > > transport stream and can be eventually assembled after some
> > > time a
> > > > > > receiver started receiving the MPEG2-TS, the time it takes to
> > > > > > retrieve all this information (especially in multicast
> > > environments)> > > may be long.  Instead, having this information
> > > readily available
> > > > > as a
> > > > > > Preamble and sending the Preamble to a receiver that will
> > > shortly> > > start receiving the transport stream will virtually
> > > eliminate the
> > > > > > waiting time and let the receiver start processing/decoding the
> > > > > > MPEG2-TS sooner.  In this document, we give an overview of the
> > > > > > MPEG2-TS and the delay components in video systems, and
> > > motivate the
> > > > > > need for constructing and using the MPEG2-TS Preamble for
> > > rapidly> > > acquiring the source stream in RTP multicast
> > > sessions.  We also
> > > > > > define and register the RTP payload format for the MPEG2-TS
> > > > > Preamble.>
> > > > > >
> > > > > >
> > > > > >
> > > > > > The IETF Secretariat.
> > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Audio/Video Transport Working Group
> > > > > > [email-masked]
> > > > > > https://www.ietf.org/mailman/listinfo/avt
> > > > >
> > > > >
> > >

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Mon, 20 Jul 2009 19:11:37 -0700

Well, if you look at the draft, you will see that we are putting the information in a very condensed format skipping all the overhead of the TS headers, PES headers, etc. in order to keep the preamble size small.

Once the info is received, we do an "inverse transform" and convert the preamble info a demux/decoder-friendly TS stream.

HTH,
-acbegen

> Sent: Monday, July 20, 2009 8:36 PM
> Subject: 答复: RE: RE: [AVT] FW: New Version Notification for draft-begen-avt-rtp-mpeg2ts-
> preamble-01
> 
> Hi, Ali
> 	I'm not questioning if Preamble is useful or not. I do agree with
> you that Preamble can be a option for eliminating the decoding delay. But
> why do we need to have "TLV format" for these kind of information to be
> Preamble? They are already there as TS format, why not simply have the
> Preamble information in TS format (as RTP payload) for delay reduction.
> 
> Best
> 发送时间: 2009年7月20日 22:56
> 收件人: zouzixuan; [email-masked]
> If the information that the decoder needs is spread over a 5-second period,
> it will add up to your time to start decoding. RAMS is eliminating some part
> of this delay, but the burst packets are the original RTP packets formatted
> as retransmission packets. So, they are not modified. You are right, these
> can be decoded eventually as well. However, the preamble info will "prepare"
> the decoder and enable it to start decoding potentially much sooner. In
> other words, it will give the decoder the summary of that 5-second period.
>