Subject: [AVT] RTP Payload Format for MPEG2-TS Preamble - draft-begen-avt-rtp-mpeg2ts-preamble-01

From: Zeev Vax <[email-masked]>
Date: Wed, 22 Jul 2009 03:25:52 +0000

Hi Ali,

This draft is important addition to the RAMS draft, and complete the information needed to scalable deployment of FCC.
The main two points which are currently not covered, and I would like to see them added.

*         Extension to support external clock

*         Align of audio and video packets to help faster channel change

For the external clock, the current draft has a PCR extension, so all is needed is to add additional field to it with the external  clock. The external clock can be used in different way, it can used to sync up RS and RR and overcome network jitter issues.

The alignment of audio and video packet is important for the FCC getting into the sub seconds performance range. With typical video compression setting the video packets are sent 2 - 4 seconds before the audio packets. If the packets are not aligned, the two options the RR has are delay the playback until they arrive which will results in almost no improvements to regular multicast tune. The other alternative is to start the playback with no audio, which is also sub optimal user experience.

Zeev

[Zeev Vax] Lead Program Manager [Live VOD & Core Infrastructure]
Phone: 1-650-693-2353    Mobile: 1-415-412-9952
Fax: 1-650-693-3329   Email: [email-masked]<mailto:[email-masked]>
[MediaRoomLogo]<http://www.microsoftmediaroom.com/>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 21 Jul 2009 23:06:59 -0700

Hi Zeev,

Thanks for the email and support.

For the external clock, I believe we can add this, but how do you wanna use it to sync sync RS and RR?

For the alignment, your observation is correct. We can make that recommendation in the draft. However, normally RS would not be able to align the audio and video streams as doing so will require (a lot of) processing on the RS. It will probably better to do the alignment before the packets get to RS, if that is possible.

-acbegen

> -----Original Message-----
> From: Zeev Vax [mailto:[email-masked]]
> Sent: Tuesday, July 21, 2009 11:26 PM
> To: [email-masked]; Ali C. Begen (abegen)
> Subject: RTP Payload Format for MPEG2-TS Preamble - draft-begen-avt-rtp-mpeg2ts-preamble-
> 01
> 
> Hi Ali,
> 
> 
> 
> ·         Extension to support external clock
> 
> ·         Align of audio and video packets to help faster channel change
> 
> 
> 
> For the external clock, the current draft has a PCR extension, so all is needed is to add
> additional field to it with the external  clock. The external clock can be used in
> different way, it can used to sync up RS and RR and overcome network jitter issues.
> 
> 
> 
> The alignment of audio and video packet is important for the FCC getting into the sub
> seconds performance range. With typical video compression setting the video packets are
> sent 2 – 4 seconds before the audio packets. If the packets are not aligned, the two
> options the RR has are delay the playback until they arrive which will results in almost
> no improvements to regular multicast tune. The other alternative is to start the playback
> with no audio, which is also sub optimal user experience.
> 
> 
> 
> Zeev
> 
> 
> 
> 
> 
> Fax: 1-650-693-3329   Email: [email-masked] <mailto:[email-masked]>
> 
> MediaRoomLogo <http://www.microsoftmediaroom.com/>
> 
> 
> 
>

---

From: David R Oran <[email-masked]>
Date: Wed, 22 Jul 2009 08:54:13 -0400

On Jul 22, 2009, at 2:06 AM, Ali C. Begen (abegen) wrote:

> For the alignment, your observation is correct. We can make that  
> recommendation in the draft. However, normally RS would not be able  
> to align the audio and video streams as doing so will require (a lot  
> of) processing on the RS.
Hmmm, I would think that the preamble burst wouldn't have any audio or  
video in it. My impression is that the purpose of the preamble is to  
reach back and send only TS structure info, ECMs, etc.that were  
earlier in the TS than the RAP that was chosen to start the actual  
burst so I'm not quite sure how re-muxing/de-muxing/"re-alignment"  
plays in here.

> It will probably better to do the alignment before the packets get  
> to RS, if that is possible.
>
> -acbegen
>
>> This draft is important addition to the RAMS draft, and complete  
>> the information needed to
>> scalable deployment of FCC.
>>
>> Fax: 1-650-693-3329   Email: [email-masked] <mailto:[email-masked] 
>> >
>>
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 22 Jul 2009 08:26:52 -0700

> From: Dave Oran (oran)
> Sent: Wednesday, July 22, 2009 8:54 AM
> To: Ali C. Begen (abegen)
> Cc: Zeev Vax; [email-masked]
> Subject: Re: [AVT] RTP Payload Format for MPEG2-TS Preamble - draft-begen-avt-rtp-mpeg2ts-
> preamble-01
> 
> 

Correct. That is the whole purpose of the draft (and the preamble info).

> burst so I'm not quite sure how re-muxing/de-muxing/"re-alignment"

I believe the request was to mention this as a "recommendation" in the Video section where we discuss the delay components of video apps. We could say that alignment of the audio and video streams when the mpeg2-ts is put together (somewhere before RS) will make it more random-access friendly. But, of course, while doing that mpeg and mpeg2-ts rules must be observed.

-acbegen

---

From: Zeev Vax <[email-masked]>
Date: Wed, 22 Jul 2009 16:26:04 +0000

Please see  inline.

Zeev

-----Original Message-----
From: David R Oran [mailto:[email-masked]]
Sent: Wednesday, July 22, 2009 5:54 AM
To: Ali C. Begen (abegen)
Cc: Zeev Vax; [email-masked]
Subject: Re: [AVT] RTP Payload Format for MPEG2-TS Preamble - draft-begen-avt-rtp-mpeg2ts-preamble-01

> wanna use it to sync sync RS and RR?

[Zeev Vax]
[Zeev Vax] If the external clock is used by the client and server, they are in sync and just need to follow the clocks differences.

> of) processing on the RS.

[Zeev Vax]
[Zeev Vax] Agreed, this is something that typically would be done by the MC source and not the RS

[Zeev Vax]
[Zeev Vax] As I understand the purpose of this draft is to add the MPEG and MPEG-TS information that would enable the FCC to be fast.

>> sent 2 - 4 seconds before the audio packets. If the packets are not
>> aligned, the two