Subject: Re: [AVT] Sound level indication in RTP (Emil Ivov)

From: William Miller <[email-masked]>
Date: Thu, 30 Jul 2009 00:55:01 -0400

The primary utility I see for this type of display is easy
identification of the party who has put the conference call on hold and
is consequently feeding music or marketing spam into the bridge.  For
this, absolute level accuracy is unnecessary; all one needs is a
display that correlates reasonably well with the dynamics of the
unwanted audio so the moderator can identify and terminate the
offending connection.

Having had teleconferences paralyzed by music-on-hold more times than I
can count, I say that such a feature is well worth having and support
adding the tools to enable it.

Best regards,

Bill Miller

Message: 1
Date: Wed, 29 Jul 2009 19:10:34 +0200
From: Emil Ivov <[email-masked]>
Subject: Re: [AVT] Sound level indication in RTP
To: stephen botzko <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Roni Even <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1

stephen botzko wrote:

Since different codecs have different digital audio reference levels, it
seems to me that their might be a codec-specific component to this problem.

Though I guess I am not completely sure from the thread exactly what
functionality this is expected to deliver.

(This answer is about Option 2:the mixer-to-participant level
distribution. Jonathan, I am not sure whether codec specifics would play
a role in the mixer optimization that your draft is about, so you may
want to answer that yourself.)

Stephen, the following image displays a Skype conf call :

http://sip-communicator.org/skypeconf/skypeconf.png

We'd like to make it possible for RTP clients (SIP, XMPP, or others) to
implement the same kind of GUI. We can't do it with standard RTP which
is why we are proposing the extension.

Cheers
Emil

Regards,
Stephen Botzko

On Wed, Jul 29, 2009 at 12:51 PM, Emil Ivov <[email-masked]
<mailto:[email-masked]>> wrote:

Hey Zeev,

Zeev Vax wrote:
> Sound level problem can't be solved only by the transport, it has to
> start with the encoder and reach the decoder.

We are not trying to solve the general topic of sound level for all
related use cases.

What we'd like is a simple way of delivering active speaker sound-level
to the UAs participating in a conference call. The point is to allow
them to display it to their users. This is all really.

The extension is not supposed to control level in any way and it has
little relation to codec specifics.

Cheers
Emil

> There are several
> standard which are dealing with it end to end. We should try to
> leverage these existing standards instead of creating a new one that
> would be isolated and won't handle the full chain.
>
> Zeev
>
> -----Original Message----- From: [email-masked]
<mailto:[email-masked]>
> [mailto:[email-masked] <mailto:[email-masked]>] On
Behalf Of Emil Ivov Sent: Wednesday,
> July 29, 2009 6:29 AM To: Eric Burger Cc: [email-masked]
<mailto:[email-masked]>; Roni Even
> Subject: Re: [AVT] Sound level indication in RTP
>
> All,
>
> I am trying to make sure that we are all on the same page so here's
> what I gather so far:
>
> 1. Option 1 (participants sending levels to mixers) and Option 2
> (mixers sending levels to participants) are two different things,
> that don't have much in common, and should be handled separately.
>
> 2. If Option 1 is to be useful it needs to use speech detection. This
> is one more reason to separate it from Option 2 since levels in conf
> calls could be used to identify sources of background noise.
>
> 3. Option 2 seems to be regarded as helpful and relevant to this
> charter, so we may proceed with it.
>
> I am having a slight doubt about "3" so I'd appreciate a clear show
> of interest (or lack thereof) in Option 2 and its adoptability as a
> working group document.
>
> Cheers Emil
>
>
>
>
> Eric Burger wrote:
>> While it sounds good [sic] to use the input sound levels, again
>> they will not reflect what people hear on the output side. That
>> would be a customer service nightmare:
>>
>> S: How may I help you?
>>
>> C: I love the flashing lights on my web interface to the conference
>> bridge. However, I can barely hear Fred, yet the web says he is
>> red- lined.
>>
>> S: Well, let me explain to you about RTP, sound level detection,
>> discreet cosine transforms, and alchemy...
>>
>> On Jul 29, 2009, at 1:51 PM, Roni Even wrote:
>>
>>> Eric, I think I agree with your feedback on the first suggestion,
>>> As for the second one the idea is for the mixer to reflect the
>>> value from the input side. But it can also be from the actual
>>> mixed value. It will still provide some view in for the
>>> participants about the relative volume of the participants in the
>>> mix. It may also be helpful since most mixers today do not
>>> suppress keyboard clicks.
>>>
>>> Roni Even
>>>
>>>> -----Original Message----- From: [email-masked]
<mailto:[email-masked]>
>>>> [mailto:[email-masked] <mailto:[email-masked]>] On
Behalf Of Eric Burger Sent:
>>>> Wednesday, July 29, 2009 2:38 PM To: [email-masked]
<mailto:[email-masked]> Subject: Re:
>>>> [AVT] Sound level indication in RTP
>>>>
>>>> I would offer that (1) is totally unhelpful and most likely
>>>> unavailable. Endpoints will only do sound-level, as opposed to
>>>> sound presence for squelch, if they are using a
>>>> sound-level-related codec.
>>>>
>>>> The mixer, on the other hand, has to do full analysis of the
>>>> media to do the mix in the first place. Moreover, most advanced
>>>> mixers (media servers) will do level balancing, which means
>>>> endpoint sound levels will not even be relatively correct as a
>>>> representation of the mix. Lastly, advanced mixers will do
>>>> noise suppression, which means a non- talker with an unmuted
>>>> mobile phone in the wind will have a relatively high sound
>>>> level, yet not be in the mix at all.
>>>>
>>>> On Jul 29, 2009, at 1:12 PM, Enrico Marocco wrote:
>>>>
>>>>> -------- Original Message -------- Subject: [AVT] Sound
>>>>> level indication in RTP Date: Wed, 29 Jul 2009 12:55:48
>>>>> +0200 From: Roni Even <[email-masked]
<mailto:[email-masked]>> To:
>>>>> [email-masked] <mailto:[email-masked]> <[email-masked]
<mailto:[email-masked]>>
>>>>>
>>>>>
>>>>>
>>>>> Hi,
>>>>>
>>>>> During the IETF75 AVT Monday session the topic of sound
>>>>> level indication was presented.
>>>>>
>>>>> To recap the topic there are two suggestions.
>>>>>
>>>>> 1. Provide the sound level indication from the endpoint
>>>>> to the mixer, this will help the mixer with selection the
>>>>> candidates to be mixed
>>>>>
>>>>> 2. Provide the incoming sound levels of all the
>>>>> participants in the mixed as measured by the mixer. This may
>>>>> be displayed to the conference participants helping them to
>>>>> know who are the speaker and if there is someone causing
>>>>> constant noise like typing.
>>>>>
>>>>> We did not have enough time to discuss at the session and we
>>>>> are looking for feedback in order to see how to continue with
>>>>> this work.
>>>>>
>>>>>
>>>>>
>>>>> We want to know if this is a good idea, which of the two
>>>>> proposal is interesting (maybe both).
>>>>>
>>>>> What use cases people see for sound level indications
>>>>>
>>>>>
>>>>>
>>>>> Please respond so we can see if there is support for this
>>>>> work and to verify the way forward.
>>>>>
>>>>>
>>>>>
>>>>> Thanks
>>>>>
>>>>> Roni Even
>>>>>
>>>>> AVT co-chair
>>
>>
------------------------------------------------------------------------
>>
>>
>> _______________________________________________ Audio/Video
>> Transport Working Group [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/avt
>
> -- Emil Ivov, Ph.D. 67000 Strasbourg,
> Project Lead France SIP
> Communicator [email-masked]
<mailto:[email-masked]> PHONE:
> +33.1.77.62.43.30 http://sip-communicator.org FAX:
> +33.1.77.62.47.31 _______________________________________________
> Audio/Video Transport Working Group [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/avt
>
>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
SIP Communicator
[email-masked] <mailto:[email-masked]>
PHONE: +33.1.77.62.43.30
http://sip-communicator.org FAX: +33.1.77.62.47.31
_______________________________________________
Audio/Video Transport Working Group
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avt

---

From: Eric Burger <[email-masked]>
Date: Thu, 30 Jul 2009 08:31:13 +0200

Agreed.  In fact, considering some of the list traffic, I would offer  
one MUST NOT use the "level" information to feed a codec.  It is  
purely for recreational purposes!

On Jul 30, 2009, at 6:55 AM, William Miller wrote:

> identification of the party who has put the conference call on hold  
> and is consequently feeding music or marketing spam into the  
> bridge.  For this, absolute level accuracy is unnecessary; all one  
> needs is a display that correlates reasonably well with the dynamics  
> of the unwanted audio so the moderator can identify and terminate  
> the offending connection.
>
> Having had teleconferences paralyzed by music-on-hold more times  
> than I can count, I say that such a feature is well worth having and  
> support adding the tools to enable it.
>
> Best regards,
> Bill Miller
>
>> Message: 1
>>>     > +33.1.77.62.47.31  
>>>     > Audio/Video Transport Working Group [email-masked] <mailto:[email-masked] 
>>> >
> <millerwc.vcf>_______________________________________________
> [email-masked]