Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-09

From: Colin Perkins <[email-masked]>
Date: Fri, 2 Oct 2009 08:13:30 +0100

There doesn't seem to be any signalling introduced. Does this mean  
that the aligned mode is removed completely, or will a future version  
add an SDP parameter?

Also, the D bit is indicated as being for backwards compatibility, but  
there's no indication what to use in future. Again, is there a need to  
define some signalling, or do you actually have no intention of moving  
away from using the D bit?

Colin

On 28 Sep 2009, at 12:20, Yury Morzeev wrote:

> Roni, Magnus, Colin,
> I've took into account your comments below and add minor changes  
> into the draft.
> Please, revise them and may be we have a chance to go to the next  
> step.
> Also I have explained Roni about the valid address. So, all  
> addresses in the document are available to authors.
> Hope to hear from you soon.
>
> Regards,
> Yury Morzeev
>
> -----Original Message-----
> From: Yury Morzeev
> Sent: Friday, September 25, 2009 1:06 PM
> To: 'Magnus Westerlund'; Roni Even
> Cc: 'Colin Perkins'; [email-masked]
> Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08
>
> Thank you gentlemen for your comments,
> We will review the document and include some changes.
>
> Regards,
> Yury Morzeev
>
>
> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Friday, September 25, 2009 1:00 PM
> To: Roni Even
> Cc: 'Colin Perkins'; Yury Morzeev; [email-masked]
> Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08
>
> Roni Even skrev:
> > Colin,
> > Thanks, I will let Yury respond. I sent a publication request last  
> night but
> > this does not prevent a revision of the draft if needed.
> > As for my view see inline
> >
> > A comment to Yury is to have a valid email address in the authors  
> list
> > otherwise they will not get any information about the progress of  
> the draft
> > in publication stage.
> >
> > Roni
> >
> >> -----Original Message-----
> >> From: Colin Perkins [mailto:[email-masked]]
> >> Sent: Friday, September 25, 2009 1:30 AM
> >> To: Roni Even
> >> Cc: [email-masked]
> >> Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08
> >>
> >> Roni,
> >>
> >> On 16 Sep 2009, at 14:33, Roni Even wrote:
> >>> We had a WGLC on version 4 of http://tools.ietf.org/html/draft-ietf-
> >> avt-rtp-ipmr-08
> >>>  , RTP Payload Format for IP-MR Speech Codec.
> >>> This revision addresses the comments that were received and I  
> would
> >>> like to start a one week WGLC on the revised draft.
> >>> Please send any comment till September 24th.
> >>> If there will be no comment we will send the draft to publication
> >>
> >> This version addresses some of my concerns with -04, but not all.
> >>
> >> The A bit in the payload header signals whether byte-aligned mode  
> is
> >> to be used. There doesn't seem to be any specification of how this
> >> differs from the non-byte-aligned mode, or how frames are padded  
> (the
> >> example is not sufficient; normative text is needed).
> >
> >
> > I suggest that Yury will add some text.
> >
> >> Also, the use of a bits in the payload header to signal aligned vs.
> >> non-aligned payload data and DTX modes is unusual. Other RTP  
> payload
> >> formats usually use out-of-band SDP signalling to such purposes. I
> >> accept that there are backwards compatibility issues here, but the
> >> document should at least explain the unusual design choice.
> >
> > The text says that it is not negotiation but an indication on the  
> structure
> > of the payload in the packet, the support of DTX is not optional  
> so there is
> > no need for the out of band negotiation.
> > Yury can clarify the backward interoperability issue.
> >
> >> The code in Appendix A is useful. What licensing terms are  
> attached to
> >> it?
> > Good question
> >
>
> I would note that the TLP applies to this:
> http://trustee.ietf.org/docs/IETF-Trust-License-Policy.pdf
>
> I would strongly recommend the authors to include the explicit BSD
> license or its short form legend.
>
> Cheers
>
> Magnus Westerlund
>
> IETF Transport Area Director
> ----------------------------------------------------------------------
> Multimedia Technologies, Ericsson Research EAB/TVM
> ----------------------------------------------------------------------
> Ericsson AB                | Phone  +46 10 7148287
> Färögatan 6                | Mobile +46 73 0949079
> SE-164 80 Stockholm, Sweden| mailto: [email-masked]
> ----------------------------------------------------------------------
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

-- 
Colin Perkins
http://csperkins.org/

---

From: Roni Even <[email-masked]>
Date: Fri, 02 Oct 2009 12:13:38 +0200

Colin,

There is no need for signaling the D bit, it is always supported and the D
just indicates if it is used in the current package. I think there is
similar use in gsm-hr

Roni

From: Colin Perkins [mailto:[email-masked]] 
Sent: Friday, October 02, 2009 9:14 AM
To: Yury Morzeev
Cc: Magnus Westerlund; Roni Even; [email-masked]
Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-09

There doesn't seem to be any signalling introduced. Does this mean that the
aligned mode is removed completely, or will a future version add an SDP
parameter? 

Also, the D bit is indicated as being for backwards compatibility, but
there's no indication what to use in future. Again, is there a need to
define some signalling, or do you actually have no intention of moving away
from using the D bit?

Colin

Roni, Magnus, Colin,

I've took into account your comments below and add minor changes into the
draft.

Please, revise them and may be we have a chance to go to the next step.

Also I have explained Roni about the valid address. So, all addresses in the
document are available to authors.

Regards,

Yury Morzeev

-----Original Message-----
From: Yury Morzeev 
Sent: Friday, September 25, 2009 1:06 PM
To: 'Magnus Westerlund'; Roni Even
Cc: 'Colin Perkins'; [email-masked]
Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08

Regards,

Yury Morzeev

-----Original Message-----

To: Roni Even

> Thanks, I will let Yury respond. I sent a publication request last night
but

> A comment to Yury is to have a valid email address in the authors list

> otherwise they will not get any information about the progress of the
draft

>>> This revision addresses the comments that were received and I would

>> The A bit in the payload header signals whether byte-aligned mode is

>> differs from the non-byte-aligned mode, or how frames are padded (the

>> non-aligned payload data and DTX modes is unusual. Other RTP payload

structure

> of the payload in the packet, the support of DTX is not optional so there
is

>> The code in Appendix A is useful. What licensing terms are attached to

Cheers

Magnus Westerlund

 

-- 

Colin Perkins

http://csperkins.org/

__________ Information from ESET NOD32 Antivirus, version of virus signature
database 4475 (20091002) __________

The message was checked by ESET NOD32 Antivirus.

http://www.eset.com

---

From: Colin Perkins <[email-masked]>
Date: Fri, 2 Oct 2009 11:48:33 +0100

But in that case, it's not just for backwards compatibility? Either  
it's a permanent feature and the draft needs to explain and justify  
the design rationale (since it's different to many other payload  
formats), or it's for backwards compatibility, and the draft needs to  
define the mechanism to be used going forwards, which is presumably  
signalling.

Colin

On 2 Oct 2009, at 11:13, Roni Even wrote:
> Colin,
> There is no need for signaling the D bit, it is always supported and  
> the D just indicates if it is used in the current package. I think  
> there is similar use in gsm-hr
> Roni
>
> that the aligned mode is removed completely, or will a future  
> version add an SDP parameter?
>
> Also, the D bit is indicated as being for backwards compatibility,  
> but there's no indication what to use in future. Again, is there a  
> need to define some signalling, or do you actually have no intention  
> of moving away from using the D bit?
>
> Colin
>
>
>
> __________ Information from ESET NOD32 Antivirus, version of virus  
> signature database 4475 (20091002) __________
>
> __________ Information from ESET NOD32 Antivirus, version of virus  
> signature database 4475 (20091002) __________
>

-- 
Colin Perkins
http://csperkins.org/

---

From: "Yury Morzeev" <[email-masked]>
Date: Fri, 2 Oct 2009 15:11:10 +0400

The 'D bit' appears as 'allow_DTX' parameter in GetFrameInfo() function source code. If you want I can add this into the text

Regards,

Yury Morzeev

________________________________

From: Colin Perkins [mailto:[email-masked]] 
Sent: Friday, October 02, 2009 2:49 PM
To: Roni Even
Cc: Yury Morzeev; 'Magnus Westerlund'; [email-masked]
Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-09

But in that case, it's not just for backwards compatibility? Either it's a permanent feature and the draft needs to explain and justify the design rationale (since it's different to many other payload formats), or it's for backwards compatibility, and the draft needs to define the mechanism to be used going forwards, which is presumably signalling.

Colin

	Colin,

	There is no need for signaling the D bit, it is always supported and the D just indicates if it is used in the current package. I think there is similar use in gsm-hr

	Roni

	There doesn't seem to be any signalling introduced. Does this mean that the aligned mode is removed completely, or will a future version add an SDP parameter? 

	Also, the D bit is indicated as being for backwards compatibility, but there's no indication what to use in future. Again, is there a need to define some signalling, or do you actually have no intention of moving away from using the D bit?

	Colin

	

	Roni, Magnus, Colin,

	I've took into account your comments below and add minor changes into the draft.

	Also I have explained Roni about the valid address. So, all addresses in the document are available to authors.

	Regards,

	Yury Morzeev

	-----Original Message-----
	From: Yury Morzeev 
	Sent: Friday, September 25, 2009 1:06 PM
	To: 'Magnus Westerlund'; Roni Even
	Cc: 'Colin Perkins'; [email-masked]
	Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08

	Regards,

	Yury Morzeev

	-----Original Message-----

	To: Roni Even

	> Thanks, I will let Yury respond. I sent a publication request last night but

	> otherwise they will not get any information about the progress of the draft

	> The text says that it is not negotiation but an indication on the structure

	> of the payload in the packet, the support of DTX is not optional so there is

	Cheers

	Magnus Westerlund

	

	-- 

	Colin Perkins

	http://csperkins.org/

	 

	__________ Information from ESET NOD32 Antivirus, version of virus signature database 4475 (20091002) __________

	http://www.eset.com

	__________ Information from ESET NOD32 Antivirus, version of virus signature database 4475 (20091002) __________

	http://www.eset.com

-- 

Colin Perkins

http://csperkins.org/

---

From: "Yury Morzeev" <[email-masked]>
Date: Fri, 2 Oct 2009 15:45:57 +0400

Guys, you both right.

D-bit NOT just for backward compatibility

D-bit only appears as allow_DTX parameter in payload parsing routine:
  if (allow_DTX) {
    FrType = GetBit(pCoded, nBits++) ? FT_DTX_SPEECH : FT_DTX_SID; // read one bit !!!
  } else {
    FrType = FT_NO_DTX;
  }
So, one can't read FrType correctly if the value of allow_DTX is unknown

D-bit REQUIRED for backward compatibility only

Internally, decoder makes no difference between FT_DTX_SPEECH and FT_NO_DTX frame types, so one spent 2 bits to transmit 1 bit if D-bit is set.

Regards,

Yury Morzeev

Colin

	Colin,

	Roni

	Colin

	

	Roni, Magnus, Colin,

	Regards,

	Yury Morzeev

	-----Original Message-----
	From: Yury Morzeev 
	Sent: Friday, September 25, 2009 1:06 PM
	To: 'Magnus Westerlund'; Roni Even
	Cc: 'Colin Perkins'; [email-masked]
	Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08

	Regards,

	Yury Morzeev

	-----Original Message-----

	To: Roni Even

	Cheers

	Magnus Westerlund

	

	-- 

	Colin Perkins

	http://csperkins.org/

	 

	
	
	http://www.eset.com

	
	
	http://www.eset.com

-- 

Colin Perkins

http://csperkins.org/

---

From: Roni Even <[email-masked]>
Date: Fri, 02 Oct 2009 15:38:38 +0200

Yury,

My assumption was that DTX support is always needed by decoder and as such
you do not need to signal support for it since support is implied and there
is no backward interoperability but also always true.

If in the future you intend to have different way, so a decoder need to
signal support , you need to add it to the draft.

This is what we find confusing

Roni

From: Yury Morzeev [mailto:[email-masked]] 
Sent: Friday, October 02, 2009 1:46 PM
To: Colin Perkins; Roni Even
Cc: Magnus Westerlund; [email-masked]
Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-09

Guys, you both right.

D-bit only appears as allow_DTX parameter in payload parsing routine:
  if (allow_DTX) {
    FrType = GetBit(pCoded, nBits++) ? FT_DTX_SPEECH : FT_DTX_SID; // read
one bit !!!
  } else {
    FrType = FT_NO_DTX;
  }
So, one can’t read FrType correctly if the value of allow_DTX is unknown

Internally, decoder makes no difference between FT_DTX_SPEECH and FT_NO_DTX
frame types, so one spent 2 bits to transmit 1 bit if D-bit is set.

Regards,

Yury Morzeev

  _____  

But in that case, it's not just for backwards compatibility? Either it's a
permanent feature and the draft needs to explain and justify the design
rationale (since it's different to many other payload formats), or it's for
backwards compatibility, and the draft needs to define the mechanism to be
used going forwards, which is presumably signalling.

Colin

Colin,

Roni

Colin

Roni, Magnus, Colin,

Regards,

Yury Morzeev

-----Original Message-----
From: Yury Morzeev 
Sent: Friday, September 25, 2009 1:06 PM
To: 'Magnus Westerlund'; Roni Even
Cc: 'Colin Perkins'; [email-masked]
Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08

Regards,

Yury Morzeev

-----Original Message-----

To: Roni Even

but

draft

structure

is

Cheers

Magnus Westerlund

 

-- 

Colin Perkins

http://csperkins.org/

http://www.eset.com

http://www.eset.com

-- 

Colin Perkins

http://csperkins.org/

---

From: "Yury Morzeev" <[email-masked]>
Date: Mon, 5 Oct 2009 20:32:32 +0400

Dear Colleagues,

Since we found some confusing  have been raised of D-bit presence, we finally decided to remove it from payload header.

Please, find the updated published version. And your comments will be appreciated. Hope you will accept payload now.

Regards,

Yury Morzeev

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yury Morzeev
Sent: Friday, October 02, 2009 3:46 PM
To: Colin Perkins; Roni Even
Cc: Magnus Westerlund; [email-masked]
Subject: Re: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-09

Guys, you both right.

 

 

Regards,

Yury Morzeev

Colin

	Colin,

	Roni

	Colin

	

	Roni, Magnus, Colin,

	Regards,

	Yury Morzeev

	-----Original Message-----
	From: Yury Morzeev 
	Sent: Friday, September 25, 2009 1:06 PM
	To: 'Magnus Westerlund'; Roni Even
	Cc: 'Colin Perkins'; [email-masked]
	Subject: RE: [AVT] Short WGLC on draft-ietf-avt-rtp-ipmr-08

	Regards,

	Yury Morzeev

	-----Original Message-----

	To: Roni Even

	Cheers

	Magnus Westerlund

	

	-- 

	Colin Perkins

	http://csperkins.org/

	

	

	http://www.eset.com

	
	
	http://www.eset.com

-- 

Colin Perkins

http://csperkins.org/