Subject: Re: [AVT] I-D Action:draft-ietf-avt-rtp-rfc3984bis-08.txt

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 20 Oct 2009 15:40:55 -0700

As written, I can see how the SDP negotiation is used to determine to
the maximum capabilities of the receivers (max-mbps, max-fs, max-br,
etc.). Once these maximums are determined, it is often the case that
multiple combinations of frame rate and resolution are possible. For
example, it may be possible to receive the following:

720p at a low frame rate
4CIF at a medium frame rate
CIF at a high frame rate

I do not see any mechanism to indicate a preference among these. It
seems such a mechanism would be useful. Am I overlooking something.

Thanks,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ye-Kui Wang
> Sent: Monday, September 21, 2009 1:54 PM
> To: [email-masked]
> Cc: 'Tom Taylor'; 'Roni Even'
> Subject: Re: [AVT] I-D Action:draft-ietf-avt-rtp-rfc3984bis-08.txt
> 
> 
> The changes compared to -07 are just those sent, by me, to the mailing
list
> on Thursday, 9/17.
> 
> BR, YK
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of [email-masked]
> > Sent: Monday, September 21, 2009 4:45 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: [AVT] I-D Action:draft-ietf-avt-rtp-rfc3984bis-08.txt
> >
> > A New Internet-Draft is available from the on-line
> > Internet-Drafts directories.
> > This draft is a work item of the Audio/Video Transport
> > Working Group of the IETF.
> >
> >
> > 	Title           : RTP Payload Format for H.264 Video
> > 	Author(s)       : Y. Wang, et al.
> > 	Filename        : draft-ietf-avt-rtp-rfc3984bis-08.txt
> > 	Pages           : 105
> > 	Date            : 2009-09-21
> >
> > This memo describes an RTP Payload format for the ITU-T
> > Recommendation H.264 video codec and the technically
> > identical ISO/IEC International Standard 14496-10 video
> > codec, excluding the Scalable Video Coding (SVC) extension
> > and the Multivew Video Coding extension, for which the RTP
> > payload formats are defined elsewhere.
> > The RTP payload format allows for packetization of one or
> > more Network Abstraction Layer Units (NALUs), produced by an
> > H.264 video encoder, in each RTP payload.  The payload format
> > has wide applicability, as it supports applications from
> > simple low bit-rate conversational usage, to Internet video
> > streaming with interleaved transmission, to high bit-rate
> > video-on-demand.
> >
> > This memo obsoletes RFC 3984.  Changes from RFC 3984 are
> > summarized in section 18.  Issues on backward compatibility
> > to RFC 3984 are discussed in section 17.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-rfc3984
> > bis-08.txt
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > Below is the data which will enable a MIME compliant mail
> > reader implementation to automatically retrieve the ASCII
> > version of the Internet-Draft.
> >
> 
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Ye-Kui Wang <[email-masked]>
Date: Wed, 21 Oct 2009 09:48:22 -0400

Preference indications could be useful. However, those should be something
generic not media type specific. If I am not wrong, the MMUSIC draft on
Image Attribute provides some kind of resolution preference indications, in
a generic manner. 

BR, YK 

> From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
> Sent: Tuesday, October 20, 2009 6:41 PM
> To: Ye-Kui Wang; [email-masked]
> Cc: Tom Taylor; Roni Even
> Subject: RE: [AVT] I-D Action:draft-ietf-avt-rtp-rfc3984bis-08.txt
> Importance: Low
> 
> As written, I can see how the SDP negotiation is used to 
> determine to the maximum capabilities of the receivers 
> (max-mbps, max-fs, max-br, etc.). Once these maximums are 
> determined, it is often the case that multiple combinations 
> of frame rate and resolution are possible. For example, it 
> may be possible to receive the following:
> 
> 720p at a low frame rate
> I do not see any mechanism to indicate a preference among 
> these. It seems such a mechanism would be useful. Am I 
> overlooking something.
> 
> Thanks,
> Charles
> 
> Behalf Of
> > > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > > Of [email-masked]
> > > Recommendation H.264 video codec and the technically identical 
> > > ISO/IEC International Standard 14496-10 video codec, 
> excluding the 
> > > Scalable Video Coding (SVC) extension and the Multivew 
> Video Coding 
> > > extension, for which the RTP payload formats are defined 
> elsewhere.
> > > The RTP payload format allows for packetization of one or more 
> > > Network Abstraction Layer Units (NALUs), produced by an
> > > H.264 video encoder, in each RTP payload.  The payload format has 
> > > wide applicability, as it supports applications from simple low 
> > > bit-rate conversational usage, to Internet video streaming with 
> > > interleaved transmission, to high bit-rate video-on-demand.
> > >
> summarized 
> > > in section 18.  Issues on backward compatibility to RFC 3984 are 
> > > discussed in section 17.
> > >
> > > Below is the data which will enable a MIME compliant mail reader 
> > > implementation to automatically retrieve the ASCII version of the 
> > > Internet-Draft.
> > >
> > 
> >

---

From: Roni Even <[email-masked]>
Date: Wed, 21 Oct 2009 16:15:52 +0200

Hi Charles,
I suggest you look at
http://tools.ietf.org/html/draft-ietf-mmusic-image-attributes-03 and see if
it addresses your requirements. The draft should be discussed in MMUSIC but
it is supposed to address your requirements
Roni

> Charles Eckel (eckelcu)
> Sent: Wednesday, October 21, 2009 12:41 AM
> __________ Information from ESET NOD32 Antivirus, version of virus
> signature database 4527 (20091020) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 
> 
> 
> 
> __________ Information from ESET NOD32 Antivirus, version of virus
> signature database 4527 (20091020) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 
> 
> __________ Information from ESET NOD32 Antivirus, version of virus
> signature database 4529 (20091021) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 

__________ Information from ESET NOD32 Antivirus, version of virus signature
database 4529 (20091021) __________

The message was checked by ESET NOD32 Antivirus.

http://www.eset.com

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 21 Oct 2009 11:37:42 -0700

Hi Roni,

Thanks for the link to the draft. At first glance, this does address my
requirements. I will raise any concerns I have with this draft to
MMUSIC. One suggestion I have for draft-ietf-avt-rtp-rfc3984bis-08.txt
is that it would be good to mention draft-ietf-mmusic-image-attributes
and add it to the references section.

Thanks,
Charles

> From: Roni Even [mailto:[email-masked]]
> Sent: Wednesday, October 21, 2009 7:16 AM
> To: Charles Eckel (eckelcu); 'Ye-Kui Wang'; [email-masked]
> Cc: 'Tom Taylor'
signature