Subject: [AVT] FW: New Version Notification for draft-begen-avt-rams-scenarios-00

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 1 Oct 2009 17:27:53 -0700

Hi,

I have submitted a new draft related to RAMS, which considers an important issue that was brought up earlier. When there are multiple RTP streams in the same multicast session or the client wants to concurrently acquire multiple RTP streams from different sessions, what should it do?

The purpose of this draft is to present the problem and make some recommendations. Thus, I put 'informational' as the intended goal.

Here is the link:
http://www.ietf.org/id/draft-begen-avt-rams-scenarios-00.txt

Your comments and discussion are welcome.
-acbegen

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Thursday, October 01, 2009 8:12 PM
To: Ali C. Begen (abegen)
Subject: New Version Notification for draft-begen-avt-rams-scenarios-00 

A new version of I-D, draft-begen-avt-rams-scenarios-00.txt has been successfuly submitted by Ali Begen and posted to the IETF repository.

Filename:	 draft-begen-avt-rams-scenarios
Revision:	 00
Title:		 Considerations for RAMS Scenarios
Creation_date:	 2009-10-01
WG ID:		 Independent Submission
Number_of_pages: 11

Abstract:
The Rapid Acquisition of Multicast RTP Sessions (RAMS) solution is a
method based on RTP and RTCP protocol family that enables an RTP
receiver to rapidly acquire and start usefully consuming the RTP
multicast data.  Upon a request from the RTP receiver, an auxiliary
unicast RTP retransmission session is set up between a retransmission
server and the RTP receiver, over which the reference information
about the new multicast stream the RTP receiver is about to join is
transmitted at an accelerated pace.  This often precedes, but may
also accompany, the multicast stream itself.  When there is only one
multicast stream to be acquired, the RAMS solution works in a
straightforward manner.  However, when there are two or more
multicast streams to be acquired from the same or different multicast
RTP sessions, care should be taken to configure each RAMS
appropriately.  This document provides example scenarios and make
practical recommendations.

The IETF Secretariat.

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 2 Oct 2009 07:39:36 -0700

I forgot to mention that the draft also attempts to explain the requirements on the feedback target selection. E.g., whether multiple sessions can share their feedback target or not. This is an important operational issue for RAMS. So, please review the document and provide your input.

-acbegen 

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali C. Begen
> (abegen)
> Sent: Thursday, October 01, 2009 8:28 PM
> To: [email-masked]
> Subject: [AVT] FW: New Version Notification fordraft-begen-avt-rams-scenarios-00
> 
> Hi,
> 
> I have submitted a new draft related to RAMS, which considers an important issue that was
> brought up earlier. When there are multiple RTP streams in the same multicast session or
> the client wants to concurrently acquire multiple RTP streams from different sessions,
> what should it do?
> 
> The purpose of this draft is to present the problem and make some recommendations. Thus, I
> put 'informational' as the intended goal.
> 
> Here is the link:
> A new version of I-D, draft-begen-avt-rams-scenarios-00.txt has been successfuly submitted
> by Ali Begen and posted to the IETF repository.
> 
> _______________________________________________
> Audio/Video Transport Working Group
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt

---

From: Jinwei Xia <[email-masked]>
Date: Tue, 20 Oct 2009 13:59:09 +0800

Hi,

I have submitted a new draft related to network-based rapid acquisition
without RTP receiver involvement by extending RTCP Rapid Acquisition, this
draft introduces a proxy acquisition function to perform rapid acquisition
related functionality on behalf of RTP receiver.

The purpose of this draft is to provide another candidate solution to
support rapid acquisition to RTP receiver.

Here is the link:
http://tools.ietf.org/html/draft-xia-avt-proxy-rapid-acquisition-00

BR
Jinwei

A new version of I-D, draft-xia-avt-proxy-rapid-acquisition-00.txt has been
successfuly submitted by Jinwei Xia and posted to the IETF repository.

Filename:	 draft-xia-avt-proxy-rapid-acquisition
Revision:	 00
Title:		 Network-based Rapid Acquisition of Multicast RTP Sessions
Creation_date:	 2009-10-19
WG ID:		 Independent Submission
Number_of_pages: 12

Abstract:
This document describes a network-based rapid acquisition mechanism which
reduces acquisition delay for an RTP receiver without supporting any rapid
acquisition related functionality.  The network is responsible for managing
rapid acquisition on behalf of the RTP receiver, including detecting SFGMP
message specified in [RFC4605] from the RTP receiver and launching the
required rapid acquisition signaling instead of the RTP receiver.  This
network-based rapid acquisition of multicast RTP session in this document is
referred to as Proxy Rapid Acquisition of Multicast Sessions (PRAMS).