Subject: Re: [AVTCORE] Pete Resnick's Discuss on draft-ietf-avtcore-srtp-vbr-audio-03: (with DISCUSS)

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Nov 2011 10:50:28 -0500

AVTCORE Working Group:

Pete is making an argument that the text in this document could be published as Standards Track. We've walked through the normative statements
in the document together and I see his argument. My only concern is whether there is any intent in the document to tell operators of existing deployments
to go change their configuration right away to avoid the security issues the document describes. Pete rightly points out that, as written, the document is 
providing guidance to new implementers, not to current operators.

Does anyone believe moving this to the Standards Track is the wrong thing to do?
Do you think the document needs to say anything more strongly about current deployments?

RjS

On Oct 31, 2011, at 8:28 AM, Pete Resnick wrote:

> Pete Resnick has entered the following ballot position for
> draft-ietf-avtcore-srtp-vbr-audio-03: Discuss
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> 
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
> 
> I don't see how this is remotely a BCP. This should be on the standards track. It is specifying all sorts of implementation parameters that are clearly testable, may have interoperability implications, and may change over time as we get implementation experience. (E.g., the length of the overhang period may be something that we specify differently, whether VAD is used or not may have interoperability implications, etc.). This discussion would have normally happened in the context of a security considerations section of a base protocol document and would have gone along the standards track with the base protocol. The fact that it is being published separately shouldn't change its treatment.
> 
> 
> 
>

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 17 Nov 2011 16:49:33 +0800

WG,

There has been no responses to this topic. If you are fine with this, I
still would appreciate a few responses to indicate that you are fine
with going to standards track.

My individual view is that there are no issue and appear appropriate.
This is something the WG chairs should have considered before requesting
the publication.

Cheers

Magnus

On 2011-11-01 23:50, Robert Sparks wrote:
> AVTCORE Working Group:
> 
> Pete is making an argument that the text in this document could be
> published as Standards Track. We've walked through the normative
> statements in the document together and I see his argument. My only
> concern is whether there is any intent in the document to tell
> operators of existing deployments to go change their configuration
> right away to avoid the security issues the document describes. Pete
> rightly points out that, as written, the document is providing
> guidance to new implementers, not to current operators.
> 
> Does anyone believe moving this to the Standards Track is the wrong
> thing to do? Do you think the document needs to say anything more
> strongly about current deployments?
> 
> RjS
> 
> 
>> When responding, please keep the subject line intact and reply to
>> all email addresses included in the To and CC lines. (Feel free to
>> cut this introductory paragraph, however.)
>> 
>> Please refer to
>> http://www.ietf.org/iesg/statement/discuss-criteria.html for more
>> information about IESG DISCUSS and COMMENT positions.
>> 
>> 
>> 
I don't see how this is remotely a BCP. This should be on the standards
track. It is specifying all sorts of implementation parameters that are
clearly testable, may have interoperability implications, and may change
over time as we get implementation experience. (E.g., the length of the
overhang period may be something that we specify differently, whether
VAD is used or not may have interoperability implications, etc.). This
discussion would have normally happened in the context of a security
considerations section of a base protocol document and would have gone
along the standards track with the base protocol. The fact that it is
being published separately shouldn't change its treatment.
>> 
>> 
>> 
>> 
> 
> _______________________________________________ Audio/Video Transport
> Core Maintenance [email-masked] 
> https://www.ietf.org/mailman/listinfo/avt
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 17 Nov 2011 09:02:19 +0000

Well you asked, so: I'm fine with making it standards-track, fwiw.
I'm not sure if "Guidelines" is an appropriate word in the document's title for a standards-track doc, but I don't care - just noting it. 

-hadriel

On Nov 17, 2011, at 3:49 AM, Magnus Westerlund wrote:

> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 17 Nov 2011 17:03:46 +0800

I looked at the document before the last call and my impression is that standards track is more appropriate as well. 

-acbegen

---

From: Colin Perkins <[email-masked]>
Date: Thu, 17 Nov 2011 17:09:36 +0800

I don't care either way. Standards track is fine.
Colin

-- 
Colin Perkins
http://csperkins.org/