Subject: [AVTCORE] [Technical Errata Reported] RFC3550 (3263)

From: RFC Errata System <[email-masked]>
Date: Mon, 18 Jun 2012 11:39:04 -0700 (PDT)

The following errata report has been submitted for RFC3550,
"RTP: A Transport Protocol for Real-Time Applications".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3550&eid=3263

--------------------------------------
Type: Technical
Reported by: Pieter Demuytere <[email-masked]>

Section: 6.4.1

Original Text
-------------
cumulative number of packets lost: 24 bits The total number of RTP data packets from source SSRC_n that have been lost since the beginning of reception. This number is defined to be the number of packets expected less the number of packets actually received, where the number of packets received includes any which are late or duplicates. Thus, packets that arrive late are not counted as lost, and the loss may be negative if there are duplicates. The number of packets expected is defined to be the extended last sequence number received, as defined next, less the initial sequence number received. This may be calculated as shown in Appendix A.3.

Corrected Text
--------------
cumulative number of packets lost: 24 bits The total number of RTP data packets from source SSRC_n that have been lost since the beginning of reception. This number is defined to be the number of packets expected less the number of packets actually received, where the number of packets received includes any which are late or duplicates. Thus, packets that arrive late are not counted as lost, and the loss may be negative if there are duplicates. The number of packets expected is defined to be the extended highest sequence number received, as defined next, less the initial sequence number received. This may be calculated as shown in Appendix A.3.

Notes
-----
Changed 

The number of packets expected is defined to be the extended last sequence number received...

Into

The number of packets expected is defined to be the extended highest sequence number received...

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3550 (draft-ietf-avt-rtp-new-12)
--------------------------------------
Title               : RTP: A Transport Protocol for Real-Time Applications
Publication Date    : July 2003
Author(s)           : H. Schulzrinne, S. Casner, R. Frederick, V. Jacobson
Category            : DRAFT STANDARD
Source              : Audio/Video Transport
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: Stephen Casner <[email-masked]>
Date: Mon, 18 Jun 2012 15:13:48 -0700 (PDT)

I consider this erratum to be valid.  The quoted paragraph says
"extended last sequence number received, as defined next", whereas
what is defined next is "extended highest sequence number received".
I think we made that terminology change but neglected to change the
usage in the quoted paragraph.

I think this erratum is not too serious, however.  I think most
readers will figure it out quickly.

                                                        -- Steve

---

From: "Frederick, Ron" <[email-masked]>
Date: Mon, 18 Jun 2012 23:00:41 +0000

I'm good with this change.

On Jun 18, 2012, at 3:13 PM, Stephen Casner wrote:

                                                       -- Steve

--------------------------------------
Type: Technical
Reported by: Pieter Demuytere <[email-masked]<mailto:[email-masked]>>

Section: 6.4.1

Original Text
-------------

Corrected Text
--------------

Notes
-----
Changed

Into

Instructions:
-------------

--
Ron Frederick
[email-masked]<mailto:[email-masked]>