Subject: Re: [AVTCORE] [Editorial Errata Reported] RFC6679 (3586)

From: Magnus Westerlund <[email-masked]>
Date: Wed, 10 Apr 2013 15:19:19 +0200

WG,

I have submitted this Errata. I would personally recommend that this
will be put into Verified due to the common practice to code according
to examples rather than the normative ABNF.

I hope people can provide any input on this within the next 2 weeks.

Cheers

Magnus
(As Individual)

On 2013-04-10 15:12, RFC Errata System wrote:
> The following errata report has been submitted for RFC6679,
> "Explicit Congestion Notification (ECN) for RTP over UDP".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6679&eid=3586
> 
> --------------------------------------
> Type: Editorial
> Reported by: Magnus Westerlund <[email-masked]>
> 
> Section: 12.1
> 
> Original Text
> -------------
>    The Offer:
> 
> ...
>       a=ecn-capable-rtp: ice rtp ect=0 mode=setread
> ...
> 
>    The Answer:
> ...
>       a=ecn-capable-rtp: ice ect=0 mode=readonly
> ...
> 
> Corrected Text
> --------------
>    The Offer:
> 
> ...
>       a=ecn-capable-rtp: ice,rtp ect=0; mode=setread
> ...
> 
>    The Answer:
> ...
>       a=ecn-capable-rtp: ice ect=0; mode=readonly
> ...
> 
> Notes
> -----
> The examples does not match the ABNF rules for the
> a=ecn-capaable-rtp attribute. Two issues are present, first the
> init method list must be comma separated with no spaces, secondly
> any additional parameters shall be semi colon plus space
> separated. Therefore both a=ecn-capable-rtp lines have been
> corrected.
> 
> This is primarily an editorial issues but people needs to aware of
> the errors in the example.
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC6679 (draft-ietf-avtcore-ecn-for-rtp-08)
> --------------------------------------
> Title               : Explicit Congestion Notification (ECN) for RTP over UDP
> Publication Date    : August 2012
> Author(s)           : M. Westerlund, I. Johansson, C. Perkins, P. O'Hanlon, K. Carlberg
> Category            : PROPOSED STANDARD
> Source              : Audio/Video Transport Core Maintenance
> Area                : Real-time Applications and Infrastructure
> Stream              : IETF
> Verifying Party     : IESG
> 
> 

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: RFC Errata System <[email-masked]>
Date: Wed, 10 Apr 2013 06:12:56 -0700 (PDT)

Section: 12.1

Original Text
-------------
   The Offer:

...

   The Answer:
...

Corrected Text
--------------
   The Offer:

...

   The Answer:
...

Notes
-----
The examples does not match the ABNF rules for the a=ecn-capaable-rtp attribute. Two issues are present, first the init method list must be comma separated with no spaces, secondly any additional parameters shall be semi colon plus space separated. Therefore both a=ecn-capable-rtp lines have been corrected. 

This is primarily an editorial issues but people needs to aware of the errors in the example.

Instructions:
-------------

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 11 Apr 2013 15:04:32 +0300

Hi,

would anybody object to put this erratum into the "held for document
update" status?

Cheers,

Gonzalo

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 16 Apr 2013 10:45:10 +0200

> would anybody object to put this erratum into the "held for document

I am okay with held for document update, although I would prefer
verified as I think it is an important, but editorial errata.

Cheers

Magnus

> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
> 
> 

-- 

Magnus Westerlund

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 18 Apr 2013 09:27:29 +0300

Hi Magnus,

yes, I agree it is important. I have just verified it.

Cheers,

Gonzalo