Subject: Re: [AVTCORE] WGLC on draft-ietf-avtcore-rtp-multi-stream-optimisation-06 - my comments

From: "Roni Even" <[email-masked]>
Date: Fri, 25 Sep 2015 19:23:37 +0300

Hi,

The document looks OK

Some comments and nits

1.       In section 1 "Consider a session  comprising ten participants, each
sending three media streams with  their own SSRC.  There will be 30 SSRCs in
such an RTP session, and
   30 RTCP reception reports will be sent per reporting interval as each
SSRC reports on all the others." Are there 30 RTCP reception reports or 270
if all 10 see all the session?  

2.       Section 3.2.1 third paragraph "even if the some or" should be "even
if some or"

3.       In section 3.3 replace chose with choose

Roni Even as individual

 

From: Roni Even [mailto:[email-masked]] 
Sent: Thursday, August 06, 2015 10:51 AM
To: [email-masked]
Subject: WGLC on draft-ietf-avtcore-rtp-multi-stream-optimisation-06

Hi,

The chairs would like to start a 5 week WGLC for
draft-ietf-avtcore-rtp-multi-stream-optimisation-06
<https://tools.ietf.org/html/draft-ietf-avtcore-rtp-multi-stream-optimisatio
n-06>  .  The longer WGLC is due to summer vacation and having a WGLC on
three documents

Please post your review comments, including an indication as to whether you
believe the document is ready to progress, no later than Thursday, September
10th.

Thanks,

Roni Even 

AVTcore co-chair

  _____

---

From: Colin Perkins <[email-masked]>
Date: Mon, 28 Sep 2015 14:51:58 +0100

Hi,

> On 25 Sep 2015, at 17:23, Roni Even <[email-masked]> wrote:
> 
> Hi,
> The document looks OK
> Some comments and nits
>  
> 1.       In section 1 “Consider a session  comprising ten participants, each sending three media streams with  their own SSRC.  There will be 30 SSRCs in such an RTP session, and
>    30 RTCP reception reports will be sent per reporting interval as each  SSRC reports on all the others.” Are there 30 RTCP reception reports or 270 if all 10 see all the session?  
> 

Each of the 30 SSRCs will send an RTCP Sender Report/Receiver Report packet. Each of those packets will contain several report blocks. I’ll try to clarify the text.

> 2.       Section 3.2.1 third paragraph “even if the some or” should be “even if some or”
> 

Will fix.

-- 
Colin Perkins
https://csperkins.org/

---

From: "Roni Even" <[email-masked]>
Date: Mon, 28 Sep 2015 17:54:32 +0300

Hi,
Inline,
Roni

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Monday, September 28, 2015 4:52 PM
To: Roni Even
Cc: [email-masked]
Subject: Re: [AVTCORE] WGLC on draft-ietf-avtcore-rtp-multi-stream-optimisation-06 - my comments

Hi,

RE:  My understanding that without grouping as also in the example in section 4.1 each SSRC will send 27 RTCP SR/RR since it need to send to each SSRC he received from and he gets 27. Again this depends on the topology.

Will fix.

-- 
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Mon, 28 Sep 2015 16:09:52 +0100

> On 28 Sep 2015, at 15:54, Roni Even <[email-masked]> wrote:
> 
> Hi,
> Inline,
> Roni
> 

Each SSRC will send an SR/RR packet. That SR/RR packets includes reports on all 30 SSRCs.

-- 
Colin Perkins
https://csperkins.org/

---

From: "Roni Even" <[email-masked]>
Date: Mon, 28 Sep 2015 19:55:40 +0300

Hi Colin,
I think it may be due to the question how many RR reports and how many packets. Section 4.1 talk about packets

"consider a  scenario in which the two endpoints in a session each have a hundred
   sources, of which eight each are sending within any given reporting
   interval."
  " In a report interval in this scenario, there will, as a baseline, be
   200 SDES packets, 184 RR packets, and 16 SR packets."

Roni

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]] 
Sent: Monday, September 28, 2015 6:10 PM
To: Roni Even
Cc: [email-masked]
Subject: Re: [AVTCORE] WGLC on draft-ietf-avtcore-rtp-multi-stream-optimisation-06 - my comments

-- 
Colin Perkins
https://csperkins.org/