Subject: Re: [AVTCORE] Fwd: Technical - Re: [Editorial Errata Reported] RFC7273 (4450)

From: Magnus Westerlund <[email-masked]>
Date: Tue, 6 Oct 2015 11:33:31 +0200

Hi Kevin,

Can you please review my previous email in detail:
https://mailarchive.ietf.org/arch/msg/avt/kjoyUZh-9c4lYMM6pXQhH30TebY

I think you need to confirm on what changes that is really proposed 
here, and thus my feedback is relevant for this.

However, I have so far seen no one objecting to the general intention to 
at least make alignment with the examples?

Cheers

Magnus Westerlund
(AVTCORE chair)

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Kevin Gross <[email-masked]>
Date: Thu, 8 Oct 2015 12:37:55 -0600

Yes, I will take your discussion into account when proposing final ABNF
changes. I wanted first to make sure there were no objection to the general
proposal of fixing this by conforming ABNF to examples. Since we have seen
no objections, I will proceed to prepare a revision.

Kevin Gross - AVA Networks

On Tue, Oct 6, 2015 at 3:33 AM, Magnus Westerlund <
[email-masked]> wrote:

> I think you need to confirm on what changes that is really proposed here,
> and thus my feedback is relevant for this.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 8 Oct 2015 17:26:06 -0400

On 10/8/15 2:37 PM, Kevin Gross wrote:
> changes. I wanted first to make sure there were no objection to the
> general proposal of fixing this by conforming ABNF to examples. Since we
> have seen no objections, I will proceed to prepare a revision.

You could simply do this:

    ; PTP domain allowed characters: 0x21-0x7E (IEEE 1588-2002)
    ptp-domain-name = "domain-name=" ptp-domain-intro 1*15ptp-domain-char
    ptp-domain-char = %x21-7E           ; (printable ascii)
    ptp-domain-intro = %x21-2F/%x3A-7E  ; (omit digits)

    ; PTP domain allowed number range: 0-127 (IEEE 1588-2008)
    ptp-domain-nmbr = "domain-nmbr=" ptp-domain-dgts
    ptp-domain-dgts = ptp-domain-n1 / ptp-domain-n2 / ptp-domain-n3
    ptp-domain-n1   = DIGIT             ; 0-9
    ptp-domain-n2   = POS-DIGIT DIGIT   ; 10-99
    ptp-domain-n3   = ("10"/"11") DIGIT ; 100-119
                    / "12" %x30-37      ; 120-127

(If it starts with a digit it is a number, else it is a name.)

	Thanks,
	Paul

> On Tue, Oct 6, 2015 at 3:33 AM, Magnus Westerlund
> <[email-masked] <mailto:[email-masked]>>
> wrote:
>
>     Hi Kevin,
>
>     However, I have so far seen no one objecting to the general
>     intention to at least make alignment with the examples?
>
>     Cheers
>
>     Magnus Westerlund
>     (AVTCORE chair)
>
>
>     --
>
>     Magnus Westerlund
>
>     <tel:%2B46%2010%207148287>
>     <tel:%2B46%2073%200949079>
>     <mailto:[email-masked]>
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>