Subject: Re: [AVTCORE] [Technical Errata Reported] RFC3611 (4597)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 4 Apr 2016 14:24:38 -0300

Hi,

I have looked at this errata. It appears to be correct. I checked Liu's 
calculation and get the same value. I think the reason the wrong value 
is in the RFC is due that the authors calculated the 33% loss value and 
used that to calculate the burst density, rather than 4/12s.

As this can be confusing when implementing I propose that we verify this 
Errata.

Please provide any feedback on this proposal no later than the 18th of 
April.

Cheers

Magnus Westerlund

Den 2016-01-22 kl. 03:10, skrev RFC Errata System:
> The following errata report has been submitted for RFC3611,
> "RTP Control Protocol Extended Reports (RTCP XR)".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=3611&eid=4597
>
> --------------------------------------
> Type: Technical
> Reported by: Liu Yuanlong <[email-masked]>
>
> Section: 4.7.2
>
> Original Text
> -------------
> burst density 84, which corresponds to 33%
>
> Corrected Text
> --------------
> burst density 85, which corresponds to 33%
>
> Notes
> -----
> error calculation for burst density, burst density=4/12*256=85.33...â‰ˆ85
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC3611 (draft-ietf-avt-rtcp-report-extns-06)
> --------------------------------------
> Title               : RTP Control Protocol Extended Reports (RTCP XR)
> Publication Date    : November 2003
> Author(s)           : T. Friedman, Ed., R. Caceres, Ed., A. Clark, Ed.
> Category            : PROPOSED STANDARD
> Source              : Audio/Video Transport
> Area                : Real-time Applications and Infrastructure
> Stream              : IETF
> Verifying Party     : IESG
>
>

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Alan Clark <[email-masked]>
Date: Tue, 5 Apr 2016 14:32:55 -0400

Hi Magnus

As the author of that section of RFC 3611 I concur that the errata 
report is correct and the suggested change should be made.

Regards

Alan Clark

On 4/4/16 1:24 PM, Magnus Westerlund wrote:
> Hi,
>
> I have looked at this errata. It appears to be correct. I checked 
> Liu's calculation and get the same value. I think the reason the wrong 
> value is in the RFC is due that the authors calculated the 33% loss 
> value and used that to calculate the burst density, rather than 4/12s.
>
> As this can be confusing when implementing I propose that we verify 
> this Errata.
>