Subject: [AVTCORE] Is SSRC 0 a valid SSRC?

From: Harald Alvestrand <[email-masked]>
Date: Tue, 2 Jan 2018 11:56:52 +0100

I was trying to find out whether or not the value 0 (zero) for SSRC is
valid or not.

RFC 3550 seems to be silent on the subject, but I believe I've seen some
other specs use zero as "invalid value" - these may be just placeholders
(as for TMMBR), or they might be something that causes trouble for using
SSRC 0 as a real value.

Does anyone have a definite statement one way or the other on this?

Harald

---

From: Colin Perkins <[email-masked]>
Date: Tue, 2 Jan 2018 11:18:08 +0000

> On 2 Jan 2018, at 10:56, Harald Alvestrand <[email-masked]> wrote:
> 

RFC 3550 says 32 bits, “SHOULD be chosen randomly”, and doesn’t mention zero as a special case. From that, I’d consider zero to be a valid SSRC.

-- 
Colin Perkins
https://csperkins.org/

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 2 Jan 2018 12:43:51 +0100

Hi,

To my knowledge the specifications that defines that the SSRC field 
shall be set to 0 is for place holders, where the field is actually not 
used. I also consider 0 as a valid SSRC value. I wished it had been 
reserved, but that is my wish and not what the specifications says.

Cheers

Magnus Westerlund

-- 

Magnus Westerlund

----------------------------------------------------------------------
Media Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 2 Jan 2018 11:58:17 +0000

Hi,
Agree with Magnus, for TMMBR it is a place holder for the media sender since there can be multiple FCI and the media sender is listed in the FCI and should be retrieved from there. 

I also looked at the c-code example in RFC3550 A.6 for generating a random 32-bit identifier and even though it is not normative it does not preclude the zero value.

Roni

-----Original Message-----
From: avt [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Tuesday, January 02, 2018 1:44 PM
To: Colin Perkins; Harald Alvestrand
Cc: [email-masked]
Subject: Re: [AVTCORE] Is SSRC 0 a valid SSRC?

Hi,

To my knowledge the specifications that defines that the SSRC field shall be set to 0 is for place holders, where the field is actually not used. I also consider 0 as a valid SSRC value. I wished it had been reserved, but that is my wish and not what the specifications says.

Cheers

Magnus Westerlund

Den 2018-01-02 kl. 12:18, skrev Colin Perkins:
>> I was trying to find out whether or not the value 0 (zero) for SSRC 
>> is valid or not.
>>
>> RFC 3550 seems to be silent on the subject, but I believe I've seen 
>> some other specs use zero as "invalid value" - these may be just 
>> placeholders (as for TMMBR), or they might be something that causes 
>> trouble for using SSRC 0 as a real value.
>>

-- 

Magnus Westerlund

---

From: Simon Perreault <[email-masked]>
Date: Tue, 2 Jan 2018 09:56:24 -0500

Full agreement with everyone in the thread.

Some data about real-world implementation:
I've looked at two RTP implementation of ours that handle production
traffic. Both generate SSRCs without excluding zero, and both do not treat
incoming zero as special in any way as far as I can see.

Simon

2018-01-02 6:58 GMT-05:00 Roni Even (A) <[email-masked]>:

> Hi,
> Agree with Magnus, for TMMBR it is a place holder for the media sender
> since there can be multiple FCI and the media sender is listed in the FCI
> and should be retrieved from there.
>
> I also looked at the c-code example in RFC3550 A.6 for generating a random
> 32-bit identifier and even though it is not normative it does not preclude
> the zero value.
>
> Roni
>
> To my knowledge the specifications that defines that the SSRC field shall
> be set to 0 is for place holders, where the field is actually not used. I
> also consider 0 as a valid SSRC value. I wished it had been reserved, but
> that is my wish and not what the specifications says.
>
> Cheers
>
> Magnus Westerlund
>
>
> > RFC 3550 says 32 bits, “SHOULD be chosen randomly”, and doesn’t mention
> zero as a special case. From that, I’d consider zero to be a valid SSRC.
> >
>
> --
>
> Magnus Westerlund
>
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Stephen Casner <[email-masked]>
Date: Tue, 2 Jan 2018 15:55:42 -0800 (PST)

Remember that the base RTP spec operates with a companion profile
spec.  It would be legal for a profile to futher constrain the SSRC
space.

                                                        -- Steve

On Tue, 2 Jan 2018, Roni Even (A) wrote:

> > RFC 3550 says 32 bits, "SHOULD be chosen randomly", and doesn't mention zero as a special case. From that, I'd consider zero to be a valid SSRC.
> >
>
> --
>
> Magnus Westerlund
>