Subject: [avtext] Resolving editor's note on "End Point" in RTP grouping taxonomy draft

From: Bo Burman <[email-masked]>
Date: Tue, 2 Dec 2014 07:58:02 +0000

Hi,

There's an editor's note in draft-ietf-avtext-rtp-grouping-taxonomy-03<https://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-grouping-taxonomy/> section 2.2.1 pondering whether the current "End Point" or the single-word "Endpoint" should be used as term. This editor's note needs to be resolved.

I would like see this changed to the single-word term "Endpoint", since I believe it is a more used term in RTP context (based on having searched through various RTP-related documents), and I also believe the semantics in this draft aligns well with the use of the term "endpoint" in those documents.

To get a sense of the possible impact of this change to documents that references this draft, I have searched the IETF database for documents that both references this draft and uses any form of "end point", "end-point" or "endpoint". I can find only two documents that references the taxonomy draft, uses any form of the term, and that are too far progressed to change;

*         draft-ietf-dart-dscp-rtp<https://datatracker.ietf.org/doc/draft-ietf-dart-dscp-rtp/>, uses the term "endpoint" (in RFC Ed Queue)

*         draft-ietf-payload-rtp-h265<https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-h265/>, uses "endpoint" (publication requested)

I can only find two less progressed documents (omitting any pre-WG Last Call documents) that references the taxonomy draft and that uses any form of the term;

*         draft-ietf-rtcweb-rtp-usage<https://datatracker.ietf.org/doc/draft-ietf-rtcweb-rtp-usage/>, uses "End-point" (WG consensus, waiting for write-up)

*         draft-ietf-avtcore-rtp-topologies-update<https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-topologies-update/>, uses "End Point" (in WG Last Call)

So, the only documents that are too far progressed to change both use the single-word form "endpoint", which is thus fully in line with my suggested change.

If you oppose this change for some reason, please speak up. If there are no major objections, I will make this change in the next version.

Cheers,
Bo

---

From: Colin Perkins <[email-masked]>
Date: Tue, 2 Dec 2014 10:58:21 +0000

No objection on my part. I’ll change the rtcweb-rtp-usage draft to match the agreed term - let me know.

Colin

On 2 Dec 2014, at 07:58, Bo Burman <[email-masked]> wrote:
> Hi,
>  
> There’s an editor’s note in draft-ietf-avtext-rtp-grouping-taxonomy-03 section 2.2.1 pondering whether the current “End Point” or the single-word “Endpoint” should be used as term. This editor’s note needs to be resolved.
>  
> I would like see this changed to the single-word term “Endpoint”, since I believe it is a more used term in RTP context (based on having searched through various RTP-related documents), and I also believe the semantics in this draft aligns well with the use of the term “endpoint” in those documents.
>  
> To get a sense of the possible impact of this change to documents that references this draft, I have searched the IETF database for documents that both references this draft and uses any form of “end point”, “end-point” or “endpoint”. I can find only two documents that references the taxonomy draft, uses any form of the term, and that are too far progressed to change;
> ·         draft-ietf-dart-dscp-rtp, uses the term “endpoint” (in RFC Ed Queue)
> ·         draft-ietf-payload-rtp-h265, uses “endpoint” (publication requested)
>  
> ·         draft-ietf-rtcweb-rtp-usage, uses ”End-point” (WG consensus, waiting for write-up)
> ·         draft-ietf-avtcore-rtp-topologies-update, uses “End Point” (in WG Last Call)
>  
> So, the only documents that are too far progressed to change both use the single-word form “endpoint”, which is thus fully in line with my suggested change.
>

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 2 Dec 2014 16:26:57 +0000

Same re topologies-update.
(We actually changed it to "End Point" for alignment with the taxonomy draft in the first place.)
Stephan

From: Colin Perkins <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 2, 2014 at 02:58
To: Bo Burman <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [avtext] Resolving editor's note on "End Point" in RTP grouping taxonomy draft

No objection on my part. I'll change the rtcweb-rtp-usage draft to match the agreed term - let me know.

Colin

On 2 Dec 2014, at 07:58, Bo Burman <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

·         draft-ietf-dart-dscp-rtp<https://datatracker.ietf.org/doc/draft-ietf-dart-dscp-rtp/>, uses the term "endpoint" (in RFC Ed Queue)

·         draft-ietf-payload-rtp-h265<https://datatracker.ietf.org/doc/draft-ietf-payload-rtp-h265/>, uses "endpoint" (publication requested)

·         draft-ietf-rtcweb-rtp-usage<https://datatracker.ietf.org/doc/draft-ietf-rtcweb-rtp-usage/>, uses "End-point" (WG consensus, waiting for write-up)

·         draft-ietf-avtcore-rtp-topologies-update<https://datatracker.ietf.org/doc/draft-ietf-avtcore-rtp-topologies-update/>, uses "End Point" (in WG Last Call)

Cheers,
Bo

---

From: Bo Burman <[email-masked]>
Date: Thu, 18 Dec 2014 10:04:20 +0000

Since there was no objections to my proposal to change to "Endpoint", I will make this change in the next version of the draft.
Since the WGLC ended December 5th, I will shortly submit an updated version, addressing the comments received during the WGLC.

/Bo

From: Stephan Wenger [mailto:[email-masked]]
Sent: den 2 december 2014 17:27
To: Colin Perkins; Bo Burman
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [avtext] Resolving editor's note on "End Point" in RTP grouping taxonomy draft

Colin

Cheers,
Bo