Subject: Re: [babel] 7298bis

From: Denis Ovsienko <[email-masked]>
Date: Mon, 05 Mar 2018 23:32:12 +0000

---- On Sun, 14 Jan 2018 22:08:18 +0000 Denis Ovsienko  wrote ---- 
>Hello list. 
> 
>This is to answer the question I have received directly, because it relates to this WG work. 
> 
>I would like to see for myself how well 7298bis would work with the current 6126bis, for that I will need to resolve the issue previously discussed on the list and if it works on paper and in the code, it will need to become a working group document (the currently missing security reference). 
> 
>If you have any input to make in this regard, please reply back to the list. 

Hello again.

Good news, there is a feasible solution to the canned replay attack, that's what Babel speakers would need to do in addition to RFC 7298:

1. Echo remote TS/PC number back in the IHU TLVs they send.
2. Maintain a table that records at what point in time what local TS/PC number had been issued. The key points here is to index by timestamp, to keep the index unique and to record only the first TS/PC number for any given timestamp.
3. Use that received (echoed) per-IHU TS/PC number to compare with the local issued TS/PC numbers from the table.

This way it becomes possible to have a simple parameter that controls the maximum lag in the TS/PC number space, but in units of real time seconds and regardless of packet rate.

draft-ovsienko-babel-rfc7298bis-00 describes this solution in more detail, its differences against RFC 7298 are:
* the above arrangements specified in a more formal manner: new sections 3.8, 3.9, 4.4; updated sections 5.3 and 5.4;
* assorted minor fixups to make it a more modern document.

It remains to be done to review the text that discusses Babel extensions, IANA considerations, cryptographic hash algorithms and the likes that have meaningfully changed since 2014. If the working group is happy with the described solution and is interested to adopt this I-D, I can make the remaining fixups and try to focus on the running code part of this work.

Cheers.

-- 

    Denis Ovsienko

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Tue, 06 Mar 2018 16:03:38 +0100

Denis Ovsienko <[email-masked]> writes:

> Good news, there is a feasible solution to the canned replay attack,
> that's what Babel speakers would need to do in addition to RFC 7298:

Awesome!

> * assorted minor fixups to make it a more modern document.

Hmm, I am not quite sure I quite understand the details of what you are
proposing from those updates; but I would have to re-read the whole
thing to be sure. I'll see if I can find the time to do that soonish :)

> It remains to be done to review the text that discusses Babel
> extensions, IANA considerations, cryptographic hash algorithms and the
> likes that have meaningfully changed since 2014. If the working group
> is happy with the described solution and is interested to adopt this
> I-D, I can make the remaining fixups and try to focus on the running
> code part of this work.

I think I probably have some opinions one the details once I've had a
chance to read it again (and maybe even try to implement it), but other
than that, cool! :)

-Toke