Subject: [babel] Use of packet trailer -- please protest now or never

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 18 Jul 2018 16:41:20 +0200

Dear all,

There has been no objection to the use of the packet trailer by
draft-do-babel-hmac, and some amount of support (support from Toke, Clara,
Weronika and myself, weak support from David).  I'd like to update
rfc6126bis with a specification of the packet trailer (see Appendix A of
draft-do).

If you see any good reasons why we shouldn't be using the packet trailer,
please share them now, since I'd like to revise rfc6126bis.

Thanks,

-- Juliusz

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 18 Jul 2018 17:55:16 -0400

Although I think it is more common in IETF protocols to include such an
authentication inside the message being authenticated, there is no
technical reason not to use a trailer. So I'm fine with either way the WG
wants to go.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]

On Wed, Jul 18, 2018 at 10:41 AM, Juliusz Chroboczek <[email-masked]> wrote:

> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel
>

---

From: Denis Ovsienko <[email-masked]>
Date: Thu, 19 Jul 2018 09:53:09 +0100

---- On Wed, 18 Jul 2018 15:41:20 +0100 Juliusz Chroboczek <[email-masked]> wrote ---- 
 > please share them now, since I'd like to revise rfc6126bis. 

Juliusz, you have conveniently forgotten that draft-do-babel-hmac is _not_ a working group document at this time, and also that 6126 _is_ a working group document, and that changes to working group documents must reflect working group consensus, even when you are listed as the author or a co-author.

It is understandable you do not want to wait any longer because draft-do-babel-hmac, despite its document name, was mostly written by you, rather than Clara or Weronika. But this fact does not imply you can start, end, or override a WG adoption call on your own. This is a remit of the chairs.

-- 
    Denis Ovsienko

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 19 Jul 2018 12:17:00 +0200

>> I'd like to update rfc6126bis with a specification of the packet
>> trailer (see Appendix A of draft-do).

> Juliusz, you have conveniently forgotten that draft-do-babel-hmac is
> _not_ a working group document at this time, and also that 6126 _is_
> a working group document, and that changes to working group documents
> must reflect working group consensus, even when you are listed as the
> author or a co-author.

If you want me to refrain from updating rfc6126bis for the time being,
that's a reasonable request.

-- Juliusz