Subject: [babel] info-model: those darned metrics

From: "STARK, BARBARA H" <[email-masked]>
Date: Sun, 18 Aug 2019 22:13:17 +0000

It looks like I missed updating some of the language in the descriptions for calculated and received metrics.

It says "At least one of babel-route-calculated-metric and babel-route-received-metric MUST be non-zero. Having both be non-zero is expected for a route that is received and subsequently advertised."

I think it should be "At least one of babel-route-calculated-metric and babel-route-received-metric will be non-NULL. Having both be non-NULL is expected for a route that is received and subsequently advertised."

There's no need for normative language here, since the values are read-only and beyond the control of the info model.

Does anyone disagree with this?
Barbara

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 22 Aug 2019 18:35:39 +0000

> It says "At least one of babel-route-calculated-metric and babel-route-
> received-metric MUST be non-zero. Having both be non-zero is expected for
> a route that is received and subsequently advertised."
> 
> I think it should be "At least one of babel-route-calculated-metric and babel-
> route-received-metric will be non-NULL. Having both be non-NULL is
> expected for a route that is received and subsequently advertised."
> 
> There's no need for normative language here, since the values are read-only
> and beyond the control of the info model.

In discussions with Mahesh on the YANG model, he expressed a preference to have normative language of:
"At least one of babel-route-calculated-metric and babel-
route-received-metric MUST be non-NULL. Having both be non-NULL is
expected for a route that is received and subsequently advertised."

Would anyone have a problem with this?
Barbara