Subject: [babel] More about (H)MAC

From: Juliusz Chroboczek <[email-masked]>
Date: Mon, 12 Aug 2019 05:34:52 +0200

Dear all,

Re Babel-(H)MAC.

Blake2s is not an HMAC

During IESG review, Benjamin Kaduk mentioned that Blake2s (which is
a SHOULD) is not an HMAC but a generic keyed MAC.  He's right.  I'm going
to rename Babel-HMAC to Babel-MAC and tweak the draft to speak of keyed
MACs?  (I'm assuming here that HMAC is generally considered a special case
of keyed MAC -- if anyone knows otherwise, please let me know.)

Does anyone object to this, or have a better suggestion?

-- Juliusz

---

From: David Schinazi <[email-masked]>
Date: Mon, 12 Aug 2019 14:30:19 -0700

That sounds good to me.

David

On Mon, Aug 12, 2019 at 2:13 PM Juliusz Chroboczek <[email-masked]> wrote:

> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel
>

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Tue, 13 Aug 2019 11:53:59 +0200

> That sounds good to me.

No objections from me either...

-Toke