Subject: [babel] I-D Action: draft-ietf-babel-yang-model-03.txt

From: [email-masked]
Date: Thu, 22 Aug 2019 12:59:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Babel routing protocol WG of the IETF.

        Title           : YANG Data Model for Babel
        Authors         : Mahesh Jethanandani
                          Barbara Stark
	Filename        : draft-ietf-babel-yang-model-03.txt
	Pages           : 37
	Date            : 2019-08-22

Abstract:
   This document defines a data model for the Babel routing protocol.
   The data model is defined using the YANG data modeling language.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-babel-yang-model/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-babel-yang-model-03
https://datatracker.ietf.org/doc/html/draft-ietf-babel-yang-model-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-babel-yang-model-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 22 Aug 2019 13:05:01 -0700

This version of the draft closely tracks the -09 version of the information model that Barbara is about to post. In addition, it updates the Security section of the document (thanks Barbara), and adds several examples of Babel configuration (thanks Juliusz).

Enjoy!

> On Aug 22, 2019, at 12:59 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

Mahesh Jethanandani
[email-masked]

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 22 Aug 2019 22:37:17 +0000

If information-model is good to proceed (?), should we start WGLC on the YANG model? I think it's ready for WGLC.
Barbara

> -----Original Message-----
> 
> This version of the draft closely tracks the -09 version of the information
> model that Barbara is about to post. In addition, it updates the Security
> section of the document (thanks Barbara), and adds several examples of
> Babel configuration (thanks Juliusz).
> 
> Enjoy!
> 
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> > org_doc_draft-2Dietf-2Dbabel-2Dyang-2Dmodel_&d=DwICAg&c=LFYZ-
> o9_HUMeMT
> > SQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_iOjRzLegD
> > 04hmeefG8&s=AjP_NNrsKhvvtRB3_dHazihUcbQUY8OZI5xarpRPaw8&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dietf-2Dbabel-2Dyang-2Dmodel-2D03&d=DwICAg&c=LFYZ-
> o9_HUMeMTS
> > QicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_iOjRzLegD0
> > 4hmeefG8&s=XDT_z6LWxE-EOISiKS8v4pyyaXxvuo95rRzLalMfmmw&e=
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> > org_doc_html_draft-2Dietf-2Dbabel-2Dyang-2Dmodel-
> 2D03&d=DwICAg&c=LFYZ-
> > o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_
> > iOjRzLegD04hmeefG8&s=zLoc5L3C6b1_2-
> 8fvxTLW0FKnPHpFYAtZGGAHuGihk4&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcd
> > iff-3Furl2-3Ddraft-2Dietf-2Dbabel-2Dyang-2Dmodel-
> 2D03&d=DwICAg&c=LFYZ-
> > o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_
> > iOjRzLegD04hmeefG8&s=3_Q-7qmIRU-
> 303jl5JYXJpjYz4kEWbleQYGy3dEgdA0&e=
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern
> > et-2Ddrafts_&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfo
> > g&m=CSM4tDMAcQ5mo5ig0a4vXrbx_iOjRzLegD04hmeefG8&s=7NN-
> GZMWj_DTjzEgK0Wl
> > GQWtRWOvQWNylXvAM2mx3GQ&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_babel&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8T
> >
> q4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_iOjRzLegD04hmeefG8&s=rUTcW
> YJnELa2k2
> > bfGoAPDjTlA-2b1ifUVN53gcNI3Ck&e=
> 
> Mahesh Jethanandani
> [email-masked]
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_babel&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=CSM4tDMAcQ5mo5ig0a4vXrbx_iOjRzLegD04hmeefG8&
> s=rUTcWYJnELa2k2bfGoAPDjTlA-2b1ifUVN53gcNI3Ck&e=

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 22 Aug 2019 18:09:40 -0700

Hi Barbara,

The reason I have not asked for WGLC for the Babel YANG model is because it lacks a routing policy module. 

Let me follow up on that on a separate thread.

Cheers.

> On Aug 22, 2019, at 3:37 PM, STARK, BARBARA H <[email-masked]> wrote:
> 
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf>.
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht>
>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf>.
>>> https://urldefense.proofpoint.com/v2/url?u=https- <https://urldefense.proofpoint.com/v2/url?u=https->
>> 3A__www.ietf.org_rfcd
>>> submission until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>> 
>>> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern <https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern>
>>> [email-masked] <mailto:[email-masked]>
>>> https://urldefense.proofpoint.com/v2/url?u=https- <https://urldefense.proofpoint.com/v2/url?u=https->
>> 3A__www.ietf.org_mail
>> [email-masked] <mailto:[email-masked]>
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://urldefense.proofpoint.com/v2/url?u=https- <https://urldefense.proofpoint.com/v2/url?u=https->

Mahesh Jethanandani
[email-masked]

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 24 Aug 2019 00:29:06 +0200

> YANG model? I think it's ready for WGLC.

Has anyone reviewed it?

-- Juliusz

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Sat, 24 Aug 2019 01:22:43 +0000

I did. In gory detail. 
WGLC would be to ask others to review. 
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 24 Aug 2019 11:54:26 +0200

> I did. In gory detail. 

You're my hero, Barbara.  I want to be you when I grow up.

-- Juliusz