Subject: [babel] draft-ietf-babel-information-model Shepherd Review

From: Donald Eastlake <[email-masked]>
Date: Sun, 6 Oct 2019 16:38:51 -0400

Hi,

I think this draft is in pretty good shape. I have a suggested alternative
abstract and a few minor editorial comments as below.

Abstract: I'd like to suggest the alternative wording below.

This Babel Information Model provides structured data elements for a Babel
implementation reporting its current state and may allow limited
configuration of some such data elements. This information model can be
used as a basis for creating data models under various other data modeling
regimes.

Editorials: see below.
Section 1, 1st paragraph, remove last set of parentheses.
Section 1, 2nd paragraph, remove first set of parentheses.
Section 1, 2nd paragraph, last sentence, "may" -> "MAY".
Section 1.2, in list, insert "(true or false)" after "Boolean".
Section 2, in list of items not required to be read-only, for MAC-keys,
"use" -> "used" twice.
Section 3.8, in babel-key-use-verify, "comparing an incoming packet" ->
"comparing with the MAC in an incoming packet".

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 6 Oct 2019 16:45:26 -0400

Hi,

One other thing, it needs an IANA Considerations Section saying that no
IANA actions are required.

Thanks,
Donald

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 9 Oct 2019 15:55:07 +0000

Thanks for the review! Detailed acknowledgement in-line with <bhs>.
I’ll be posting an updated draft imminently. It will also include the IANA Considerations section from your other comment.
Barbara

From: Donald Eastlake <[email-masked]>
Sent: Sunday, October 06, 2019 4:39 PM
To: Babel at IETF <[email-masked]>
Cc: babel-chairs <[email-masked]>; [email-masked]
Subject: draft-ietf-babel-information-model Shepherd Review

Hi,

I think this draft is in pretty good shape. I have a suggested alternative abstract and a few minor editorial comments as below.

This Babel Information Model provides structured data elements for a Babel implementation reporting its current state and may allow limited configuration of some such data elements. This information model can be used as a basis for creating data models under various other data modeling regimes.

<bhs> Done, but with minor change: “various data modeling regimes” instead of “various other data modeling regimes” (because no “first” data modeling regimes is described to be “other” than).

Editorials: see below.
Section 1, 1st paragraph, remove last set of parentheses.
<bhs> Done
Section 1, 2nd paragraph, remove first set of parentheses.
<bhs> Done
Section 1, 2nd paragraph, last sentence, "may" -> "MAY".
<bhs> Done
Section 1.2, in list, insert "(true or false)" after "Boolean".
<bhs> Done
Section 2, in list of items not required to be read-only, for MAC-keys, "use" -> "used" twice.
<bhs> Changed “use”->”key used” (I found the “used” by itself to be ambiguous as to whether the subject of the verb was the parameter or the key)
Section 3.8, in babel-key-use-verify, "comparing an incoming packet" -> "comparing with the MAC in an incoming packet".
<bhs> Done

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]<mailto:[email-masked]>

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 9 Oct 2019 17:25:30 -0400

Hi Barbara.

I'm fine with all your changes. I'll submit the draft for publication shortly.

Thanks,
Donald