Subject: [babel] Minor format problem in draft-ietf-babel-yang-model-04

From: Donald Eastlake <[email-masked]>
Date: Thu, 2 Jan 2020 23:27:14 -0500

Hi Mahesh,

Happy New Year!

There seems to be a minor format problem in this draft, in particular four
lines, all identical, that are 76 characters long. Lines over 72 characters
are not allowed in Internet Drafts.

On page 34, page 35, page 36, and page 38 the following line occurs:
            xmlns:babel="urn:ietf:params:xml:ns:yang:ietf-babel">babel:babel
Is it possible to fold this into something like
            xmlns:babel=
                "urn:ietf:params:xml:ns:yang:ietf-babel">babel:babel
or just reduce the indent of those lines?

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 2 Jan 2020 23:21:19 -0800

Hi Donald,

Yes, that should be ok. And thanks for catching it.

Cheers.

Mahesh Jethanandani
[email-masked]

> On Jan 2, 2020, at 8:27 PM, Donald Eastlake <[email-masked]> wrote:
> 
> Hi Mahesh,
> 
> Happy New Year!
> 
> There seems to be a minor format problem in this draft, in particular four lines, all identical, that are 76 characters long. Lines over 72 characters are not allowed in Internet Drafts.
>

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 3 Jan 2020 13:32:55 -0500

Hi Mahesh,

You're welcome. My apologies for not noticing it earlier. Can you go ahead
and post a revision with this trivial change?

Thanks,
Donald

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 3 Jan 2020 13:21:43 -0800

Hi Donald,

In trying to make the changes you requested, I came across another change that needs to be pushed.

The information model suggests that babel-information-obj should maintain a list of metric-comp-algorithm that are supported by an implementation. The problem with just keeping a list in YANG is that there is no way to enforce that the implementation uses only those algorithms. To address the issue we had introduced the concept of features in -04 version of the draft.

Using the feature statement, the implementation can declare which of the metric-comp-algorithms it supports, which was the intention of having a list of those algorithms in the first place. As such, we do not need the global list anymore, and needs to be removed. I will be adding that change in the -05 version of the draft.

If you feel that it requires a short LC to be issued, please feel free to do so after I post the draft.

Thanks.

> On Jan 3, 2020, at 10:32 AM, Donald Eastlake <[email-masked]> wrote:
> 
> Hi Mahesh,
> 
> You're welcome. My apologies for not noticing it earlier. Can you go ahead and post a revision with this trivial change?
> 
> Thanks,
> Donald
>  [email-masked] <mailto:[email-masked]>
> 
> On Fri, Jan 3, 2020 at 2:21 AM Mahesh Jethanandani <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Donald,
> 
> [email-masked] <mailto:[email-masked]>
> 
> On Jan 2, 2020, at 8:27 PM, Donald Eastlake <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Mahesh,
>> 
>> Happy New Year!
>> 
>>  [email-masked] <mailto:[email-masked]>
Mahesh Jethanandani
[email-masked]

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 6 Jan 2020 14:39:38 +0000

Hi Mahesh,
In looking over this change, I'm trying to understand how indicating supported metric computation algorithms (expressed through feature + identity statements, but no leaf-list) differs from indicating supported security mechanisms, MAC algorithms, and certificate types (expressed through identity statements + leaf-list).

Why would we not use the same approach for all 4 of these?
Barbara

From: babel <[email-masked]> On Behalf Of Mahesh Jethanandani
Sent: Friday, January 03, 2020 4:22 PM
To: Donald Eastlake <[email-masked]>
Cc: Babel at IETF <[email-masked]>
Subject: Re: [babel] Minor format problem in draft-ietf-babel-yang-model-04

Hi Donald,

Thanks.

On Jan 3, 2020, at 10:32 AM, Donald Eastlake <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mahesh,

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]<mailto:[email-masked]>

On Fri, Jan 3, 2020 at 2:21 AM Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:
Hi Donald,

Cheers.
Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

On Jan 2, 2020, at 8:27 PM, Donald Eastlake <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mahesh,

Happy New Year!

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]<mailto:[email-masked]>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 6 Jan 2020 11:07:11 -0800

Hi Barbara,

You bring up a good point.

Have added feature statements for security, MAC and certificate types, and made the identity statements conditional on the features being declared. Also beefed up the example to show how the system could be configured for HMAC-SHA256 MAC algorithm.

Thanks.

> On Jan 6, 2020, at 6:39 AM, STARK, BARBARA H <[email-masked]> wrote:
> 
> Hi Mahesh,
> In looking over this change, I’m trying to understand how indicating supported metric computation algorithms (expressed through feature + identity statements, but no leaf-list) differs from indicating supported security mechanisms, MAC algorithms, and certificate types (expressed through identity statements + leaf-list).
>  
> On Jan 3, 2020, at 10:32 AM, Donald Eastlake <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Mahesh,
>  
Mahesh Jethanandani
[email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 15 Jan 2020 21:38:52 -0500

Hi Mahesh,

Thanks for posting an update to the Babel YANG draft. Does this includes
all the changes you currently think needed? If so, I think we could just do
a brief WG Last Call and then proceed to request publication.

For people's information, the diff against the previous version is
https://tools.ietf.org/rfcdiff?url2=draft-ietf-babel-yang-model-05.txt

Thanks,
Donald

On Mon, Jan 6, 2020 at 2:07 PM Mahesh Jethanandani <[email-masked]>
wrote:

> Have added feature statements for security, MAC and certificate types, and
> made the identity statements conditional on the features being declared.
> Also beefed up the example to show how the system could be configured for
> HMAC-SHA256 MAC algorithm.
>
> Thanks.
>
> In looking over this change, I’m trying to understand how indicating
> supported metric computation algorithms (expressed through feature +
> identity statements, but no leaf-list) differs from indicating supported
> security mechanisms, MAC algorithms, and certificate types (expressed
> through identity statements + leaf-list).
>
> *From:* babel <[email-masked]> *On Behalf Of *Mahesh Jethanandani
> *Sent:* Friday, January 03, 2020 4:22 PM
> *To:* Donald Eastlake <[email-masked]>
> *Cc:* Babel at IETF <[email-masked]>
> *Subject:* Re: [babel] Minor format problem in
> draft-ietf-babel-yang-model-04
>
> Hi Donald,
>
> The information model suggests that babel-information-obj should maintain
> a list of metric-comp-algorithm that are supported by an implementation.
> The problem with just keeping a list in YANG is that there is no way to
> enforce that the implementation uses only those algorithms. To address the
> issue we had introduced the concept of features in -04 version of the draft.
>
> Using the feature statement, the implementation can declare which of the
> metric-comp-algorithms it supports, which was the intention of having a
> list of those algorithms in the first place. As such, we do not need the
> global list anymore, and needs to be removed. I will be adding that change
> in the -05 version of the draft.
>
> On Fri, Jan 3, 2020 at 2:21 AM Mahesh Jethanandani <
> [email-masked]> wrote:
>
> Hi Donald,
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 16 Jan 2020 09:09:01 -0800

Hi Donald,

> On Jan 15, 2020, at 6:38 PM, Donald Eastlake <[email-masked]> wrote:
> 
> Hi Mahesh,
> 
> Thanks for posting an update to the Babel YANG draft. Does this includes all the changes you currently think needed?

Yes.

> If so, I think we could just do a brief WG Last Call and then proceed to request publication.

Okay.

Thanks.

> https://tools.ietf.org/rfcdiff?url2=draft-ietf-babel-yang-model-05.txt <https://tools.ietf.org/rfcdiff?url2=draft-ietf-babel-yang-model-05.txt>
> 
> Thanks,
> Donald
> On Mon, Jan 6, 2020 at 2:07 PM Mahesh Jethanandani <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Barbara,
> 
>> On Jan 6, 2020, at 6:39 AM, STARK, BARBARA H <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Mahesh,
>> From: babel <[email-masked] <mailto:[email-masked]>> On Behalf Of Mahesh Jethanandani
>> To: Donald Eastlake <[email-masked] <mailto:[email-masked]>>
>> Cc: Babel at IETF <[email-masked] <mailto:[email-masked]>>