Subject: Re: [babel] Alvaro Retana's Discuss on draft-ietf-babel-source-specific-07: (with DISCUSS and COMMENT)

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 21 Apr 2021 16:41:02 +0200

> I am balloting DISCUSS because I believe that the document is missing important
> considerations/details related to the operation of Babel in a network.  I hope
> these points should be easy to address.

In -08, I've rewritten and expanded the background section.  Please review
the new version.

> (a) While I understand the table above is just an example, it can be
> interpreted as indicating that B is the provider that assigned the
> 2001:DB8:0:2::/64 prefix.

This whole section has been rewritten.  It is hopefully now clear that
this is just an example of what could go wrong if we weren't careful, and
is not meant to be representative of actual usage.

> (b) How is the source address selected by the host?

I've added wording to explain that.  Please note that host behaviour is
outside the scope of this document, and that it is an open area of
research -- while the new text points at IPv6 address selection, at MPTCP,
at SCTP, and at ICE, I do not believe that any of these protocols provides
the final answer to this very interesting problem.

> (1) §4 talks about "lower layers", what are those?  Please be specific.

The text says "any lower layer that performs packet forwarding".  This is
meant to apply either to the TCAM or the kernel's forwarding engine,
depending on your implementation, but tries to avoid mentioning any
particular technology.

> (2) The second bullet in §4 says that "Babel...MUST either silently ignore any
> source-specific routes, or disambiguate..."  Given the required (use of MUST)
> nature of the disambiguation, I would like to see an algorithm for it, not just
> an example.  I do not include this point in the DISCUSS section because I think
> there are ways not to require disambiguation; perhaps something along the lines
> of:

>    ...SHOULD silently ignore any source-specific routes.  A router can also
>    choose to use a disambiguation algorithm (see SS-ROUTING for an example),
>    but the details are out of this document's scope.

The text says

      (see Section V.B of [SS-ROUTING] for such an algorithm);

> (3) §7.1: "Source Plen  The length of the advertised source prefix."  Indicate
> in bits.

Done.

-- Juliusz

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 22 Apr 2021 14:26:41 -0700

Juliusz:

Hi!  I hope you are doing well.

Thanks for the updates in the text.  I am clearing my DISCUSS.

Alvaro.