Subject: Re: [BXXPwg] terminology wrt "protocol binding" and "BEEP channel profiles"?

From: [email-masked]
Date: Fri, 18 May 2001 11:29:42 -0700

thanks for the note Marshall.

> hi. am i correct in summarizing your proposal to be:
> 
>  when talking outside the context of the BEEP specifications, use the
>  term "BEEP channel profile" when referring to what is called a "profile"
>  inside the BEEP specifications
> 
> if so, sounds like a fine idea to me.

That's part of the proposal. The other part involves how one more generally 
talks about the "binding" or "mapping" of another protocol onto BEEP, from 
outside the context of BEEP.

E.g. Such a binding can conceptually look like this (from outside the context 
of BEEP)..

           +----------------------------+
           | (some protocol, e.g. FOOP) |
           +----------------------------+ <-- the "protocol binding" for
           |  BEEP                      |     FOOP-over-BEEP
           +----------------------------+
           |  TCP                       |
           +----------------------------+
           |  IP                        |
           +----------------------------+

So it seems to me that an unambiguous way to talk about this is thus..

  "In order to specify a protocol binding for FOOP-over-BEEP, one must write 
   and register a 'BEEP channel profile for FOOP'."

My question is whether you will find statements, such as the one immediately 
above, to be clear and unambiguous when you're evaluating them in a context 
external to BEEP (e.g. in the context of, say, designing "FOOP").

thanks

JeffH

_______________________________________________
BXXPwg mailing list
[email-masked]
http://lists.invisible.net/mailman/listinfo/bxxpwg

---

From: "Marshall T. Rose" <[email-masked]>
Date: Fri, 18 May 2001 15:38:59 -0700

>   In order to specify a protocol binding for FOOP-over-BEEP, one must
write
>   and register a 'BEEP channel profile for FOOP'

yes, fine with me!

/mtr