Subject: [BEEPwg] Aborting SASL authentication from the client

From: Kevin Kress <[email-masked]>
Date: 14 Sep 2002 23:43:26 -0700

I was hoping the group could clarify something for me.  In SASL when a
client aborts a SASL transaction, sending a <blob status='abort'/> what
would the proper response from the server be?  

Should it respond with a RLY message of "<ok/>"  or perhaps a RLY with
"<error code='451'/>" or should it be the "<error code='451'/>" in a ERR
message?  Other suggestions?

Thoughts?

--Kevin Kress

---

From: Marshall Rose <[email-masked]>
Date: Sun, 15 Sep 2002 11:23:00 -0700

the server should send
    
    <blob status='complete' />
    
which is its way of telling the client that the sasl exchange has
successfully completed. (note that "a successful completion of the
exchange" doesn't mean that the client got authenticated).
    
/mtr
_______________________________________________
BEEPwg mailing list
[email-masked]
http://lists.beepcore.org/mailman/listinfo/beepwg