Subject: FW: [BEHAVE] STUN FINGERPRINT

From: "Kevin Johns" <[email-masked]>
Date: Wed, 10 Jan 2007 17:03:33 -0700

All,
 
I sent this last week and did not see a response. Given the original
postings close proximity to the new year, I suspect several folks were
on vacation and thus missed it.
 
Please respond if you have any thoughts on this.
 
Regards,
Kevin Johns

  _____  

From: Kevin Johns 
Sent: Wednesday, January 03, 2007 2:17 PM
To: [email-masked]
Subject: [BEHAVE] STUN FINGERPRINT

All,
 
Per the text of the current STUN draft (-05), it states that the value
is computed as the CRC-32 of the STUN message up to (but excluding) the
FINGERPRINT attribute itself.
 
The question is on the length value used in the message length field of
the STUN header. Is the FINGERPRINT calculated using the message length
including the FINGERPRINT attribute or the message length minus the
FINGERPRINT attribute?
 
I could not find this discussed anywhere in the draft and we need to
know which way to implement.
 
Regards,
Kevin Johns
_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave
_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Jan 2007 12:56:37 -0500

Sorry for not replying Kevin. This is a good question. I think it should 
be including the FINGERPRINT. THis way, when the fingerprint is 
verified, the recipient does not need to modify the message prior to 
verification.

I'll clarify along the with the other gazillion fixes required from 
comments :(

-Jonathan R.

Kevin Johns wrote:

> ------------------------------------------------------------------------
> *From:* Kevin Johns
> *Sent:* Wednesday, January 03, 2007 2:17 PM
> *To:* [email-masked]
> *Subject:* [BEHAVE] STUN FINGERPRINT
> 
> All,
>  
> ------------------------------------------------------------------------
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com