Subject: [BEHAVE] rfc3489bis: clarification on magic cookie, XOR-MAPPED-ADDRESS and byte order

From: "Alfred E. Heggestad" <[email-masked]>
Date: Tue, 06 Feb 2007 17:24:43 +0100

hi

in rfc3489-bis05 there seem to be some confusion regarding the byte order
of magic cookie and XOR-MAPPED-ADDRESS. could I ask that we include some
info about the byte order in rfc3489-bis06 ?

my assumption is the following (please correct me if wrong):

 > Section 6:
 >
 >   The magic cookie is a fixed value, 0x2112A442.  In the previous
 >   version of this specification [15] this field was part of the
 >   transaction ID.  This fixed value is used as part of the
 >   identification of a STUN message when STUN is multiplexed with other

the magic cookie value is in host byte order, and will be encoded to
network byte order on the wire. correct?

 > Section 11.10
 >
 >   For example, using the "^" character to indicate exclusive or, if the
 >   IP address is 192.168.1.1 (0xc0a80101) and the port is 5555 (0x15B3),
 >   the X-Port would be 0x15B3 ^ 0x2112 = 0x34A1, and the X-Address would
 >   be 0xc0a80101 ^ 0x2112A442 = 0xe1baa543.

the X-port value 0x34A1 above is in host byte order and will be converted to
network byte order on the wire. correct?

the X-Address value 0xe1baa543 above is in host byte order and will be converted to
network byte order on the wire. correct?

this stuff should be quite simple to implement, but I know from implementors that
this is interpreted differently, so we need to make sure that the spec does not
leave anything open for mis-interpretation. my apologies if this has been covered
already..

thanks

/alfred

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 14 Feb 2007 11:29:56 -0500

To answer your question - everything is represented in network byte 
order on the wire. This is generally true in ietf protocols, but I'll 
restate it.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com