Subject: Re: [BEHAVE] duplicated STUN attributes

From: Cullen Jennings <[email-masked]>
Date: Sat, 14 Apr 2007 21:23:13 -0700

Another excellent example of why we should let IANA run this registry.

On Mar 21, 2007, at 6:58 AM, Alfred E. Heggestad wrote:

> hi
>
> I would just like to point out that there are some duplicated
> STUN attributes on the "STUN Attributes" homepage:
>
>   PADDING 0x0026
>   PADDING 0x8026
>
>   http://www.employees.org/behave/stun-attributes.html
>
>
>
> request to authors of STUN usage documents: please review the
> list of STUN attribute values (both tables) *before* submitting
> the I-D, and make sure that it does not conflict with itself
> or any other STUN usages.
>
> this would make the life of STUN implementors easier.
>
>
> /alfred
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/behave

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Sun, 15 Apr 2007 09:33:32 -0700

The reason the employees.org page lists both of those values is because
they're both defined by -nat-behavior-discovery:

 > grep "26.*PADDING" draft-ietf-behave-nat-behavior-discovery-00.txt
   0x8026: PADDING
   0x0026: PADDING

I agree IANA needs to run this, once these documents are RFCs -- an IANA
registry wouldn't be effective for Internet Drafts.

-d

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: Saturday, April 14, 2007 9:23 PM
> To: Alfred E. Heggestad
> Cc: Behave WG
> Subject: Re: [BEHAVE] duplicated STUN attributes
> 
>

---

From: "Alfred E. Heggestad" <[email-masked]>
Date: Sun, 15 Apr 2007 19:19:29 +0200

Hi Dan

I think the employees.org page helps alot co-ordinating these values
while the spec is under development (i.e. internet-draft). at the
moment we have at least these specs under development; rfc3489bis,
turn, natbd and ice.

I would suggest that attribute values are only mentioned once in
the spec, to avoid conflicts, also I hope that the authors can check
the values against employees.org before publishing..

/alfred

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 16 Apr 2007 09:06:05 -0700

Yes, agreed.

-d

> From: Alfred E. Heggestad [mailto:[email-masked]] 
> Sent: Sunday, April 15, 2007 10:19 AM
> To: Dan Wing
> Cc: 'Behave WG'
> >  > grep "26.*PADDING" 
> draft-ietf-behave-nat-behavior-discovery-00.txt
> >    0x8026: PADDING
> >    0x0026: PADDING
> > 
> >