Subject: Re: [BEHAVE] adopt STUN test vectors?

From: Philip Matthews <[email-masked]>
Date: Mon, 3 Dec 2007 10:40:20 -0800

I support the idea of published STUN test vectors, either as a  
separate document, or as an appendix to 3489bis.
- Philip

On 21-Nov-07, at 10:43 , Dan Wing wrote:

> We don't have a milestone for STUN test vectors and it probably  
> falls a bit
> outside of the as-written charter, but before we try to change  
> those:  is
> there interest in adopting Remi's "Test vectors for RFC3489bis",
> draft-denis-behave-rfc3489bis-test-vectors-02 as a working group  
> item for
> BEHAVE?  It's 6 pages, please skim it:
>
> http://www.ietf.org/internet-drafts/draft-denis-behave-rfc3489bis- 
> test-vectors
> -02.txt
>
> Before adopting it, I will need to get approval from our ADs to add  
> another
> milestone and adjust the charter accordingly.  But I wanted to poll  
> first to
> see if we should try doing that.
>
> Thanks,
> -d
>
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/behave
>

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 04 Dec 2007 13:16:35 -0500

Same here. In this particular case the vectors are small enough, its 
probably easier to include them as an appendix to rfc3489bis. If the 
ADs/wg chairs are Ok with that, I would propose to do that.

-Jonathan R.

Philip Matthews wrote:
> I support the idea of published STUN test vectors, either as a separate 
> document, or as an appendix to 3489bis.
> - Philip
> 
>> We don't have a milestone for STUN test vectors and it probably falls 
>> a bit
>> outside of the as-written charter, but before we try to change those:  is
>> draft-denis-behave-rfc3489bis-test-vectors-02 as a working group item for
>> http://www.ietf.org/internet-drafts/draft-denis-behave-rfc3489bis-test-vectors 
>>
>> -02.txt
>>

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 4 Dec 2007 16:04:31 -0800

Do we have (or can we get) independent verification they are correct?

Cullen <with my individual hat on>

On Dec 4, 2007, at 10:16 AM, Jonathan Rosenberg wrote:

> Same here. In this particular case the vectors are small enough,  
> its probably easier to include them as an appendix to rfc3489bis.  
> If the ADs/wg chairs are Ok with that, I would propose to do that.
>
> -Jonathan R.
>
> Philip Matthews wrote:
>>> Before adopting it, I will need to get approval from our ADs to  
>>> add another
>>> milestone and adjust the charter accordingly.  But I wanted to  
>>> poll first to

---

From: Rémi Denis-Courmont <[email-masked]>
Date: Wed, 5 Dec 2007 02:24:18 +0200

> Do we have (or can we get) independent verification they are correct?

I did receive a few comments from other implementors that they work for 
them... but but, I guess you're asking for them to post here by themselves.

-- 
Rémi Denis-Courmont

---

From: Brian Korver <[email-masked]>
Date: Tue, 4 Dec 2007 16:26:01 -0800

They worked with my implementation.

-brian
[email-masked]

---

From: "Alfred E. Heggestad" <[email-masked]>
Date: Wed, 05 Dec 2007 01:41:19 +0100

> Do we have (or can we get) independent verification they are correct?

I have implemented the test-vectors in regression tests, and they seem
to work ok.

/alfred

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 4 Dec 2007 17:10:52 -0800

Awesome - if it works for Korver and Philip, then I am strongly in  
favor of these vectors.