Subject: [BEHAVE] TURN draft queries

From: "Sourav Chakraborty" <[email-masked]>
Date: Wed, 12 Dec 2007 18:58:44 +0530

Hi Everybody,

Here are some queries that we have regarding TURN.Please clarify them at the
earliest--

As far as our understanding goes(according to
draft-ietf-behave-turn-03),there are 3 Timers to be implemented,alongwith
the actions taken at server and client--
1>Lifetime timer(turn-03: section 10.3)
            Server: Destroy allocation on expiry
            Client: Re send Allocate request on expiry of 3/4th of the time
2>Keepalive timer(turn-03: section 4.3)
            Client: What is the timer value? What message is sent on expiry?
            Server: No action
3>Permission inactivity timer(turn-03: section 10.3)
            Client: No action
            Server: Delete permission (How is the permission refreshed?)

Also please clarify whether only STUN(not TURN) can be used as a
solution for UDP media traffic
transfer over SYMMETRIC NATs.
--both endpoints behind symmetric NATs
TURN will be required.Only STUN is not enough
--one endpoint behind symmetric NAT,other endpoint in public domain
Not sure.Please clarify??

Please let us know if our understanding is correct alongwith answers to the
questions.
Thanks in advance
Regards
Sourav
_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: Philip Matthews <[email-masked]>
Date: Wed, 12 Dec 2007 14:57:02 -0500

Sourav:

We are in the middle of a major redesign of TURN. TURN-04 is  
significantly different than TURN-03. This is not because we like to  
change TURN, but because we are trying to finalize it as soon as  
possible, while addressing some old concerns.

However, the points you list below are mostly applicable to TURN-04  
as well.

- Philip

On 12-Dec-07, at 08:28 , Sourav Chakraborty wrote:

> --both endpoints behind symmetric  
> NATs                                TURN will be required.Only STUN  
> is not enough
> --one endpoint behind symmetric NAT,other endpoint in public  
> domain   Not sure.Please clarify??
>
>