Subject: [BEHAVE] RE: A simpler way to reduce keepalive traffic (Frank W. Miller)

From: Bryan Ford <[email-masked]>
Date: Tue, 4 Dec 2007 10:03:09 -0800

Frank W. Miller wrote:
> Since I was not able to attend the BoF, could you provide a synopsis  
> of why
> this consensus was arrived at?  Specifically, can you describe any
> deployment scenarios that were quantitatively presented that have  
> difficulty
> with the "chattiness" you are referring to?  I will assume that the
> chattiness is primarily a problem for the STUN servers that are  
> servicing
> the keepalives.  What kind of data was presented to support this  
> problem?

The minutes don't appear to be on-line yet, but they should be soon,  
and the presentation slides (at least the version before the  
presentation - some modifications were made during it) are available  
on the "meeting materials" page at: https://datatracker.ietf.org/meeting/70/materials.html

The biggest motivation seemed to be the drain on the battery power of  
wireless devices: someone offered the anecdote that he'd observed 50%  
of the power of some devices go to keepalive transmissions, although I  
don't remember any "hard" data presented to back this up.  Maybe  
someone else on the list can point to some?

Cheers,
Bryan

_______________________________________________
Behave mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 4 Dec 2007 10:19:31 -0800

(I am CC'ing the SAFE mailing list, as the motivation for reducing keepalives
came up during SAFE.)

Citation:
http://tinyurl.com/3c63ef [IEEE]

  "Energy Consumption of Always-On Applications in WCDMA Networks"
   Haverinen, H.; Siren, J.; Eronen, P.
   Vehicular Technology Conference, 2007. VTC2007-Spring. IEEE 65th
   Volume , Issue , 22-25 April 2007 Page(s):964 - 968
   Digital Object Identifier   10.1109/VETECS.2007.207

    Summary: Always-on applications, such as push email and
    voice-over-IP, are characterized by the need to be constantly
    reachable for incoming communications. In the presence of
    stateful firewalls or NATs, such applications require
    "keep-alive" messages to maintain up-to-date connection state
    in the firewall or NAT, and thus preserve reachability. In
    this paper, we analyze how these keep-alive messages
    influence battery lifetime in WCDMA networks. Using
    measurements in a 3G network, we show that the energy
    consumption is significantly influenced by the radio resource
    control (RRC) parameters and the frequency of keep-alive
    messages. The results suggest that especially UDP-based
    protocols, such as mobile IPv4 and IPsec NAT traversal
    mechanisms, require very frequent keep-alives that can lead
    to unacceptably short battery lifetimes."

I expect we can find a way for the paper to be made available to non-IEEE
members.  Pasi?

-d

> -----Original Message-----
> From: Bryan Ford [mailto:[email-masked]] 
> Sent: Tuesday, December 04, 2007 10:03 AM
> To: [email-masked]
> Subject: [BEHAVE] RE: A simpler way to reduce keepalive 
> traffic (Frank W.Miller)
> 
> Frank W. Miller wrote:
> on the "meeting materials" page at: 
> https://datatracker.ietf.org/meeting/70/materials.html
>

---

From: <[email-masked]>
Date: Tue, 4 Dec 2007 21:53:55 +0200

Dan Wing wrote:

> I expect we can find a way for the paper to be made available 
> to non-IEEE members.  Pasi?

The PDF is also on my home page: http://www.iki.fi/pe/publications/

Best regards,
Pasi

---

From: Aki Niemi <[email-masked]>
Date: Tue, 04 Dec 2007 16:08:04 -0800

> someone else on the list can point to some?

The paper I was (mainly) referring to at the mike was this one from
Henry Haverinen, Jonne Siren and Pasi Eronen:

http://www.niksula.hut.fi/~peronen/publications/haverinen_siren_eronen_vtc2007.pdf

Cheers,
Aki