Subject: [BEHAVE] Prioritization of the translation cases

From: Dave Thaler <[email-masked]>
Date: Thu, 19 Feb 2009 13:39:49 -0800

On our WG charter we have a milestone to "Determine relative

prioritization of the four translation cases."

As the first step in doing this, we would like to get a sense

of the energy/importance/urgency of each of the cases.  To do

this, we would like to ask three questions per scenario:

1) Are you already doing this today with the deprecated NAT-PT?

2) Have you or are you planning to implement code for this scenario?

3) Have you or are you planning to deploying this scenario in a real

   environment (not just a test lab)?

The first question is intended to get a sense of what NAT-PT is being

used for today, which we'd like to replace.  The other two questions

are intended to get a sense of interest among those creating solutions,

and those trying to deploy solutions.

We have set up a doodle poll at:

http://www.doodle.com/9qsdgt8r6kqk6zty

which may appear a bit complicated, but it's just the three

questions above applied to each scenario.

For completeness we are asking about six scenarios.  The first

four are in our charter and the last two are not listed

in our charter, but were discussed as part of IVI, and also we

would like to get a sense of how much deployment of NAT-PT there

is already in those scenarios.  The scenarios are:

   1. An IPv6 network to IPv4 Internet

   2. IPv6 Internet to an IPv4 network

   3. An IPv4 network to IPv6 Internet

   4. IPv4 Internet to an IPv6 network

   5. IPv6 to IPv4 within the same organization

   6. IPv4 to IPv6 within the same organization

If you care to provide additional information, then you can

do so in email to the list in addition to the doodle.

Thanks,

-Dave Thaler & Dan Wing

---

From: Hiroshi MIYATA <[email-masked]>
Date: Fri, 20 Feb 2009 18:11:46 +0900

Hi Dave,

I added my record.

But let me note that we are not using original(deprecated) NAT-PT,
though I marked the deprecated NAT-PT.

We are using modified NAT-PT. It is almost same as NAT64+DNS64,
which is currently discussed.

Thanks,

....hiroshi miyata

On 2009/02/20, at 6:39, Dave Thaler wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: Dave Thaler <[email-masked]>
Date: Mon, 23 Feb 2009 18:57:33 -0800

The doodle questions were tailored to
   a) End-users (or anyone really) already using NAT-PT
   b) Implementers
   c) Network admins

So far 7 people have responded (most with multiple roles each):

   a. 2 using NAT-PT
   b. 4 implementing
   c. 3 deploying
   a. 3 using NAT-PT
   b. 4 implementing
   c. 4 deploying
   a. 1 using NAT-PT
   b. 1 implementing
   c. 0 deploying
   a. 1 using NAT-PT
   b. 5 implementing
   c. 5 deploying
   a. 3 using NAT-PT
   b. 3 implementing
   c. 3 deploying
   a. 1 using NAT-PT
   b. 2 implementing
   c. 2 deploying

I would like to encourage anyone who would answer Yes to any question to
respond if you haven't already.

One goal of prioritization is to decide what order to focus efforts on,
if we cannot do them all simultaneously with the same energy.

Some tentative observations from the poll so far
(we'll see if this changes based on any more responses)
1) all of the scenarios are important to someone
2) Scenario 3 seems the least urgent
3) Scenarios 1, 2, 4, and 5 are all fairly urgent.
4) Scenario 4 is the most popular scenario for IPv4-initiated communication

1, 2, and 5 all have the common property of being initiated from the IPv6
side (and hence some of the same solutions may apply).

If others have strong feelings or data to point out, please
do so (here on the list).  If you want to comment on
"Do you see a clear operational requirement for <pick a number>"
this would be a good time to start if you haven't already.

-Dave

-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Dave Thaler
> Sent: Thursday, February 19, 2009 1:40 PM
> To: [email-masked]
> Subject: [BEHAVE] Prioritization of the translation cases
>