Subject: Re: [BEHAVE] Comments on draft-baker-behave-v4v6-translation-02

From: Fred Baker <[email-masked]>
Date: Sun, 3 May 2009 12:59:53 -0700

yes. It only fails if people try changing ports.

On Apr 27, 2009, at 12:18 PM, james woodyatt wrote:

> On Apr 20, 2009, at 07:36, Iljitsch van Beijnum wrote:
>>
>> On the other hand, SCTP includes address management that would  
>> probably fail in the presence of protocol translation.
>
>
> Thinking about this some, I don't see why it should fail.  As long  
> as the NAT64/DNS64 function operates properly, then SCTP should sail  
> along fine without caring what network layer is carrying its packets  
> in which address realms.
>
>
> --
> james woodyatt <[email-masked]>
> member of technical staff, communications engineering
>
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: Michael Tüxen <[email-masked]>
Date: Sun, 3 May 2009 22:15:25 +0200

Hi Fred, Hi James,

Fred is right here: an SCTP end-point has exactly one port number.
So if you have a multihomed SCTP association there can not be
middleboxes changing the port number independently. That is why
our NAT solution does not change the port number at all.

Best regards
Michael

On May 3, 2009, at 9:59 PM, Fred Baker wrote:

>> as the NAT64/DNS64 function operates properly, then SCTP should  
>> sail along fine without caring what network layer is carrying its  
>> packets in which address realms.
>>
>>
>> --