Subject: [BEHAVE] setting the ID field and the DF flag for outgoing IPv4 packets

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 29 Oct 2009 16:13:21 +0100

Hi,

according to the stateless draft:

3.1. Translating IPv6 Headers into IPv4 Headers

   If there is no IPv6 Fragment header, the IPv4 header fields are set
   as follows:

...

   Identification:  All zero.
...

   Flags:  The More Fragments flag is copied from the M flag in the
      Fragment header.  The Don't Fragments flag is set to zero allowing
      this packet to be fragmented by IPv4 routers.

So, is it me or this is a problem?

(note that this was unchanged from rfc2765)

I mean, we are allowing fragmentation but we are including a reasonable 
ID value, so if packets get fragmented, we won't be able to reasemeble 
them, cause all packet will contain the same ID... what am i missing?

Regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 29 Oct 2009 16:16:39 +0100

please disregard this message.
I mixed the processing of the IPv6 packets with  and without fragment 
header.
sorry for the noise

marcelo bagnulo braun escribió:
> I mean, we are allowing fragmentation but we are including a 
> reasonable ID value, so if packets get fragmented, we won't be able to 
> reasemeble them, cause all packet will contain the same ID... what am 
> i missing?
>
> Regards, marcelo
>
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>