Subject: [BEHAVE] TURN port assignment and IANA port registry

From: "Dan Wing" <[email-masked]>
Date: Thu, 29 Oct 2009 08:42:11 -0700

The IANA section in TURN [1] does not request a port assignment for TURN.
However, due to existing IANA procedures, IANA is assigning port numbers for
TURN.  When [2] is adopted, the IANA procedures will be changed so that a port
number registration is not required; however, [2] is not yet adopted.

This email is to confirm there is no objection in BEHAVE for the following
IANA action to the IANA port registry [3]:

OLD:
stun            3478/tcp   Session Traversal Utilities for NAT  (STUN) port
stun            3478/udp   Session Traversal Utilities for NAT  (STUN) port
#                          [RFC5389]
...
stuns           5349/tcp   STUN over TLS
stuns           5349/udp   Reserved for a future enhancement of STUN
#                          [RFC5389]

NEW:
stun            3478/tcp   Session Traversal Utilities for NAT  (STUN) port
stun            3478/udp   Session Traversal Utilities for NAT  (STUN) port
#                          [RFC5389]
turn            3478/tcp   TURN over TCP
turn            3478/udp   TURN over UDP
#                          [RFC-ietf-behave-turn-16.txt]
...
stuns           5349/tcp   STUN over TLS
stuns           5349/udp   Reserved for a future enhancement of STUN
#                          [RFC5389]
turns           5349/tcp   TURN over TLS
turns           5349/udp   Reserved for a future enhancement of TURN

If you have an objection, please send email to [email-masked].
Thanks.

[1] http://tools.ietf.org/html/draft-ietf-behave-turn-16#section-18 
[2] http://tools.ietf.org/html/draft-ietf-tsvwg-iana-ports-03
[3] http://www.iana.org/assignments/port-numbers

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 29 Oct 2009 12:05:31 -0400

> number registration is not required; however, [2] is not yet adopted.

This seems like an insane waste of port numbers, since they're not
needed.  Is there some way to include the text "not used" or something
like that in these assignments, so that (1) naive firewall people
don't immediately start trying to make rules based on these numbers
and (2) future port assignments can re-use these numbers without fear?
(I don't want actually to object to the assignment, since we obviously
need to get around this bureaucratic issue somehow.)

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 29 Oct 2009 09:31:56 -0700

> -----Original Message-----
> From: Andrew Sullivan [mailto:[email-masked]] 
> Sent: Thursday, October 29, 2009 9:06 AM
> To: Dan Wing
> Cc: Behave WG; [email-masked]; 
> [email-masked]
> Subject: Re: [BEHAVE] TURN port assignment and IANA port registry
> 
> needed. 

An additional port was not assigned; the port number for TURN  
is the same as STUN (3478).  See 
http://www.iana.org/assignments/port-numbers which contains the 
assignment.

> Is there some way to include the text "not used" or something

STUN need a default port, partially to deal with applications,
and libraries that don't support SRV.  TURN is an extension
to STUN so can use the same port.  The TURN port is expected 
to be configurable via SRV (with same requirements on applications
and libraries for SRV support) or also via its URI defined in 
draft-ietf-behave-turn-uri.

-d

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 29 Oct 2009 12:46:26 -0400

On Thu, Oct 29, 2009 at 09:31:56AM -0700, Dan Wing wrote:
> is the same as STUN (3478).

Oh, well, then, I'll shut up.  I guess I should have checked this
first.  No objection here.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.