Subject: [BEHAVE] IETF77 recharter / milestone discussion

From: "Dan Wing" <[email-masked]>
Date: Sun, 7 Mar 2010 11:56:12 -0800

During Friday's BEHAVE session we will be discussing rechartering
and milestones for BEHAVE.  Our current charter is available at
http://www.ietf.org/dyn/wg/charter/behave-charter and as soon
as we send the six IPv6/IPv4 translation documents to the IESG,
we will have completed many of those items.  There is still
outstanding work, though, which needs to be discussed.

If you are presenting an individual draft in BEHAVE, which
you want to have the working group consider as a charter
item, it is your responsibility to use YOUR PRESENTATION
TIME to motiviate the working group.

During the rechartering discussion time, we do not want to 
discuss particular SOLUTIONS.  Rather, we want to discuss 
particular PROBLEMS.  Specifically, we want to determine
if the problem is important enough to add to the charter,
and if there is sufficient energy to work on a solution.

Below is what we intend to discuss around re-chartering
and milestones.  If you see something missing from the list,
please reply to the chairs or the mailing list.

currently-chartered work, with milestones.  We need to 
decide new deadlines.
  - SCTP NAT
      * draft-ietf-behave-sctpnat

currently-chartered work, without milestones.  We need to 
decide if there is interest and if can solve these:
  - BEHAVE scenario 3 (An IPv4 network to IPv6 Internet)
      * draft-liu-behave-nat46
      * draft-huang-behave-pnat
      * draft-huang-behave-rfc2767bis
      * draft-huang-behave-rfc3338bis
      * draft-thaler-6man-unique-v4mapped
  - BEHAVE scenario 4 (IPv4 Internet to an IPv6 network)
      * draft-perkins-behave-dpinat
      * draft-perkins-sourceipnat
      * draft-xli-behave-dns46-for-stateless
      * draft-wing-behave-http-46-relay
  - multicast IPv6/IPv4 translation
      (Scope:  IPv6 senders and IPv4 listeners, or
               IPv4 senders and IPv6 listeners?  
               SSM or ASM?)
      * draft-venaas-behave-v4v6mc-framework
      * draft-jiang-behave-v4v6mc-proxy

non-chartered work.  We need to decide if there is interest, 
and if we can solve these:
  - IPv6-only hosts encountering IPv4 address literals
      * draft-wing-behave-http-ip-address-literals
      * draft-wing-v6ops-v6app-v4server
  - avoiding NAT64 with dual-stack host
      * draft-wing-behave-dns64-config
      * draft-boucadair-behave-dns-a64
      * draft-boucadair-behave-dns64-discovery
      * draft-cao-behave-dsdns64
  - high availability stateful NAT
      * draft-chen-behave-rsnat
      * draft-xu-behave-nat-state-sync
      * draft-xu-behave-stateful-nat-standby
  - NAT load balancing
      * draft-chen-behave-olnat
      * draft-wang-behave-nat64-load-balancer
  - analysis against NAT-PT
      * draft-penno-behave-64-analysis

-d

---

From: Dave Thaler <[email-masked]>
Date: Thu, 25 Mar 2010 00:23:12 +0000

As a reminder, Friday will be a recharter discussion and hence
we would like to remind the WG of the points in the email below.

Presentation/discussion of individual drafts on Thursday should
be focused on motivating the WG discussion on Friday
on the charter.  Since the Friday charter time will be at the
level of what PROBLEMS we might want to add milestones to solve,
discussion will be most productive on Thursday if it motivates
solving a particular problem.  Details of particular SOLUTIONS
are less important to motivate the charter discussion.

Thanks,
-Dave

> -----Original Message-----
> From: Dan Wing [mailto:[email-masked]]
> Sent: Sunday, March 07, 2010 11:56 AM
> To: 'behave'
> Cc: [email-masked]
> Subject: IETF77 recharter / milestone discussion
>