Subject: Re: [BEHAVE] using IPv4-mapped DNS/DNS64 resolvers for dual-stack/IPv6-only hosts

From: Zhen Cao <[email-masked]>
Date: Tue, 9 Mar 2010 11:12:57 +0800

Late catch-up with one comment on the approach:

if a dual stack host sends a query to first DNS (::ffff:192.0.2.1) but
fails to get any resultsr, it will failover to the second DNS and
there will be the same problem that traffic will be translated via
NAT64?

Thanks,
Zhen

On Sat, Feb 13, 2010 at 4:00 AM, Dan Wing <[email-masked]> wrote:
> A few weeks ago there was an active thread on BEHAVE and [email-masked],
> worrying about how a network containing a mix of dual-stack hosts and
> IPv6-only hosts would work.  Ideally, to prevent unnecessary address family
> translation, the dual-stack hosts should use a 'normal' DNS resolver and the
> IPv6-only hosts should use a DNS64 resolver.  However, it is difficult to
> detect if a host is dual-stack or is IPv6-only.
>
> So, I wrote an Internet Draft describing details of several approaches that
> had been discussed on the mailing list, and attempted to provide a list of
> advantages/disadvantages to each.
>
>
> While writing them down, I came up with another approach which uses an
> IPv4-mapped address in the list of IPv6 DNS servers.  An IPv6-only host cannot
> use that address, so it would use the next DNS server on the list; a
> dual-stack host can use such a DNS server.  Details are in:
>
> http://tools.ietf.org/html/draft-wing-behave-dns64-config-02#section-3.1
>
> Please comment on this approach.  For whatever it's worth, the idea seems to
> work.
>
> -d
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 8 Mar 2010 19:20:41 -0800

> -----Original Message-----
> From: Zhen Cao [mailto:[email-masked]] 
> Sent: Monday, March 08, 2010 7:13 PM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [BEHAVE] using IPv4-mapped DNS/DNS64 resolvers 
> for dual-stack/IPv6-only hosts
> 
> fails to get any resultsr, it will failover to the second DNS 

Right.

> and there will be the same problem that traffic will be translated 
> via NAT64?

Yes.

So that means the first DNS server better be working.  

I expect the industry can accomplish that.  _One_ way to accomplish that is to
operate both servers on the same physical server, listening on two different
IP addresses, and responding differently based on the incoming packet.

So far, based on email discussion, this is the only viable idea that does not
require modifying the host.  (I consider the DHCPv6 manipulations in my draft
to be non-viable, even though they do not require modifying the host).

-d

---

From: WashamFan <[email-masked]>
Date: Tue, 09 Mar 2010 14:28:41 +0800

Hi Dan,

IMO, whether normal DNS or DNS64 should be used depends
on what applications residing in the host would be used.

Assume there are 2 applications installed on a DS host.
one is DS suitable application (e.g., firefox browser),
the other is IPv6-only application. When the DS suitable
application is used, normal DNS is prefered. When the
IPv6-only application is used, DNS64 is prefered.

In that regard, detecting the type of the hosts
make little sense to me. applications used rather than
the host they reside in matters to this issue.

Thanks,
washam

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 9 Mar 2010 07:07:41 -0800

> From: WashamFan [mailto:[email-masked]] 
> Sent: Monday, March 08, 2010 10:29 PM
> To: Dan Wing
> Cc: [email-masked]

I admit that I had not considered that.

Can you please name an IPv6-only application that runs on
a dual-stack host?

-d

> >  > if a dual stack host sends a query to first DNS 
> (::ffff:192.0.2.1) 
> > but
> >  I expect the industry can accomplish that.  _One_ way to 
> accomplish 
> > that is to
> >  So far, based on email discussion, this is the only viable 
> idea that 
> > does not
> >  require modifying the host.  (I consider the DHCPv6 
> manipulations in 
> > my draft

---

From: Mark Andrews <[email-masked]>
Date: Wed, 10 Mar 2010 11:20:36 +1100

> Can you please name an IPv6-only application that runs on

traceroute6 and ping6.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 9 Mar 2010 17:01:28 -0800

> > Can you please name an IPv6-only application that runs on

Amusing, Mark.  Thanks.

-d