Subject: [BEHAVE] Translating ICMP msgs in draft-ietf-behave-v6v4-xlate

From: Philip Matthews <[email-masked]>
Date: Tue, 30 Mar 2010 07:45:34 -0400

The document says (section 3.2):

       ICMPv4 error messages:

         Destination Unreachable (Type 3):  For all codes that are not
            explicitly listed below, set the Type field to 1, and adjust
            the ICMP checksum both to take the type change into account
            and to include the ICMPv6 pseudo-header.

            Translate the Code field as follows:

            Code 0, 1 (Net, host unreachable):  Set Code value to 0 (no
               route to destination).
 
            ...   more codes listed ...

I think the wording of the second paragraph above needs to be changed. 
Should it perhaps read as follows?

         Destination Unreachable (Type 3):  Translate the Code field as 
            described below, set the Type field to 1, and adjust
            the ICMP checksum both to take the code and type change into account
            and to include the ICMPv6 pseudo-header.

Also, in the list of codes, should there not be a paragraph that handles the case
where the code is NOT one of the ones listed? It is not clear if one just copies the
code value from ICMPv4 to ICMPv6, or if one drops this ICMP message.

- Philip

---

From: Xing Li <[email-masked]>
Date: Tue, 30 Mar 2010 23:04:04 +0800

thanks. modified.

xing

Philip Matthews 写道:
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>
>
>

---

From: Philip Matthews <[email-masked]>
Date: Wed, 31 Mar 2010 07:57:30 -0400

What is your proposed handling of ICMP error messages where the code field is not one of the values listed?

Also, a similar wording problem seems to exists in the section that deals with ICMP translation in the other direction (v4 --> v6). There the text reads:

      ICMPv4 error messages:

        Destination Unreachable (Type 3)
           For all that are not explicitly listed below set the Type to
           1.

           Translate the code field as follows:
              Code 0, 1 (net, host unreachable):
                     Set Code to 0 (no route to destination).

Again, the sentence that starts "For all that are not explicitly listed below..." seems to need rewording or moving or something.
What is it trying to say?

- Philip

On 2010-03-30, at 11:04 , Xing Li wrote:

>> I think the wording of the second paragraph above needs to be changed. Should it perhaps read as follows?
>> 
>>         Destination Unreachable (Type 3):  Translate the Code field as             described below, set the Type field to 1, and adjust

---

From: Philip Matthews <[email-masked]>
Date: Wed, 31 Mar 2010 08:12:21 -0400

Ignore the second half of the message below. I was comparing draft-ietf-behave-v6v4-xlate with the original SIIT RFC, and got confused as to which document I was looking at. The problem mentioned in the second half of the message below is actually in the SIIT RFC -- it seems that some of the wording problems over ICMP handling originated in that RFC.

However, I am still interested in the answer to the question in the first sentence.

- Philip

---

From: Xing Li <[email-masked]>
Date: Wed, 31 Mar 2010 21:12:32 +0800

Philip Matthews 写道:

Thanks.
> Ignore the second half of the message below. I was comparing 
> draft-ietf-behave-v6v4-xlate with the original SIIT RFC, and got 
> confused as to which document I was looking at. The problem mentioned 
> in the second half of the message below is actually in the SIIT RFC -- 
> it seems that some of the wording problems over ICMP handling 
> originated in that RFC.
>
In https://datatracker.ietf.org/doc/draft-ietf-behave-v6v4-xlate/

It reads

  Other Code values:  Silently drop

  Unknown ICMPv4 types:  Silently drop.
  
  Other Code values:  Silently drop.

  Unknown error messages:  Silently drop.

regards,

xing

>>
>>
>> Also, a similar wording problem seems to exists in the section that 
>> deals with ICMP translation in the other direction (v4 --> v6). There 
>> the text reads:
>>
>> ICMPv4 error messages:
>>
>> Again, the sentence that starts "For all that are not explicitly 
>> listed below..." seems to need rewording or moving or something.