Subject: Re: [BEHAVE] using IPv4-mapped DNS/DNS64 resolvers fordual-stack/IPv6-only hosts

From: [email-masked]
Date: Fri, 12 Mar 2010 15:24:55 +0800

Hi, Mark,

You are misunderstanding. DNS64 server does not need to know the type of the host. It only needs to know the type A answer it receives is for a type A query it forwads or it generates. If the type A answer is for a type A query it forwards, DNS64 server should not touch the answer, just forwards the answer to the host. If the type A answer is for a type A query it generates, DNS64 server should sythesize a type AAAA answer for the type A answer and forward the sythesized type AAAA answer to the host.

The transaction ID in the DNS query message can help DNS64 server to complete this function. Please see the mail I sent to Dan Wing.

Best Regards,
Zhenqiang Li

> Hi, Dan,
> 
> IMO, DNS64 enhancement can solve your problem. Since dual stack application g
> enerates A and AAAA DNS query, and IPv6 only application only generates AAAA 
> query, DNS64 can recognize the type of the application easily. DNS64 should n
> ot synthesize the answer of A query it forwards, only synthesize the answer o
> f A query it generates for AAAA query.

Rubbish.  A DNS64 server cannot tell what type of client is generating
the queries.   Remember a good stub resolver will send each query
on a different random port and the query id will not be guessable.
There is just no way for a DNS64 server to work whether a AAAA query
is from a IPv6 only client, a IPv4 only client or a dual stack client.

Mark

> Best Regards,
> Zhenqiang Li
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Simon Perreault <[email-masked]>
Date: Fri, 12 Mar 2010 16:17:00 +0900

> You are misunderstanding. DNS64 server does not need to know the type of the host. It only needs to know the type A answer it receives is for a type A query it forwads or it generates. If the type…

I also don't understand what you are proposing.

I have three open-source DNS64 implementations available at
http://ecdysis.viagenie.ca/download.html. If you could modify one of them to
implement your idea and show us the code, I'm sure we would all understand. One
of them is very small, in Perl, and should be very easy to modify. We wrote it
exactly for this kind of purpose.

Thanks,
Simon
-- 
DNS64 open-source   --> http://ecdysis.viagenie.ca
STUN/TURN server    --> http://numb.viagenie.ca
vCard 4.0           --> http://www.vcarddav.org