Subject: Re: [BEHAVE] two ideas

From: <[email-masked]>
Date: Mon, 1 Mar 2010 13:37:54 +0100

Dear Dacheng,

Please see inline.

Cheers,
Med

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de Dacheng Zhang
Envoyé : samedi 27 février 2010 09:18
À : [email-masked]
Objet : [BEHAVE] two ideas

Hello, everybody:

After reading draft-wing-behave-dns64-config-02, I have two ideas here, and hope to get your kindly comments:

1. In section 3.2, it is suggested to use DNSsec to disable DNS64. But in order to deal with the circumstance where synthesized addresses have been already encapsulated in AAAA records, maybe it is a good idea to specify a new flag in the DNS answer containing an AAAA RR. The flag indicates that a synthesized address is contained in the RR. An updated dual-stack host can recognize it while conventional ones will just ignore the flag.
[Med] I'm not sure what kind of flags can be used, but an alternative proposal to define a new RR for synthesised AAAA can be found at: http://tools.ietf.org/html/draft-boucadair-behave-dns-a64-01. Does A64 RR solves the issue you have?

2. In the sections 3.5 and 3.6, solutions of using DHCP to identify dual stack host are introduced. I want to know whether it is another feasible solution to define an option for dual stack hosts. If such an option is attached in a request from a host, the DHCP server will ensure that the host has a dual-stack.

What do you think of them?

BR ^_^

Dacheng

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 1 Mar 2010 11:57:54 -0800

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dacheng Zhang
> Sent: Saturday, February 27, 2010 12:18 AM
> To: [email-masked]
> Subject: [BEHAVE] two ideas
> 
> Hello, everybody:
> 
>  
> 
> After reading draft-wing-behave-dns64-config-02, I have two 
> ideas here, and hope to get your kindly comments:
> 
>  
> 
> 1. In section 3.2, it is suggested to use DNSsec to disable 
> DNS64. But in order to deal with the circumstance where 
> synthesized addresses have been already encapsulated in AAAA 
> records, 

I don't understand what is meant by "have been already 
encapsulated"; DNS64 does the synthesis on-the-fly, so they
are not "already" synthesized AAAA responses.  Could you clarify?

> maybe it is a good idea to specify a new flag in the 
> DNS answer containing an AAAA RR. The flag indicates that a 
> synthesized address is contained in the RR. An updated 
> dual-stack host can recognize it while conventional ones will 
> just ignore the flag.

I vaguely recall there was a proposal to do that, but I can't
remember the name of the I-D or the section of some other
I-D.  I can certainly add that to draft-wing-behave-dns64-config,
and I believe it would have positives and negatives nearly
identical to Section 3.2, namely:

Advantages:
  * It is simple

Disadvantages:
  * It requires dual-stack host to understand the new flag if
    if it wants to avoid using the NAT64
  
Are there other advantages or disadvantages? 

I'm not sure of the implications of the host transitioning
from dual-stack to IPv6-only.  Thoughts on that?

> 2. In the sections 3.5 and 3.6, solutions of using DHCP to 
> identify dual stack host are introduced. I want to know 
> whether it is another feasible solution to define an option 
> for dual stack hosts. If such an option is attached in a 
> request from a host, the DHCP server will ensure that the 
> host has a dual-stack. 

It seems reasonable for the DHCP Request to indicate "I am 
dual-stack".  

Advantages:
  * Simple

Disadvantages:
  * It requires dual-stack host to include this new DHCP
    option if it wants to avoid using the NAT64

How would a host transition from dual-stack to IPv6-only in
that case?  It seems that if it releases its IPv4 address,
and becomes IPv6-only, it would need to re-DISCOVER, and
indicate "I am not dual stack" (or perhaps not send the
option?).

-d