Subject: [BEHAVE] UDP checksum of zero.

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Wed, 14 Apr 2010 16:15:57 -0700

"When a stateless translator receives the first fragment of a
   fragmented UDP IPv4 packet and the checksum field is zero, the
   translator SHOULD drop the packet and generate a system management
   event specifying at least the IP addresses and port numbers in the
   packet.  When it receives fragments other than the first, it SHOULD
   silently drop the packet, since there is no port information to log."
 
The second sentence does not make sense. When a non-first fragment
is received there is no UDP header and hence there is no UDP checksum.
So you cannot determine if the checksum is zero or not and hence the
second
sentence must be removed. We would need to keep state to determine if
the
subsequent fragments belong to the same flow that had the UDP checksum
of zero or not.
That would not belong in this draft.
 
Senthil

---

From: Xing Li <[email-masked]>
Date: Thu, 15 Apr 2010 19:07:24 +0800

Thanks.

Senthil Sivakumar (ssenthil) 写道:
> So you cannot determine if the checksum is zero or not and hence the second
> sentence must be removed. We would need to keep state to determine if the
> subsequent fragments belong to the same flow that had the UDP checksum of zero or not.

The second sentence simply means the fragments other than the first 
should be silently dropped. We will remove the second sentence in the 
next upload during the IESG process.

Regards,

xing, congxiao

>  
> Senthil
> ------------------------------------------------------------------------
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Thu, 15 Apr 2010 04:24:56 -0700

-----Original Message-----
From: Xing Li [mailto:[email-masked]] 
Sent: Thursday, April 15, 2010 7:07 AM
To: Senthil Sivakumar (ssenthil)
Cc: [email-masked]
Subject: Re: [BEHAVE] UDP checksum of zero.

Thanks.

Senthil Sivakumar (ssenthil) 写道:
> The second sentence does not make sense. When a non-first fragment is 
> received there is no UDP header and hence there is no UDP checksum.
> second sentence must be removed. We would need to keep state to 
> determine if the subsequent fragments belong to the same flow that had the UDP checksum of zero or not.

The second sentence simply means the fragments other than the first should be silently dropped. We will remove the second sentence in the next upload during the IESG process.

[Senthil] We *cannot* silenty drop any non-first fragments, right?. The stateless translator would have to pass them on. The only thing we can do is identify and drop the first fragment with UDP csum of zero. 

Thanks
Senthil

Regards,

xing, congxiao

---

From: Xing Li <[email-masked]>
Date: Thu, 15 Apr 2010 22:04:56 +0800

Hi, Senthil,

> [Senthil] We *cannot* silenty drop any non-first fragments, right?. The stateless translator would have to pass them on. The only thing we can do is identify and drop the first fragment with UDP cs…

You are correct. If the translator can identify the problem, it will
drop the packet which contains the problem, if the translator cannot
identify the problem, it will pass the packet and let the end system
handle it.

Regards,

xing, congxiao