Subject: [BEHAVE] IPv4 literals

From: Cameron Byrne <[email-masked]>
Date: Tue, 7 Dec 2010 14:51:06 -0800

Here is an interesting project that has popped on the T-Mobile USA
IPv6 FUT network.

The N900 now has some tricks to help with IPv4 literals in the
IPv6-only NAT64 environment

http://code.google.com/p/n900ipv6/wiki/LDPreloadNat64

It requires the manual definition of the PREF64, but could likely be
modified to use WKP as a default or one of the PREF64 discover methods

Cameron

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 7 Dec 2010 18:45:56 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Cameron Byrne
> Sent: Tuesday, December 07, 2010 2:51 PM
> To: [email-masked]
> Subject: [BEHAVE] IPv4 literals
> 

Thanks for the pointer.

It is effectively doing NAT46 in the host, which results in a system
that is NAT464 (NAT46 in the host and NAT64 in the network).
 
> modified to use WKP as a default or one of the PREF64 discover methods

Yep.

-d