Subject: [BEHAVE] Request to adopt draft-boucadair-behave-bittorrent-address-sharing as WG document

From: <[email-masked]>
Date: Thu, 1 Sep 2011 15:45:36 +0200

Dear all,

I would like to have a feedback from the WG whether there is an interest to adopt http://tools.ietf.org/html/draft-boucadair-behave-bittorrent-address-sharing-00 as WG document.

Comments and suggestions are welcome.

Cheers,
Med

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dan Wing
> Sent: Friday, June 10, 2011 9:22 PM
> To: Behave WG
> Cc: [email-masked]; 'Dave Thaler'
> Subject: [BEHAVE] BEHAVE presentations at IETF81
> 

> 
> * draft-boucadair-behave-bittorrent-address-sharing -- I 
> believe this was
> going to be published AD-sponsored, unless there is interest 
> in the working
> group on this document?  If folks want to look at it, and 
> decide if they
> could provide peer review, we might consider adopting this as 
> a WG document.
> Please let me know.
>

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 6 Sep 2011 15:49:59 +0200

On 1 sep 2011, at 15:45, <[email-masked]> <[email-masked]> wrote:

> http://tools.ietf.org/html/draft-boucadair-behave-bittorrent-address-sharing-00 

> Comments and suggestions are welcome.

Why did you use the address 193.51.145.206 as the shared address rather than an RFC 1918 address? This way special case logic for address sharing in the application, if any, will probably remain unused. Also, this address is in the same subnet as the other non-shared peers, which may trigger other special case logic.

Testing with both regular and private addresses would be best.

A lot of text is presented in narrow columns in long, page break spanning tables. Don't do this. I can't stand to read it.

Considering the fact that the found issue (under one of two possible configuration settings two peers sharing an address can't connect to a single other peer) is a pretty extreme corner case which doesn't even preclude eventual successful downloading and the BitTorrent protocol (unless I missed something) isn't published as an RFC, I don't think this work is in the right place here so it shouldn't be adopted as a WG document and it shouldn't be published as an RFC. Even if the "belongs here" isn't found persuasive both the strange test setup and the unfortunate formatting make this document too immature for WG adoption.

---

From: Rémi Després <[email-masked]>
Date: Wed, 7 Sep 2011 11:49:58 +0200

> Comments and suggestions are welcome.

+1 to make it a WG document.

RD

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: SM <[email-masked]>
Date: Thu, 08 Sep 2011 07:22:20 -0700

At 06:49 06-09-2011, Iljitsch van Beijnum wrote:
>Considering the fact that the found issue (under one of two possible 
>configuration settings two peers sharing an address can't connect to 
>a single other peer) is a pretty extreme corner case which doesn't 
>even preclude eventual successful downloading and the BitTorrent 
>protocol (unless I missed something) isn't published as an RFC, I 
>don't think this work is in the right place here so it shouldn't be 
>adopted as a WG document and it shouldn't be published as an RFC. 
>Even if the "belongs here" isn't found persuasive both the strange 
>test setup and the unfortunate formatting make this document too 
>immature for WG adoption.

The BitTorrent protocol has not been published as a RFC.  It's odd to 
have the two ends on the same IPv4 /24 unless the intent is to use 
"shared transition" IPv4 address space.  The document requires some 
editorial work.  The tables in Section 4 are difficult to 
read.  Concluding that the results are valid for all IP shared 
address solutions in a stretch (Section 6).

What do the authors expect by having the document adopted by this 
working group?

Regards,
-sm