Subject: [BEHAVE] presentations at IETF82

From: "Dan Wing" <[email-masked]>
Date: Tue, 27 Sep 2011 17:02:38 -0700

We requested a 2 hour slot for BEHAVE.

If you would like to present in BEHAVE at IETF82, please send to
[email-masked]:
  - topic title
  - presenter's name
  - Internet Draft filename(s)
  - time requested

We will give priority to:
  1. working group items
  2. items actively discussed on the mailing list
  3. new topics

Please send the request by October 24th, which is also the cutoff
date for initial Internet Drafts (-00).

-Dan and Dave

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 27 Sep 2011 20:22:10 -0400

Dan, I'm puzzled. Behave was shutting down. And then out of the blue, a meeting. Can you explain in general, and also in this context, what means "working group items"?

Marc.

Le 2011-09-27 à 20:02, Dan Wing a écrit :

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 27 Sep 2011 18:39:06 -0700

> -----Original Message-----
> From: Marc Blanchet [mailto:[email-masked]]
> Sent: Tuesday, September 27, 2011 5:22 PM
> To: Dan Wing
> Cc: [email-masked]; [email-masked]
> Subject: Re: [BEHAVE] presentations at IETF82
> 
> Dan, I'm puzzled. Behave was shutting down. And then out of the blue, a
> meeting. Can you explain in general, and also in this context, what
> means "working group items"?

Yes.  Let me explain from my perspective what I see happening with
BEHAVE:

BEHAVE is at an inflection point -- we are changing direction.  We
have completed our initial work (STUN, TURN, multicast/TCP/UDP/ICMP
behavior documents) and completed what might be called our 
"NAT-PTbis" work (the document set related to NAT64/DNS64).

As you all recall, we had very little discussion on the list prior to
IETF81, which is why we had allocated only an hour.  Participant 
energy was going away because we had completed our major milestones.
So, we asked if we could close BEHAVE.  We spent about half of our
meeting time at IETF81 talking about the future of BEHAVE rather 
than discussing documents.

After IETF81, the chairs built a list of I-Ds that had been 
proposed into the working  group, and have shared that with 
David Harrington, our AD.  Some of these documents seem like they 
fit into BEHAVE's existing charter and some don't.

David Harrington is currently on vacation, and will return from 
vacation next week.  I don't know what he will decide.  I 
know that activity on the Behave mailing list and updated 
documents will likely keep the working group energized and 
keep the chairs energized.  And I would expect such activity 
will also keep the working group open.  

To answer your specific question:  In the spirit of keeping 
things moving along, I had requested more agenda time (two hours) 
than we had at IETF81 (one hour) and I sent out the 'presentations 
for IETF82' email to ensure existing work continues and that 
we learn of new work (-00 or updates to existing documents) 
that is aimed at BEHAVE.  This will provide additional input to
David Harrington to decide if Behave should have additional
milestones, charter update, or be closed.

With multicast translation and the Mon/Tue Softwire interim
in Beijing (which I did not attend, but I know included 
discussions on double translation (Dual-IVI)), there may well
be more work coming towards Behave, towards Softwire, another
working group, or a new working group.

-d

---

From: Dave Thaler <[email-masked]>
Date: Wed, 28 Sep 2011 21:08:22 +0000

We said last time we would complete the existing milestones, including meeting as needed to finish them.
Not doing so was never part of the question.

We also said we'd consider the MIB work as being (the management) part of existing work, if there's enough interest.  (And there seems to be.)

We will give priority to presentations that are on existing milestones.
If there is still time left over, we'll allow presentations on things that are in scope for discussion but have no milestones (even if they later move to another group).  

That's because even if work is happening elsewhere, some things are good to also have the behave WG review.   As long as we're meeting anyway, we can use leftover meeting time, if any, to have a higher bandwidth review of other items that should be reviewed by behave folks, rather than just using the mailing list.

Hope that clarifies,
-Dave

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Dan Wing
> Sent: Tuesday, September 27, 2011 6:39 PM
> To: 'Marc Blanchet'
> > Dan, I'm puzzled. Behave was shutting down. And then out of the blue,
> > a meeting. Can you explain in general, and also in this context, what
> BEHAVE is at an inflection point -- we are changing direction.  We have
> completed our initial work (STUN, TURN, multicast/TCP/UDP/ICMP behavior
> documents) and completed what might be called our "NAT-PTbis" work (the
> document set related to NAT64/DNS64).
> 
> As you all recall, we had very little discussion on the list prior to IETF81,
> which is why we had allocated only an hour.  Participant energy was going
> away because we had completed our major milestones.
> So, we asked if we could close BEHAVE.  We spent about half of our meeting
> time at IETF81 talking about the future of BEHAVE rather than discussing
> documents.
> 
> After IETF81, the chairs built a list of I-Ds that had been proposed into the
> working  group, and have shared that with David Harrington, our AD.  Some
> of these documents seem like they fit into BEHAVE's existing charter and
> some don't.
> 
> David Harrington is currently on vacation, and will return from vacation next
> week.  I don't know what he will decide.  I know that activity on the Behave
> mailing list and updated documents will likely keep the working group
> energized and keep the chairs energized.  And I would expect such activity
> To answer your specific question:  In the spirit of keeping things moving
> along, I had requested more agenda time (two hours) than we had at IETF81
> (one hour) and I sent out the 'presentations for IETF82' email to ensure
> existing work continues and that we learn of new work (-00 or updates to
> existing documents) that is aimed at BEHAVE.  This will provide additional
> input to David Harrington to decide if Behave should have additional
> With multicast translation and the Mon/Tue Softwire interim in Beijing
> (which I did not attend, but I know included discussions on double
> translation (Dual-IVI)), there may well be more work coming towards Behave,
> towards Softwire, another working group, or a new working group.
> 
> -d
> 
> 
> > Marc.
> >
> > >  2. items actively discussed on the mailing list  3. new topics
> > >

---

From: David Harrington <[email-masked]>
Date: Wed, 28 Sep 2011 23:49:08 +0200

Hi,

There was a suggestion that behave should be shut down after its chartered
work was finished. As Responsible AD, I requested feedback from the WG. My
tendency is to favor  closing the WG after the work completes.

There is still some chartered work to be completed, so we are not closing
the WG yet.
Therefore a meeting is fully justified.

There was discussion of whether some existing proposals would justify a
new WG, or should be redirected to existing WGs. That analysis is still
ongoing, and there are BOFs in development, such as the multicast
transtion BOF, that might include some of the existing proposals. Some of
the work could end up being addressed in softwires. Some of the work could
end up being addressed in OPS area. New proposals may also be discussed at
the behave meeting. We have no desire to stop discussion of worthy ideas
while the IETF (and IESG) discusses how best to charter/organize the work
going forward.

David Harrington
Transport Area Director

On 9/28/11 2:22 AM, "Marc Blanchet" <[email-masked]> wrote:

>meeting. Can you explain in general, and also in this context, what means
>"working group items"?
>
>Marc.
>