Subject: [BEHAVE] http://tools.ietf.org/html/draft-ietf-behave-nat-mib-08 - Suggestion to make it scalable

From: "Jagadish Shivamurthy (jshivamu)" <[email-masked]>
Date: Mon, 14 Oct 2013 16:48:02 +0000

Hello,
I am from Cisco engineering team that works on Edge and Core router products.
We do provide NAT solutions for Service Providers in our routers (ASR9K and CRS-1 and CRS-3 routers).
We want to implement the new MIB being defined in http://tools.ietf.org/html/draft-ietf-behave-nat-mib-08
However, the MIB in the current format (as of draft version 8) has a limitation that prevents us from being able to implement it. Our routers provide NAT at large scale (CGN or LSN). A single router (that is a single SNMP agent) can have multiple line cards that provide NAT (different NAT solutions such as NAT44, NAT64, DS Lite) and there could be multiple (up to 64) instances of each of these applications on a single card. Hence, the MIB needs to be capable of handle multiple instances of NAT applications. Though using SNMP contexts is one way to handle this, the method of contexts is manageable when the number of instances is small. This method does NOT scale up. It becomes too complex to deploy and configure when we have hundreds of instances to support.

Hence, in order for this MIB to be used in a large scale NAT (LSN) environment, we request you to add the ability to handle multiple instances. A smaller router/firewall box that has only one instance can make use of the MIB with a single instance. Hence the MIB will become useful across different scale of NAT solutions.
Please consider this requirement and provide this support in the next draft. It will be very helpful to us if you could let us know if this request is considered or not.

Thanks
Jagadish

---

From: Simon Perreault <[email-masked]>
Date: Wed, 16 Oct 2013 19:59:38 +0200

Thanks a lot for the input!

I had expected that SNMPv3 contexts would be used to do that, but I see 
it can become unmanageable. What's needed is fairly easy to add to the 
draft. Unless people disagree, it's going to be part of the next revision.

Could this problem be generalized to other non-NAT application? If so, 
is there a need for a generic solution?

Simon

Le 2013-10-14 18:48, Jagadish Shivamurthy (jshivamu) a écrit :
> We want to implement the new MIB being defined in
> http://tools.ietf.org/html/draft-ietf-behave-nat-mib-08
>
> However, the MIB in the current format (as of draft version 8) has a
> limitation that prevents us from being able to implement it. Our routers
> provide NAT at large scale (CGN or LSN). A single router (that is a
> single SNMP agent) can have multiple line cards that provide NAT
> (different NAT solutions such as NAT44, NAT64, DS Lite) and there could
> be multiple (up to 64) instances of each of these applications on a
> single card. Hence, the MIB needs to be capable of handle multiple
> instances of NAT applications. Though using SNMP contexts is one way to
> handle this, the method of contexts is manageable when the number of
> instances is small. This method does NOT scale up. It becomes too
> complex to deploy and configure when we have hundreds of instances to
> support.
>
> Hence, in order for this MIB to be used in a large scale NAT (LSN)
> environment, we request you to add the ability to handle multiple
> instances. A smaller router/firewall box that has only one instance can
> make use of the MIB with a single instance. Hence the MIB will become
> useful across different scale of NAT solutions.
>
> Please consider this requirement and provide this support in the next
> draft. It will be very helpful to us if you could let us know if this
> request is considered or not.
>
> Thanks
>
> Jagadish
>
>
>
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: "Senthil Sivakumar (ssenthil)" <[email-masked]>
Date: Wed, 16 Oct 2013 18:10:21 +0000

I support adding the instances, I have heard from other people too that
contexts don¹t scale well.

Thanks
Senthil

---

From: Simon Perreault <[email-masked]>
Date: Thu, 17 Oct 2013 16:55:56 +0200

Le 2013-10-17 17:58, Jagadish Shivamurthy (jshivamu) a écrit :
> Hi Simon and Senthil,
> Thanks a lot for the quick and positive response.
> Could we know when is the next revision of the draft scheduled?

It was just published!

http://tools.ietf.org/html/draft-ietf-behave-nat-mib-09

Simon

---

From: "Jagadish Shivamurthy (jshivamu)" <[email-masked]>
Date: Thu, 17 Oct 2013 15:58:31 +0000

Hi Simon and Senthil,

Thanks
Jagadish

-----Original Message-----
From: Senthil Sivakumar (ssenthil) 
Sent: Wednesday, October 16, 2013 11:40 PM
To: Simon Perreault; Jagadish Shivamurthy (jshivamu)
Cc: Pranabesh Das (pranabes); [email-masked]; Asutosh Brahma (abrahma); Somnath Roy (somnathr); Ananth Bhat (anantbha); Siva Sivaramakrishnan (sivarama)
Subject: Re: [BEHAVE] http://tools.ietf.org/html/draft-ietf-behave-nat-mib-08 - Suggestion to make it scalable

I support adding the instances, I have heard from other people too that contexts don¹t scale well.

Thanks
Senthil

On 10/16/13 1:59 PM, "Simon Perreault" <[email-masked]> wrote:

>> limitation that prevents us from being able to implement it. Our 
>> routers provide NAT at large scale (CGN or LSN). A single router 
>> (that is a single SNMP agent) can have multiple line cards that 
>> provide NAT (different NAT solutions such as NAT44, NAT64, DS Lite) 
>> and there could be multiple (up to 64) instances of each of these 
>> applications on a single card. Hence, the MIB needs to be capable of 
>> handle multiple instances of NAT applications. Though using SNMP 
>> contexts is one way to handle this, the method of contexts is 
>> manageable when the number of instances is small. This method does 
>> NOT scale up. It becomes too complex to deploy and configure when we 
>> have hundreds of instances to support.
>>
>> instances. A smaller router/firewall box that has only one instance 
>> can make use of the MIB with a single instance. Hence the MIB will 
>> become useful across different scale of NAT solutions.
>>

---

From: Tina TSOU <[email-masked]>
Date: Tue, 22 Oct 2013 00:13:45 +0000

Dear Jagadish,
Version-09 is at http://datatracker.ietf.org/doc/draft-ietf-behave-nat-mib/.

Thank you,
Tina

On Oct 20, 2013, at 5:22 PM, "Jagadish Shivamurthy (jshivamu)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Simon and Senthil,

Thanks
Jagadish

-----Original Message-----
From: Senthil Sivakumar (ssenthil)
Sent: Wednesday, October 16, 2013 11:40 PM
To: Simon Perreault; Jagadish Shivamurthy (jshivamu)
Cc: Pranabesh Das (pranabes); [email-masked]<mailto:[email-masked]>; Asutosh Brahma (abrahma); Somnath Roy (somnathr); Ananth Bhat (anantbha); Siva Sivaramakrishnan (sivarama)
Subject: Re: [BEHAVE] http://tools.ietf.org/html/draft-ietf-behave-nat-mib-08 - Suggestion to make it scalable

Thanks
Senthil

On 10/16/13 1:59 PM, "Simon Perreault" <[email-masked]<mailto:[email-masked]>> wrote:

Simon

I am from Cisco engineering team that works on Edge and Core router
products.

We do provide NAT solutions for Service Providers in our routers
(ASR9K and CRS-1 and CRS-3 routers).

Thanks

Jagadish

_______________________________________________
Behave mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/behave

[email-masked]<mailto:[email-masked]>

_______________________________________________
Behave mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/behave