Subject: [BEHAVE] [Technical Errata Reported] RFC5766 (5231)

From: RFC Errata System <[email-masked]>
Date: Mon, 8 Jan 2018 20:45:59 -0800 (PST)

The following errata report has been submitted for RFC5766,
"Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5231

--------------------------------------
Type: Technical
Reported by: Hannes Landeholm <[email-masked]>

Section: 16

Original Text
-------------
    |<-- Refresh success response -------|             |             |
    |    Transaction-Id=0x427BD3E625A85FC731DC4191     |             |
    |    SOFTWARE="Example server, version 1.17"       |             |
    |    LIFETIME=600 (10 minutes)       |             |             |

Corrected Text
--------------
    |<-- Refresh success response -------|             |             |
    |    Transaction-Id=0x427BD3E625A85FC731DC4191     |             |
    |    SOFTWARE="Example server, version 1.17"       |             |
    |    LIFETIME=600 (10 minutes)       |             |             |
    |    MESSAGE-INTEGRITY=...           |             |             |

Notes
-----
The last example refresh success response lacks message-integrity, incorrectly implying that the response after a stale nonce exchange does not have to be authenticated.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5766 (draft-ietf-behave-turn-16)
--------------------------------------
Title               : Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)
Publication Date    : April 2010
Author(s)           : R. Mahy, P. Matthews, J. Rosenberg
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Simon Perreault <[email-masked]>
Date: Tue, 9 Jan 2018 08:58:26 -0500

This is correct. Verified.

Simon

2018-01-08 23:45 GMT-05:00 RFC Errata System <[email-masked]>:

> The last example refresh success response lacks message-integrity,
> incorrectly implying that the response after a stale nonce exchange does
> not have to be authenticated.
>
> Instructions:
> -------------
> Title               : Traversal Using Relays around NAT (TURN): Relay
> Extensions to Session Traversal Utilities for NAT (STUN)
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 9 Jan 2018 12:24:31 -0600

Hi, Simon,

> This is correct. Verified.

I've marked it as verified in the errata system.

Spencer