Subject: Re: [bess] 答复: Flowspec for L2VPN and E-VPN

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 14 Nov 2014 00:14:58 +0000

If we define a new things I prefer to address the wider issue and include
L2 in that.

On 13/11/14 14:13, "Haoweiguo" <[email-masked]> wrote:

>Hi Wim,
>Allocating different AFI/SAFI(s) for each flow spec application is a
>applicable solution. Theoretically, unified mechanism for all flowspec
>can be designed, but it maybe a more harder work in IDR.
>Thanks
>weiguo
>
>________________________________________
>发件人: BESS [[email-masked]] 代表 Henderickx, Wim (Wim)
>[[email-masked]]
>发送时间: 2014年11月14日 7:55
>收件人: Thomas Morin; BESS
>抄送: IDR Chairs
>主题: Re: [bess] Flowspec for L2VPN and E-VPN
>
>As I stated in the IDR meeting my observation is that we require to many
>AFI/SAFI(s) for all flow spec functions. Flow spec in general is providing
>match criteria¹s with related actions. Given the proposal on Flowspec for
>L2 is new we should look at the bigger picture.
>In My view we need a mechanism in BGP to advertise Flowspec match
>criteria¹s with related actions and they should cover L2/L3-IPv4/IPv6.
>
>On 13/11/14 13:44, "Thomas Morin" <[email-masked]> wrote:
>
>>Hi WG,
>>
>>A heads up...
>>
>>These two drafts relate to BESS and thus may be of interest to us:
>>- draft-hao-idr-flowspec-l2vpn
>><http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01> (on
>>idr agenda, being presented right now)
>>- draft-hao-idr-flowspec-evpn
>><https://tools.ietf.org/html/draft-hao-idr-flowspec-evpn-00>
>>
>>Best,
>>
>>-Thomas
>>
>>
>>_______________________________________________
>>BESS mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/bess
>
>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 00:16:53 +0000

How to achieve compatability with current existed flowspec[RFC5575] applications? 
Thanks
weiguo

________________________________________
发件人: Henderickx, Wim (Wim) [[email-masked]]
发送时间: 2014年11月14日 8:14
收件人: Haoweiguo; Thomas Morin; BESS
抄送: IDR Chairs
主题: Re: 答复: [bess] Flowspec for L2VPN and E-VPN

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 14 Nov 2014 08:00:28 +0000

+1... Would to avoid to see multiplication of fs safi.

Sent from iPAD

> On Nov 14, 2014, at 01:15, Henderickx, Wim (Wim) <[email-masked]> wrote:
>

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 08:06:59 +0000

Hi Bertrand,
What's your solution for RT overlap issue or other possible issue?Sometimes it is unfortunate that designing beauty needs to be compromised in reality.
Thanks
weiguo

________________________________________
发件人: Bertrand Duvivier (bduvivie) [[email-masked]]
发送时间: 2014年11月14日 16:00
收件人: Henderickx, Wim (Wim)
抄送: Haoweiguo; Thomas Morin; BESS; IDR Chairs
主题: Re: [bess] 答复:  Flowspec for L2VPN and E-VPN

Sent from iPAD

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 14 Nov 2014 09:09:22 +0100

RT overlap is a configuration issue not a protocol design issue.

It is easy to avoid it by proper RT assignment for non congruent services.

Cheers,
R.

On Fri, Nov 14, 2014 at 9:06 AM, Haoweiguo <[email-masked]> wrote:

> Hi Bertrand,
> What's your solution for RT overlap issue or other possible
> issue?Sometimes it is unfortunate that designing beauty needs to be
> compromised in reality.
> Thanks
> weiguo
>
> > On Nov 14, 2014, at 01:15, Henderickx, Wim (Wim) <
> [email-masked]> wrote:
> >

---

From: Haoweiguo <[email-masked]>
Date: Wed, 19 Nov 2014 11:56:34 +0000

Hi Bertrand,
Yes, unified fs safi is a good design, the fs safi can be used for all kinds of BGP fs, like IPv4,VPNv4,IPv6,VPNv6, layer 2(EVPN,PBB-EVPN,TRILL-EVPN,NVO3-EVPN,VPLS,PBB-VPLS.etc).
Currently IPV4 and VPNv4 flowspec has already been defined in RFC [5575]. IPv6 and VPNv6 flowspec definition is a WG draft.
If we prefer unified fs safi, should layer 2 fs and IPv6 fs merge into one single draft or evolve separately? I would like to hear WG co-chairs and experts opinion on this point.
Thanks
weiguo
________________________________________
From: Bertrand Duvivier (bduvivie) [[email-masked]]
Sent: Friday, November 14, 2014 16:00
To: Henderickx, Wim (Wim)
Cc: Haoweiguo; Thomas Morin; BESS; IDR Chairs
Subject: Re: [bess] 答复:  Flowspec for L2VPN and E-VPN

Sent from iPAD

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 19 Nov 2014 12:08:54 +0000

I would do the separate AFI/SAFI when we add L2. Customers deployed
Ipv4/Ipv6 with VPN or without VPNs already so we should not change this.

On 19/11/14 03:56, "Haoweiguo" <[email-masked]> wrote:

>Hi Bertrand,
>Yes, unified fs safi is a good design, the fs safi can be used for all
>kinds of BGP fs, like IPv4,VPNv4,IPv6,VPNv6, layer
>2(EVPN,PBB-EVPN,TRILL-EVPN,NVO3-EVPN,VPLS,PBB-VPLS.etc).
>Currently IPV4 and VPNv4 flowspec has already been defined in RFC [5575].
>IPv6 and VPNv6 flowspec definition is a WG draft.
>If we prefer unified fs safi, should layer 2 fs and IPv6 fs merge into
>one single draft or evolve separately? I would like to hear WG co-chairs
>and experts opinion on this point.
>Thanks
>weiguo
>> On Nov 14, 2014, at 01:15, Henderickx, Wim (Wim)
>><[email-masked]> wrote:
>>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 25 Nov 2014 03:23:42 +0000

IMO the SAFIs already defined for flowspec (SAFI 133, 134) can be reused. The L2 AFI can ensure a separate AFI/SAFI for L2.

Best regards,
Jie

> -----Original Message-----
> From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim
> (Wim)
> Sent: Wednesday, November 19, 2014 8:09 PM
> To: Haoweiguo; Bertrand Duvivier (bduvivie)
> Cc: IDR Chairs; Thomas Morin; BESS
> >one single draft or evolve separately? I would like to hear WG
> >co-chairs and experts opinion on this point.
> >Thanks
> >weiguo
> >>> applicable solution. Theoretically, unified mechanism for all
> >>> flowspec can be designed, but it maybe a more harder work in IDR.
> >>> Thanks
> >>> weiguo
> >>>
> >>> AFI/SAFI(s) for all flow spec functions. Flow spec in general is
> >>>providing  match criteria¹s with related actions. Given the proposal
> >>>on Flowspec for
> >>>> <http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01>
> >>>> (on idr agenda, being presented right now)