Subject: [bess] Flowspec for L2VPN and E-VPN

From: Thomas Morin <[email-masked]>
Date: Thu, 13 Nov 2014 13:44:19 -1000

Hi WG,

A heads up...

These two drafts relate to BESS and thus may be of interest to us:
- draft-hao-idr-flowspec-l2vpn 
<http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01> (on 
idr agenda, being presented right now)
- draft-hao-idr-flowspec-evpn 
<https://tools.ietf.org/html/draft-hao-idr-flowspec-evpn-00>

Best,

-Thomas

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 14 Nov 2014 00:55:28 +0100

Hi Thomas,

Are those really two separate documents ? I can't find the former while the
slides @ IDR really talk about the content of the latter :)

Cheers,
R.

On Fri, Nov 14, 2014 at 12:44 AM, Thomas Morin <[email-masked]>
wrote:

> - draft-hao-idr-flowspec-l2vpn <http://tools.ietf.org/html?
> draft=draft-hao-idr-flowspec-l2vpn-01> (on idr agenda, being presented
> right now)
> - draft-hao-idr-flowspec-evpn <https://tools.ietf.org/html/
> draft-hao-idr-flowspec-evpn-00>
>
> Best,
>
> -Thomas
>
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 13 Nov 2014 23:55:52 +0000

As I stated in the IDR meeting my observation is that we require to many
AFI/SAFI(s) for all flow spec functions. Flow spec in general is providing
match criteria¹s with related actions. Given the proposal on Flowspec for
L2 is new we should look at the bigger picture.
In My view we need a mechanism in BGP to advertise Flowspec match
criteria¹s with related actions and they should cover L2/L3-IPv4/IPv6.

---

From: Lucy yong <[email-masked]>
Date: Fri, 14 Nov 2014 00:00:51 +0000

We should have flow-spec per VNI that may carry L2 and/or L3 traffic.

Lucy

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, November 13, 2014 5:56 PM
To: Thomas Morin; BESS
Cc: IDR Chairs
Subject: Re: [bess] Flowspec for L2VPN and E-VPN

As I stated in the IDR meeting my observation is that we require to many
AFI/SAFI(s) for all flow spec functions. Flow spec in general is providing match criteria¹s with related actions. Given the proposal on Flowspec for
L2 is new we should look at the bigger picture.
In My view we need a mechanism in BGP to advertise Flowspec match criteria¹s with related actions and they should cover L2/L3-IPv4/IPv6.

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 00:02:08 +0000

Hi Robert and Thomas,

Yes, these two drafts are same topic. The former is a new version on BGP layer 2 flow spec. The 00 version can only use for EVPN network, the 01 version can be used for l2vpn network,not just EVPN network.

Thanks.

________________________________
发件人: BESS [[email-masked]] 代表 Robert Raszuk [[email-masked]]
发送时间: 2014年11月14日 7:55
收件人: Thomas Morin
抄送: IDR Chairs; BESS
主题: Re: [bess] Flowspec for L2VPN and E-VPN

Hi Thomas,

Are those really two separate documents ? I can't find the former while the slides @ IDR really talk about the content of the latter :)

Cheers,
R.

On Fri, Nov 14, 2014 at 12:44 AM, Thomas Morin <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

A heads up...

These two drafts relate to BESS and thus may be of interest to us:
- draft-hao-idr-flowspec-l2vpn <http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01> (on idr agenda, being presented right now)
- draft-hao-idr-flowspec-evpn <https://tools.ietf.org/html/draft-hao-idr-flowspec-evpn-00>

Best,

-Thomas

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 00:13:11 +0000

Hi Wim,
Allocating different AFI/SAFI(s) for each flow spec application is a applicable solution. Theoretically, unified mechanism for all flowspec can be designed, but it maybe a more harder work in IDR.
Thanks
weiguo

________________________________________
发件人: BESS [[email-masked]] 代表 Henderickx, Wim (Wim) [[email-masked]]
发送时间: 2014年11月14日 7:55
收件人: Thomas Morin; BESS
抄送: IDR Chairs
主题: Re: [bess] Flowspec for L2VPN and E-VPN

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 14 Nov 2014 00:20:10 +0000

+1..

Jim Uttaro