Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 25 Nov 2014 11:02:25 +0000

The reason we did this is providing the most flexibility because depending on the use case you need one and not the other. Hence we optimised for flexibility.

From: Haoweiguo <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 25 November 2014 10:21
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, sajassi <[email-masked]<mailto:[email-masked]>>
Subject: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Hi Ali and other Co-authors,

In the EVPN IRB draft, Route Type-2 is used to advertise TS's MAC and IP. Two BGP Extended Communities are carried with each RT-2 route. The first community carries tunnel type, the second community carries NVE MAC. In normal case, all RT-2 routes from a remote NVE share same NVE MAC, so in this case the Route information encoding isn't compact.
So a new compact encoding method is introduced as follows:

1. Add tunnel type field in Route Type-2.
2. Introduce a new Route Type to exclusively advertise tunnel type,NVE MAC and L3 VN ID.
3. Ingress NVEs correlate the new Type Route and RT-2 routes advertised from egress NVE to get the NVO3 encapsulation information for inter-subnet IP traffic forwarding.

Maybe there are other more compact methods. I would like to hear your co-authors opinion on this point.

Thanks

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Tue, 25 Nov 2014 13:01:45 +0000

Hi Wim,

Yes, the design has flexibility. But for most scenarios, we don't need this flexibility, we want to more compact encoding method. If all MAC routes advertised from a egress NVE share same NVE MAC and tunnel type, the two BGP Extended Communities carried with each MAC route is redundant, egress NVE only needs advertise its NVE MAC and tunnel type only once.

I think we had better provide two alternative solutions, one is for flexibility, another one is for compactness. Depending on different scenarios, the vendors can choose one for implementation.

Thanks

weiguo

________________________________

From: Henderickx, Wim (Wim) [[email-masked]]
Sent: Tuesday, November 25, 2014 19:02
To: Haoweiguo; [email-masked]; [email-masked]
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Thanks

weiguo

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Tue, 25 Nov 2014 14:41:27 +0000

Hi Weiguo,

If all the mac routes share the same NVE MAC and tunnel type for the same tenant, you can pack all those routes into a single bgp update. You don’t need a separate extended community per route.
It is actually a very efficient solution.

Thank you.
Jorge

From: Haoweiguo <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 25, 2014 at 5:01 AM
To: "Henderickx, Wim (Wim)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Hi Wim,

Thanks

weiguo

From: Henderickx, Wim (Wim) [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, November 25, 2014 19:02
To: Haoweiguo; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Thanks

weiguo

---

From: John E Drake <[email-masked]>
Date: Tue, 25 Nov 2014 15:42:25 +0000

Hi,

I think this suggestion is ill-considered.  We don't want two alternative solutions.

Yours Irrespectively,

John

From: BESS [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Tuesday, November 25, 2014 8:02 AM
To: Henderickx, Wim (Wim); [email-masked]; [email-masked]
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Hi Wim,

Thanks

weiguo

Thanks

weiguo

---

From: John E Drake <[email-masked]>
Date: Tue, 25 Nov 2014 15:43:20 +0000

Precisely.

Yours Irrespectively,

John

From: BESS [mailto:[email-masked]] On Behalf Of Rabadan, Jorge (Jorge)
Sent: Tuesday, November 25, 2014 9:41 AM
To: Haoweiguo; Henderickx, Wim (Wim); [email-masked]; [email-masked]
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Hi Weiguo,

Thank you.
Jorge

Hi Wim,

Thanks

weiguo

Thanks

weiguo

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 25 Nov 2014 16:34:18 +0000

Indeed we don’t need 2 solutions and what we have documented in the draft is efficient and flexible.

From: John E Drake <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 25 November 2014 16:43
To: Jorge Rabadan <[email-masked]<mailto:[email-masked]>>, Haoweiguo <[email-masked]<mailto:[email-masked]>>, Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, sajassi <[email-masked]<mailto:[email-masked]>>
Subject: RE: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Precisely.

Yours Irrespectively,

John

From: BESS [mailto:[email-masked]] On Behalf Of Rabadan, Jorge (Jorge)
Sent: Tuesday, November 25, 2014 9:41 AM
To: Haoweiguo; Henderickx, Wim (Wim); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Hi Weiguo,

Thank you.
Jorge

Hi Wim,

Thanks

weiguo

Thanks

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Wed, 26 Nov 2014 03:45:15 +0000

Hi Joege, Wim and John,

Thanks for your response. I agree with you, no need to support two encoding solutions. Yes, if multiple mac routes share same NVE MAC and tunnel type, we can pack these routes into a single BGP update message with a extended community, encoding format is comparatively efficient.

Thanks

weiguo

From: BESS [[email-masked]] on behalf of Henderickx, Wim (Wim) [[email-masked]]
Sent: Wednesday, November 26, 2014 0:34
To: John E Drake; Rabadan, Jorge (Jorge); Haoweiguo; [email-masked]; [email-masked]
Subject: Re: [bess] A comment and question for the draft "draft-ietf-bess-evpn-inter-subnet-forwarding-00"

Precisely.

Yours Irrespectively,

John

Hi Weiguo,

Thank you.
Jorge

Hi Wim,

Thanks

weiguo

Thanks

weiguo