Subject: Re: [bess] 答复: 答复: Flowspec for L2VPN and E-VPN

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 14 Nov 2014 00:27:55 +0000

We define a new AFI/SAFI that accommodates all we have + include L2
extensions.
Operators that don’t need L2 extensions keep what they have.
Operators that need L2 extensions go to the new method or mix the new
method with the old methods per service type.

Make sense?

On 13/11/14 14:16, "Haoweiguo" <[email-masked]> wrote:

>How to achieve compatability with current existed flowspec[RFC5575]
>applications? 
>Thanks
>weiguo
>
>________________________________________
>发件人: Henderickx, Wim (Wim) [[email-masked]]
>发送时间: 2014年11月14日 8:14
>收件人: Haoweiguo; Thomas Morin; BESS
>抄送: IDR Chairs
>主题: Re: 答复: [bess] Flowspec for L2VPN and E-VPN
>
>If we define a new things I prefer to address the wider issue and include
>L2 in that.
>
>On 13/11/14 14:13, "Haoweiguo" <[email-masked]> wrote:
>
>>Hi Wim,
>>Allocating different AFI/SAFI(s) for each flow spec application is a
>>applicable solution. Theoretically, unified mechanism for all flowspec
>>can be designed, but it maybe a more harder work in IDR.
>>Thanks
>>weiguo
>>
>>________________________________________
>>发件人: BESS [[email-masked]] 代表 Henderickx, Wim (Wim)
>>[[email-masked]]
>>发送时间: 2014年11月14日 7:55
>>收件人: Thomas Morin; BESS
>>抄送: IDR Chairs
>>主题: Re: [bess] Flowspec for L2VPN and E-VPN
>>
>>As I stated in the IDR meeting my observation is that we require to many
>>AFI/SAFI(s) for all flow spec functions. Flow spec in general is
>>providing
>>match criteria¹s with related actions. Given the proposal on Flowspec for
>>L2 is new we should look at the bigger picture.
>>In My view we need a mechanism in BGP to advertise Flowspec match
>>criteria¹s with related actions and they should cover L2/L3-IPv4/IPv6.
>>
>>On 13/11/14 13:44, "Thomas Morin" <[email-masked]> wrote:
>>
>>>Hi WG,
>>>
>>>A heads up...
>>>
>>>These two drafts relate to BESS and thus may be of interest to us:
>>>- draft-hao-idr-flowspec-l2vpn
>>><http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01> (on
>>>idr agenda, being presented right now)
>>>- draft-hao-idr-flowspec-evpn
>>><https://tools.ietf.org/html/draft-hao-idr-flowspec-evpn-00>
>>>
>>>Best,
>>>
>>>-Thomas
>>>
>>>
>>>_______________________________________________
>>>BESS mailing list
>>>[email-masked]
>>>https://www.ietf.org/mailman/listinfo/bess
>>
>>_______________________________________________
>>BESS mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/bess

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 00:42:03 +0000

Hi Wim,
It seems to be a solution. Another problem:
Current BGP flow spec for L2 VPN /L3 VPN relies on Rout Target for policy import/export. If using unified solution, RT can't overlap between different applications(L2VPN,L3VPN...). If using separating AFI/SAFI solution, no RT constraint issue.
Maybe there are other questions for unified solution, i would like to hear other expert's comments on your proposal.
Thanks
weiguo

________________________________________
发件人: BESS [[email-masked]] 代表 Henderickx, Wim (Wim) [[email-masked]]
发送时间: 2014年11月14日 8:27
收件人: Haoweiguo; Thomas Morin; BESS
抄送: IDR Chairs
主题: Re: [bess] 答复:  答复:  Flowspec for L2VPN and E-VPN

Make sense?

---

From: Mach Chen <[email-masked]>
Date: Fri, 14 Nov 2014 07:05:22 +0000

Hi Weiguo, Wim and others,

IMHO, AFI/SAFI based Flowspec would have better scalability and compatibility. There is a precedent (RT-Constrain) that adopted the unified RT for all AFI/SAFI that bring many limitation when deploying RTC.

Best regards,
Mach

> -----Original Message-----
> From: BESS [mailto:[email-masked]] On Behalf Of Haoweiguo
> Sent: Friday, November 14, 2014 8:42 AM
> To: Henderickx, Wim (Wim); Thomas Morin; BESS
> Cc: IDR Chairs
> Subject: [bess] 答复: 答复: 答复: Flowspec for L2VPN and E-VPN
> 
> Hi Wim,
> Current BGP flow spec for L2 VPN /L3 VPN relies on Rout Target for policy
> import/export. If using unified solution, RT can't overlap between different
> applications(L2VPN,L3VPN...). If using separating AFI/SAFI solution, no RT
> constraint issue.
> >>providing match criteria¹s with related actions. Given the proposal on
> >>Flowspec for
> >>><http://tools.ietf.org/html?draft=draft-hao-idr-flowspec-l2vpn-01>
> >>>(on idr agenda, being presented right now)

---

From: Haoweiguo <[email-masked]>
Date: Fri, 14 Nov 2014 07:59:31 +0000

Whether using unified AFI/SAFI or using individual AFI/SAFI for each BGP flowspec applications, RT overlap is a concern. Marc expressed his opinion, more other experts comments are welcomed.
Thanks
weiguo

________________________________________
发件人: Mach Chen
发送时间: 2014年11月14日 15:05
收件人: Haoweiguo; Henderickx, Wim (Wim); Thomas Morin; BESS
抄送: IDR Chairs
主题: RE: [bess] 答复:  答复:  答复:  Flowspec for L2VPN and E-VPN

Best regards,
Mach

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 14 Nov 2014 08:03:15 +0000

It does
Bertrand

Sent from iPAD

> On Nov 14, 2014, at 01:28, Henderickx, Wim (Wim) <[email-masked]> wrote:
>

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 14 Nov 2014 08:10:56 +0000

Rt range is large enough field to not overlap between l2 and l3 rt's and rt rewrite is also possible

Adding newer safi does add lots of complexity as well
- increase bgp db
- increase bgp stack to process newer safi 
- for evpn mix routed and bridged environment (some pe bridging, some other routing) we will have to send 2 bgp fs with 2 differents safi's

Sent from iPAD

> On Nov 14, 2014, at 01:42, Haoweiguo <[email-masked]> wrote:
> 
> Hi Wim,

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 14 Nov 2014 12:59:00 +0000

I am on the same page

On 13/11/14 21:05, "Mach Chen" <[email-masked]> wrote:

>IMHO, AFI/SAFI based Flowspec would have better scalability and
>compatibility. There is a precedent (RT-Constrain) that adopted the
>unified RT for all AFI/SAFI that bring many limitation when deploying RTC.
>
>Best regards,
>Mach
>
>> Maybe there are other questions for unified solution, i would like to
>>hear other
>> expert's comments on your proposal.
>> Thanks
>> weiguo
>>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 14 Nov 2014 13:51:31 +0000

IMO there are more important reasons why one does not deploy RTC.

Jim Uttaro

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Friday, November 14, 2014 2:05 AM
To: Haoweiguo; Henderickx, Wim (Wim); Thomas Morin; BESS
Cc: IDR Chairs
Subject: Re: [bess] 答复: 答复: 答复: Flowspec for L2VPN and E-VPN

Best regards,
Mach

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 14 Nov 2014 15:09:02 +0100

Jim,

And what now RTC has to do with this discussion ???

r.

On Fri, Nov 14, 2014 at 2:51 PM, UTTARO, JAMES <[email-masked]> wrote:

> compatibility. There is a precedent (RT-Constrain) that adopted the unified
> RT for all AFI/SAFI that bring many limitation when deploying RTC.
>
> Best regards,
> Mach
>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 14 Nov 2014 14:27:25 +0000

Look just one message below what I wrote and one will find the following. I bolded the sentence.

“Hi Weiguo, Wim and others,

Best regards,
Mach”

From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Friday, November 14, 2014 9:09 AM
To: UTTARO, JAMES
Cc: Mach Chen; Haoweiguo; Henderickx, Wim (Wim); Thomas Morin; BESS; IDR Chairs
Subject: Re: [bess] 答复: 答复: 答复: Flowspec for L2VPN and E-VPN

Jim,

r.

On Fri, Nov 14, 2014 at 2:51 PM, UTTARO, JAMES <[email-masked]<mailto:[email-masked]>> wrote:
IMO there are more important reasons why one does not deploy RTC.

Jim Uttaro

-----Original Message-----
From: BESS [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mach Chen
Sent: Friday, November 14, 2014 2:05 AM
To: Haoweiguo; Henderickx, Wim (Wim); Thomas Morin; BESS
Cc: IDR Chairs
Subject: Re: [bess] 答复: 答复: 答复: Flowspec for L2VPN and E-VPN

Best regards,
Mach

> From: BESS [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Haoweiguo
> 发件人: BESS [[email-masked]<mailto:[email-masked]>] 代表 Henderickx, Wim (Wim)
> [[email-masked]<mailto:[email-masked]>]
> 发送时间: 2014年11月14日 8:27
> On 13/11/14 14:16, "Haoweiguo" <[email-masked]<mailto:[email-masked]>> wrote:
>
> >发件人: Henderickx, Wim (Wim) [[email-masked]<mailto:[email-masked]>]
> >发送时间: 2014年11月14日 8:14
> >On 13/11/14 14:13, "Haoweiguo" <[email-masked]<mailto:[email-masked]>> wrote:
> >
> >>Hi Wim,
> >>发件人: BESS [[email-masked]<mailto:[email-masked]>] 代表 Henderickx, Wim (Wim)
> >>[[email-masked]<mailto:[email-masked]>]
> >>发送时间: 2014年11月14日 7:55
> >>收件人: Thomas Morin; BESS
> >>抄送: IDR Chairs
> >>On 13/11/14 13:44, "Thomas Morin" <[email-masked]<mailto:[email-masked]>> wrote:
> >>
> >>>Hi WG,
> >>>
> >>>A heads up...
> >>>
> >>>[email-masked]<mailto:[email-masked]>
> >>[email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 14 Nov 2014 15:36:56 +0100

Well,

For one Mach's msg never made it to the list. I am not sure how you have
received it :)

Second my comment was general not just to you directly.

Why flowspec discussion now is derailed to RTC topic of same or different
RT. Both are completely orthogonal.

Cheers,
r.

On Fri, Nov 14, 2014 at 3:27 PM, UTTARO, JAMES <[email-masked]> wrote:

> compatibility. *There is a precedent (RT-Constrain) that adopted the
> unified RT for all AFI/SAFI that bring many limitation when deploying RTC.*
>
>
>
> Best regards,
>
> Mach”
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
> Raszuk
> *Sent:* Friday, November 14, 2014 9:09 AM
> *To:* UTTARO, JAMES
> *Cc:* Mach Chen; Haoweiguo; Henderickx, Wim (Wim); Thomas Morin; BESS;
> IDR Chairs
> *Subject:* Re: [bess] 答复: 答复: 答复: Flowspec for L2VPN and E-VPN
>
>
>
> Jim,
>
>
>