Subject: Re: [bess] PMSI Tunnel Attribute Flags

From: Eric C Rosen <[email-masked]>
Date: Tue, 29 Sep 2015 10:04:22 -0400

Jorge,

Sorry about the delay getting back to you; hopefully we can bring this 
document to WGLC relatively sonn.

> Although I was still leaning towards a registry per tunnel-type or at
> least per SAFI (since it would save the use of a new EC) I think at this
> moment it is even more important to close on this as soon as possible to
> avoid issues.

Slide 6 of the presentation I gave at the Dallas IETF provides some 
reasons for not setting up a different registry per tunnel-type or SAFI.
>
> My only other comment is that it would seem 'cleaner' to use the most
> significant bit to indicate the existence of the EC instead of bit 1. If
> would be good to confirm that the rumor about the use of bit 0 is an
> existing implementation, in which case I agree it can’t be used.

I did hear the "rumor" from a reliable source ;-)

> If that
> is the case, it would be good if the relevant people document that
> somewhere.

Indeed it would.  But hopefully, once we set up the registry, similar 
undocumented uses of the flag bits will be less likely to happen.

Eric

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Tue, 29 Sep 2015 22:55:21 +0000

Eric,

That’s ok.
As I said, to me it is more important to close on this asap. I would be interested to know what that bit is used for ;-) but.. other than that, I fully support this document.

Thank you.
Jorge  

On 9/29/15, 7:04 AM, "BESS on behalf of Eric C Rosen" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess