Subject: Re: [bess] draft-ietf-bess-evpn-prefix-advertisement-02

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Wed, 7 Oct 2015 22:31:16 +0000

Sami,

There are intended for different scenarios. When a subnet is sitting
behind a TS, there is no need to advertise label/VNI in RT5 for that
subnet because it gets resolved via label/VNI associated with RT2 for that
TS. In other scenarios, where subnet gets directly advertised by PE (e.g.,
no indirection and no RT2), then label/VNI for that subnet gets advertised
in RT5.

Cheers,
Ali

On 10/7/15, 2:56 PM, "BESS on behalf of Sami Boutros (sboutros)"
<[email-masked] on behalf of [email-masked]> wrote:

>Hi Jorge,
>
>In some of the use case sections in the draft, there is no mention of the
>label/VNI that will be associated with RT-5.
>As well if the router-mac will be associated with RT-5 and the GW-IP will
>be set, why do we need to advertise those again in RT-2?
>
>Thanks,
>
>Sami
>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Fri, 9 Oct 2015 05:46:50 +0000

Sami,

Besides what Ali says, for your second question note that in the use-case 5.4 we are explicitly avoiding GW-IP non-zero plus router’s mac in the same update:

"The Router's MAC Extended Community MUST be sent if the associated
          RT-5's GW IP Address is zero.”

Thanks.
Jorge