Subject: [bess] Stephen Farrell's No Objection on draft-ietf-bess-mvpn-bidir-ingress-replication-03: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 15 Oct 2015 05:28:00 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-bess-mvpn-bidir-ingress-replication-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bess-mvpn-bidir-ingress-replication/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have one less and two more serious comments...

- Less seriously, "MP2MP tunnel" seems like a strange use of
language, I wondered if it might be better to call these an
MP2MP warren (as in rabbit warren, and of course bearing in
mind the ops-dir review:-)

- More seriously, this is another draft that simply has too
many acronyms and uses those too densely. For example, I just
find it really hard to believe that "If a PE, say PEx, is
connected to a site of a given VPN, and PEx's next hop
interface to some C-RPA is a VRF interface, then PEx MUST
advertises a (C-*,C-*-BIDIR) S-PMSI A-D route, regardless of
whether it has any local Bidir-PIM join states corresponding
to the C-RPA learned from its CEs" is a useful sentence to
implementers. IMO enough folks have commented on this aspect
that the wg would be wise to seriously consider the
readibility of their output.  I've worked on enough EU-funded
projects that had write-only documents to be worried if the
IETF starts to produce those.  (This is not a discuss since
I've been assured that this is not a problem for implementers,
and while I do accept that, I also continue to worry about
it.)

- I am simply not in a position to evaluate section 4. And nor
was the assigned secdir reviewer. The same point about density
and that making any secdir review hard to impossible was noted
by the secdir reviewer for draft-ietf-bess-mvpn-bidir. I don't
think it'd be valid for me to put on a discuss on the basis
that nothing this complex has "no new security issues" but it
was tempting.

Overall, I think it would be best if this were returned to the
wg asking for significant improvement in clarity for readers.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 15 Oct 2015 13:00:10 +0000

On 10/15/15, 8:28 AM, "Stephen Farrell" <[email-masked]> wrote:

Stephen (and everyone else):

>IMO enough folks have commented on this aspect
>readibility of their output...(This is not a discuss since

You're right, enough people have commented on the readability of the bess
work.  As I said in other threads, I don't believe that to be an issue
with the implementation and development of the work in the WG.

However, it is becoming an issue for appropriate reviews outside the WG.
I'll work with the Chairs (and authors) on the clarity of upcoming
documents.

Thanks!

Alvaro.