Subject: [bess] I-D Action: draft-ietf-bess-evpn-etree-03.txt

From: [email-masked]
Date: Mon, 12 Oct 2015 10:17:37 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the BGP Enabled Services Working Group of the IETF.

        Title           : E-TREE Support in EVPN & PBB-EVPN
        Authors         : Ali Sajassi
                          Samer Salam
                          Sami Boutros
                          Jim Uttaro
	Filename        : draft-ietf-bess-evpn-etree-03.txt
	Pages           : 16
	Date            : 2015-10-12

Abstract:
   The Metro Ethernet Forum (MEF) has defined a rooted-multipoint
   Ethernet service known as Ethernet Tree (E-Tree).  [ETREE-FMWK]
   proposes a solution framework for supporting this service in MPLS
   networks. This document discusses how those functional requirements
   can be easily met with (PBB-)EVPN and how (PBB-)EVPN offers a more
   efficient implementation of these functions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-etree/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-bess-evpn-etree-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-etree-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lucy yong <[email-masked]>
Date: Wed, 14 Oct 2015 16:44:31 +0000

Hi Ali, et al

This version has quite changes. Could you summarize what have been changed for what reason? I had some comments while ago,  https://mailarchive.ietf.org/arch/msg/bess/TnGmg2SYNGrc0DMCClVHrYLyX6Y

Does this version address them?

Few comments to this version:

*         Section 3.3.1 does not mention if the MAC learning needs to learn the MAC's root role or leaf role for the scenario described in section 2.3. How does PE2 (in figure 3) advertise the learned MAC?

*         The content in Section 3.3.1 starting from the second paragraph to the end is useful, but does not belong to this section. Maybe move to section 3.2 or other place?

*         In section 5.1, the E-TREE Extended Community is re-defined. To advertise MAC/IP from a root AC, BGP must not insert this extended community because the community is for the leaf indication. It is better to explicitly state it. In fact, the simpler logic can be: when this extended community is advertised along with MAC/IP advertisement route, it means that the MAC is originated by a leaf otherwise means the MAC is originated by a root; when this extended community is advertised along with the Ethernet A-D per ES route, it means that the ES has leaf role and a valid label should be encoded in the label field in the EC. The flag is not necessary.

*         The draft suggests for a PE to allocate a single Leaf label for all single-homed ESs on the PE. If we allocates one extended MPLS label as of the Leaf Label, all PE will use the same label on the leaf BUM packets to indicate a leaf origination. IMO: this is simpler method.

Regards,

Lucy

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, October 12, 2015 12:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] I-D Action: draft-ietf-bess-evpn-etree-03.txt

        Authors         : Ali Sajassi

                          Samer Salam

                          Sami Boutros

                          Jim Uttaro

      Pages           : 16

      Date            : 2015-10-12

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________

BESS mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/bess