Subject: Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Fri, 6 Nov 2015 14:14:13 +0000

Hi Wim,

If you can tell me what part of the draft is not clear, I will explain it here and if any further clarification in the draft needed, I will take care of it.

Cheers,
Ali

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Wim Henderickx <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 4, 2015 at 10:58 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

After clarification in the meeting I learned it is a requirement to select the same PE for upstream/downstream traffic.
My question is how is this done? Or better which mechanisms are used to achieve this?

---

From: Wim Henderickx <[email-masked]>
Date: Sat, 07 Nov 2015 11:10:06 +0100

First if this is a  requirement it should be listed in section 2.

For known unicast traffic the document describes a upstream hash function in section 4.2.1.
For BUM traffic It describes the SHG/DF procedures but there is no guarantee described that the downstream DF is similar to the upstream hash or IGP distance in case of unequal cost. As such I don’t see how for BUM traffic the consistency between upstream and downstream is guaranteed? (section 4.2.2.)

From:  Ali Sajassi <[email-masked]>
Date:  Friday 6 November 2015 at 15:14
To:  Wim Henderickx <[email-masked]>, "[email-masked]" <[email-masked]>
Subject:  Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

Hi Wim,

Cheers,
Ali

From: BESS <[email-masked]> on behalf of Wim Henderickx <[email-masked]>
Date: Wednesday, November 4, 2015 at 10:58 PM
To: "[email-masked]" <[email-masked]>
Subject: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Sun, 8 Nov 2015 09:06:32 +0000

It is not a hard requirement. I will add it as a soft requirement (e.g., either SHOULD or MAY) and it would only be for known unicast traffic - i.e., upstream and downstream traffic per VNI can be guaranteed to go through the same PE for known unicast if the operator chooses so.

Cheers,
Ali

From: Wim Henderickx <[email-masked]<mailto:[email-masked]>>
Date: Saturday, November 7, 2015 at 7:10 PM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

For known unicast traffic the document describes a upstream hash function in section 4.2.1.
For BUM traffic It describes the SHG/DF procedures but there is no guarantee described that the downstream DF is similar to the upstream hash or IGP distance in case of unequal cost. As such I don't see how for BUM traffic the consistency between upstream and downstream is guaranteed? (section 4.2.2.)

From: Ali Sajassi <[email-masked]<mailto:[email-masked]>>
Date: Friday 6 November 2015 at 15:14
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

Hi Wim,

Cheers,
Ali

---

From: Wim Henderickx <[email-masked]>
Date: Sun, 08 Nov 2015 11:18:42 +0100

How will you do QoS guarantees if the BUM traffic is not accommodated in this scheme ?

From:  Ali Sajassi <[email-masked]>
Date:  Sunday 8 November 2015 at 10:06
To:  Wim Henderickx <[email-masked]>, "[email-masked]" <[email-masked]>
Subject:  Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

Cheers,
Ali

From: Wim Henderickx <[email-masked]>
Date: Saturday, November 7, 2015 at 7:10 PM
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] draft-sajassi-bess-pbb-evpn-anycast-ip- tunnels-00.txt

Hi Wim,

Cheers,
Ali