Subject: Re: [bess] Comments on "draft-sajassi-bess-evpn-igmp-mld-proxy-00"

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 5 Nov 2015 02:33:39 +0000

Hi Weiguo,

From: Haoweiguo <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 22, 2015 at 2:17 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Comments on "draft-sajassi-bess-evpn-igmp-mld-proxy-00"

Hi Ali,

I have read through the draft, i think the procedures is fine for IGMP/MLD proxy. However, this draft doesn't consider multicast router scenario, better to be added.

Scenario 1:

         An EVPN PE acts as multicast router and runs PIM protocol with the outside multicast routers.

Scenario 2:

         An EVPN PE connects to a multicast router on port1, no IGMP receiver on the port.  The PE sends IGMP/MLD to the multicast router.

We have covered both scenarios. The first one is referred to as "distributed anycast router"

In both scenarios, the EVPN PE should announce its role through the extended route type6 to indicate it connects to a multicast router or acts as multicast router itself.

Other EVPN PEs having local multicast source should forward the multicast traffic to the PE announcing multicast router role, the PE announcing multicast router role should not be pruned for all multicast traffic.

For the PE connecting to a multicast router, it should translate  EVPN route type-6 message to IGMP/MLD message, it's already described in your draft. For the PE acting as multicast router, it should translate EVPN route type-6 message to PIM protocol, this part has not been covered in your draft, better to be added.

Correct, the mcast traffic treatment for inter-subnet is not described yet but we'll mention it in the next rev.

Cheers,
Ali

Thanks,

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Thu, 5 Nov 2015 05:54:09 +0000

Hi Ali,

Thanks for your reply. I think the 'distributd anycast multicast router' may not satisfy my requirements. In my discriptions, one multicast router is attached behind a EVPN PE or the multicast router also acts as an EVPN PE at the same time,  the multicat router is centralized deployed. In this scenario, one bit Flag as multicast router indicator is needed. The PE acting as multicast router or with multicast router behind should announce the route type 6 message with the indicator flag marked. When other PEs with multicast source behind receives the message,  when they inject local multicast traffic to EVPN network, they will always send the traffic to the multicast router PE, the multicast traffic will never be pruned. If no this Flag, if the multicast router PE has no local IGMP/MLG receivers, the multicast traffic from other PEs will never come to the multicast router PE.

I think your whole solution is good, it's easy to add this multicast router Flag bit in route type-6 TLV.

Thanks,
weiguo
________________________________
From: Ali Sajassi (sajassi) [[email-masked]]
Sent: Thursday, November 05, 2015 10:33
To: Haoweiguo
Cc: [email-masked]
Subject: Re: Comments on "draft-sajassi-bess-evpn-igmp-mld-proxy-00"

Hi Weiguo,

Hi Ali,

Scenario 1:

Scenario 2:

We have covered both scenarios. The first one is referred to as “distributed anycast router"

Correct, the mcast traffic treatment for inter-subnet is not described yet but we’ll mention it in the next rev.

Cheers,
Ali

Thanks,

weiguo