Subject: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 5 Nov 2015 05:25:21 +0000

Maybe good to clarify in this draft which nodes are involved in EVPN from the drawing on p3 in https://www.ietf.org/proceedings/94/slides/slides-94-bess-11.pdf?
Did I understood correctly in the meeting that this is required between all SPE(s), if so why?

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 5 Nov 2015 05:40:10 +0000

I did not get that either until Ali confirmed that in the meeting.

I had thought that SPEs were running regular L3VPN (not EVPN) but the ones that a CE multi-home to would also use EVPN procedures. Now it looks like there is no “regular” L3VPN – everything is EVPN.

Jeffrey

From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, November 05, 2015 2:25 PM
To: [email-masked]
Subject: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 5 Nov 2015 05:42:22 +0000

Is the draft assuming also IP-VPN in the core or only EVPN?
I don’t see a reason for excluding one or another

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 14:40
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Jeffrey

From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, November 05, 2015 2:25 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Thu, 5 Nov 2015 05:44:36 +0000

My understanding is that an IP-VPN PE would not be able take advantage of “mass-withdraw”?

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: Thursday, November 05, 2015 2:42 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
Subject: Re: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Jeffrey

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 5 Nov 2015 05:46:09 +0000

IF you do Edge-PIC this is optional afais.

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 14:44
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: Thursday, November 05, 2015 2:42 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Jeffrey

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 5 Nov 2015 06:44:47 +0000

The point is that the CE does not realize that it is multihomed.
The access node implements the multihoming, but the CE has only one BGP session and one interface.
The APE-SPE connections is an ethernet with the same ESI towards SPE1 and SPE2
The SPEs talk EVPN, using route type 5 to implement an L3VPN service.
This provides the ESI and mass withdrawal that RFC4364 routes do not.

--Jakob

From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, November 04, 2015 9:46 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Jeffrey

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 5 Nov 2015 08:17:12 +0000

Jakob, thx this is clear.
What I see is that the benefits of ESI and Mass withdraw indication are also solved based on implementation. By using PW/tunnel indications and local Edge PIC on the SPE connected to the access network can enable the same behaviour with similar convergence results.

From: "Jakob Heitz (jheitz)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 15:44
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

--Jakob

Jeffrey