Subject: [bess] Question on draft-shah-bess-l2vpn-yang-00

From: Rotem Cohen <[email-masked]>
Date: Sun, 22 Nov 2015 15:50:08 +0000

Hi Himanshu, et al.

Can you explain please why for VPWS the leaves 'discovery-type' and 'signaling-type' appear directly below 'vpws-instance/' while for VPLS they appear below 'vpls-instance/pw/'?

It looks that 'signaling-type' should be under '../pw/' hierarchy for both vpls-instance and vpws-instance.
The 'discovery-type' leaf should be configured at the service-instance level with status to indicate that the instance advertises itself (configuration) and at the PW level as an indication that this specific PW has been set up due to auto-discovery vs. manual peer configuration.

'discovery' and 'signaling' containers under 'bgp-parameters' container have references to '../../discovery-type' and to '../../signaling-type' respectively. Because the referenced leaves are on a different levels of the tree for vpws-instance and vpls-instance it causes compilation error.

Regards,

Rotem Cohen

PTS System Architecture Group Manager

T:

+972.3.926.8247

M:

+972.54.926.8247

E:

[email-masked]<mailto:[email-masked]>

www.ecitele.com<http://www.ecitele.com/>

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Tue, 24 Nov 2015 02:49:45 +0000

Rotem,

I agree with your statement. I'll bring this up in our weekly meeting and get back to you on Thursday.

Regards,

Patrice

   [http://www.cisco.com/web/europe/images/email/signature/est2014/logo_06.png?ct=1406640631632]

Patrice Brissette
TECHNICAL LEADER.ENGINEERING

[email-masked]<mailto:[email-masked]>
Phone: +1 613 254 3336

Cisco Systems Canada Co. / Les Systemes Cisco Canada CIE
Canada
Cisco.com<http://www.cisco.com/global/CA/>

[http://www.cisco.com/assets/swa/img/thinkbeforeyouprint.gif] Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Please click here<http://www.cisco.com/web/about/doing_business/legal/cri/index.html> for Company Registration Information.

From: Rotem Cohen <[email-masked]<mailto:[email-masked]>>
Date: Sunday, November 22, 2015 at 10:50 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>, Evyatar Wiesel <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Question on draft-shah-bess-l2vpn-yang-00

Hi Himanshu, et al.

Regards,

Rotem Cohen

T:

+972.3.926.8247

M:

+972.54.926.8247

E: