Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Fri, 6 Nov 2015 14:46:35 +0000

Wim,
The draft currently assumes that all the S-PEs are EVPN PEs. However, the remote S-PEs really don't have to be EVPN PEs. They can be IP-VPN PEs and we can use evpn-ipvpn-interop draft for the interoperability between the two types. On the other hand, the S-PEs in the redundancy group have to be EVPN PEs.

Now, regarding using local edge PIC on the SPEs, it doesn't give you the sych-up of prefixes for VRFs and ARP cache tables. We are talking about a single BGP session between the CE and S-PEs. And upon failure, we are talking about non-stop forwarding with min. traffic disruption.

-Ali

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of "Henderickx, Wim (Wim)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 5, 2015 at 1:17 AM
To: "Jakob Heitz (jheitz)" <[email-masked]<mailto:[email-masked]>>, "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Jakob, thx this is clear.
What I see is that the benefits of ESI and Mass withdraw indication are also solved based on implementation. By using PW/tunnel indications and local Edge PIC on the SPE connected to the access network can enable the same behaviour with similar convergence results.

From: "Jakob Heitz (jheitz)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 15:44
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

The point is that the CE does not realize that it is multihomed.
The access node implements the multihoming, but the CE has only one BGP session and one interface.
The APE-SPE connections is an ethernet with the same ESI towards SPE1 and SPE2
The SPEs talk EVPN, using route type 5 to implement an L3VPN service.
This provides the ESI and mass withdrawal that RFC4364 routes do not.

--Jakob

From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, November 04, 2015 9:46 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

IF you do Edge-PIC this is optional afais.

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 14:44
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

My understanding is that an IP-VPN PE would not be able take advantage of "mass-withdraw"?

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: Thursday, November 05, 2015 2:42 PM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Is the draft assuming also IP-VPN in the core or only EVPN?
I don't see a reason for excluding one or another

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 5 November 2015 at 14:40
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

I did not get that either until Ali confirmed that in the meeting.

I had thought that SPEs were running regular L3VPN (not EVPN) but the ones that a CE multi-home to would also use EVPN procedures. Now it looks like there is no "regular" L3VPN - everything is EVPN.

Jeffrey

From: BESS [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, November 05, 2015 2:25 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Maybe good to clarify in this draft which nodes are involved in EVPN from the drawing on p3 in https://www.ietf.org/proceedings/94/slides/slides-94-bess-11.pdf?
Did I understood correctly in the meeting that this is required between all SPE(s), if so why?

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 6 Nov 2015 15:43:46 +0000

Ali, ok I see the ARP cache sync and customer route sync is a benefit. Maybe we should make this clearer in the draft.

From: Ali Sajassi <[email-masked]<mailto:[email-masked]>>
Date: Friday 6 November 2015 at 15:46
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "Jakob Heitz (jheitz)" <[email-masked]<mailto:[email-masked]>>, "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Wim,
The draft currently assumes that all the S-PEs are EVPN PEs. However, the remote S-PEs really don’t have to be EVPN PEs. They can be IP-VPN PEs and we can use evpn-ipvpn-interop draft for the interoperability between the two types. On the other hand, the S-PEs in the redundancy group have to be EVPN PEs.

Now, regarding using local edge PIC on the SPEs, it doesn’t give you the sych-up of prefixes for VRFs and ARP cache tables. We are talking about a single BGP session between the CE and S-PEs. And upon failure, we are talking about non-stop forwarding with min. traffic disruption.

-Ali

--Jakob

My understanding is that an IP-VPN PE would not be able take advantage of “mass-withdraw”?

Is the draft assuming also IP-VPN in the core or only EVPN?
I don’t see a reason for excluding one or another

I had thought that SPEs were running regular L3VPN (not EVPN) but the ones that a CE multi-home to would also use EVPN procedures. Now it looks like there is no “regular” L3VPN – everything is EVPN.

Jeffrey

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Sat, 7 Nov 2015 00:02:01 +0000

We’ll do.

From: "Henderickx, Wim (Wim)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, November 6, 2015 at 8:43 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, "Jakob Heitz (jheitz)" <[email-masked]<mailto:[email-masked]>>, "Jeffrey (Zhaohui) Zhang" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] draft-sajassi-bess-evpn-l3vpn- multihoming-00.txt

Wim,

-Ali

--Jakob

Jeffrey