Subject: [bess] Introducing a one-implementation requirement before WG last calls

From: Thomas Morin <[email-masked]>
Date: Tue, 24 Nov 2015 10:03:29 +0100

Hello everyone,

Following the positive feedback received during BESS meeting in Yokohama 
about introducing a one-implementation requirement in BESS, we propose 
to do the following for future WG last calls:

As a prerequisite before doing a working group last call on a document, 
the chairs will ask the working group for known implementations of the 
specifications; a relatively detailed level of information will be 
required (e.g. "release x.y of solution z shipping date d", "all 
features implemented", "partial implementation only", etc.) and everyone 
will be invited to reply (not only co-authors of the specifications); 
the chairs will then do the working group last call if satisfying 
information was provided on at least one implementation.

We are open for comments on this proposal until December 7th.

Martin & Thomas

---

From: Antoni Przygienda <[email-masked]>
Date: Tue, 24 Nov 2015 23:34:14 +0000

+1  (I don't mean make it 1+1=2 implementations, I just say it's a very good new [and old ;-) ] idea ;-) 

thanks 

--- tony
_____________________________________________
"Simple, clear purpose and principles give rise to complex and intelligent behavior. Complex rules and regulations give rise to simple and stupid behavior." 
--- Dee Hock 

> -----Original Message-----
> From: BESS [mailto:[email-masked]] On Behalf Of Thomas Morin
> Sent: Tuesday, November 24, 2015 1:03 AM
> To: BESS
> Subject: [bess] Introducing a one-implementation requirement before WG
> last calls
> 
> Hello everyone,
> 
> about introducing a one-implementation requirement in BESS, we propose to
> do the following for future WG last calls:
> 
> As a prerequisite before doing a working group last call on a document, the
> chairs will ask the working group for known implementations of the
> specifications; a relatively detailed level of information will be required (e.g.
> "release x.y of solution z shipping date d", "all features implemented",
> "partial implementation only", etc.) and everyone will be invited to reply (not
> only co-authors of the specifications); the chairs will then do the working
> group last call if satisfying information was provided on at least one
> implementation.
> 
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 25 Nov 2015 17:26:52 -0800

Sounds like a good idea to me. One tweak: having an official "release x.y @shipping date d" is unlikely for a draft. The value of one implementation (vs more) is that it shows that a spec is implementable and reasonably complete. So, this should be the focus, with details on how much of the spec was implemented. Shipping plans should be totally optional. 

Note that even an experimental implementation takes effort, is likely to become official, and shows a degree of seriousness of the part of the implementor.  Asking for greater commitment at WGLC is (imho) asking too much. 

Kireeti

> On Nov 24, 2015, at 01:03, Thomas Morin <[email-masked]> wrote:
> 
> Hello everyone,
> 
> Following the positive feedback received during BESS meeting in Yokohama about introducing a one-implementation requirement in BESS, we propose to do the following for future WG last calls:
> 
> As a prerequisite before doing a working group last call on a document, the chairs will ask the working group for known implementations of the specifications; a relatively detailed level of information will be required (e.g. "release x.y of solution z shipping date d", "all features implemented", "partial implementation only", etc.) and everyone will be invited to reply (not only co-authors of the specifications); the chairs will then do the working group last call if satisfying information was provided on at least one implementation.
>

---

From: Martin Vigoureux <[email-masked]>
Date: Thu, 26 Nov 2015 10:50:03 +0100

Hello Kireeti,

thanks for your inputs.
I understand the challenge that "release x.y @shipping date d" might 
pose. What we want, is to go beyond the "I am aware of an 
implementation" type of response. It might currently be sufficient with 
regards to the shepherd write-up question, but won't be any more if we 
introduce the requirement. We'd like to have tangible information. 
Giving "details on how much of the spec was implemented" is clearly 
going in that direction.

-m

---

From: Thomas Morin <[email-masked]>
Date: Thu, 26 Nov 2015 14:50:09 +0100

Kireeti, Martin,

Any data related to a serious implementation (even a beta without a 
shipping date), would I think be convincing enough.
"release x.y @shipping date d" was simply provided as a possible answer, 
not of the minimum requirement to be convincing.

As Martin said we need more than "I am aware of an implementation".
I would say we also need more than "we plan to implement".

There are cases where we may need more detailed data.
Take for instance the case of a draft that needs specific dataplane 
support: would we accept as convincing enough an implementation on a 
software-only platform, in the absence of any vendor planning to 
implement on hardware ?

-Thomas

Martin Vigoureux :
> implementation" type of response. It might currently be sufficient 
> with regards to the shepherd write-up question, but won't be any more 
> if we introduce the requirement. We'd like to have tangible 
> information. Giving "details on how much of the spec was implemented" 
> is clearly going in that direction.
>
> -m
>
>> Sounds like a good idea to me. One tweak: having an official "release 
>> x.y @shipping date d" is unlikely for a draft. The value of one 
>> implementation (vs more) is that it shows that a spec is 
>> implementable and reasonably complete. So, this should be the focus, 
>> with details on how much of the spec was implemented. Shipping plans 
>> should be totally optional.
>>
>> Note that even an experimental implementation takes effort, is likely 
>> to become official, and shows a degree of seriousness of the part of 
>> the implementor.  Asking for greater commitment at WGLC is (imho) 
>> asking too much.
>>
>> Kireeti
>>
>>> Following the positive feedback received during BESS meeting in 
>>> Yokohama about introducing a one-implementation requirement in BESS, 
>>> we propose to do the following for future WG last calls:
>>>
>>> As a prerequisite before doing a working group last call on a 
>>> document, the chairs will ask the working group for known 
>>> implementations of the specifications; a relatively detailed level 
>>> of information will be required (e.g. "release x.y of solution z 
>>> shipping date d", "all features implemented", "partial 
>>> implementation only", etc.) and everyone will be invited to reply 
>>> (not only co-authors of the specifications); the chairs will then do 
>>> the working group last call if satisfying information was provided 
>>> on at least one implementation.
>>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 26 Nov 2015 17:01:03 -0000

Perhaps it is time to recall RFC 6982.
While that RFC says nothing about setting hurdles (so that debate needs to continue) it does provide a lightweight way of tracking implementations and noting what bits of I-Ds have been implemented.

Yaron and I can report mixed results from the RFC so far: sometime there has been a degree of enthusiasm to report implementations (free marketing?) while other times implementations that we know are out there have sullenly refused to present details for inclusion in I-Ds. Draw your own conclusions :-)

Adrian

> Sent: 26 November 2015 13:50
> To: [email-masked]
> Subject: Re: [bess] Introducing a one-implementation requirement before WG
> last calls
> 
> Kireeti, Martin,
>