Subject: Re: [bess] Poll for adoption: draft-zzhang-bess-evpn-bum-procedure-updates-03

From: "Arun Prakash (arprakas)" <[email-masked]>
Date: Fri, 2 Sep 2016 21:17:26 +0000

Hi Jeffrey,

Thank you for the explanation. Am not clear if this draft is only for L2
or can it be used for L3 as well?
What if we have both L2 and L3 multicast ?

Thanks
Arun

On 8/28/16, 7:08 PM, "BESS on behalf of Jeffrey (Zhaohui) Zhang"
<[email-masked] on behalf of [email-masked]> wrote:

>Hi Swadesh,
>
>"Enable MVPN safi and enhance it for EVPN" is not a trivial thing that
>can be cleanly done on top of MVPN. You'd end up complicating MVPN
>procedures a lot for EVPN specific things. Instead, we can apply the same
>principles to EVPN safi and procedures, and that's what this draft is
>about.
>
>BTW, we don't yet see the need of the equivalent of MVPN type-5 routes
>for EVPN. Draft-sajassi-bess-evpn-igmp-mld-proxy already proposed SMET
>route which is very similar to MVPN type-6/7 (to be exact, a combination
>of type-4/6/7). That is explained in
>draft-zzhang-bess-mvpn-evpn-cmcast-enhancements.
>
>Jeffrey
>
>> -----Original Message-----
>> From: Swadesh Agrawal (swaagraw) [mailto:[email-masked]]
>> Sent: Friday, August 26, 2016 3:06 AM
>> To: Eric Rosen <[email-masked]>; Martin Vigoureux
>> <[email-masked]>; [email-masked]
>> Cc: [email-masked]
>> Subject: Re: [bess] Poll for adoption: draft-zzhang-bess-evpn-bum-
>> procedure-updates-03
>> 
>> Why we need to copy MVPN procedures in EVPN. Why not enable MVPN safi
>>and
>> enhance it for any EVPN specific requiremnt. Also going in this
>>direction
>> may require to add 5,6 and 7 routes as well in future.
>> 
>> Regards
>> Swadesh
>> 
>> On 8/25/16, 2:22 PM, "Eric C Rosen" <[email-masked]> wrote:
>> 
>> >Support.
>> >
>> >MVPN has a number of multicast features that are valuable, but haven't
>> >yet been incorporated into EVPN.  This draft takes a comprehensive look
>> >at the MVPN  procedures that provide those features, and shows how to
>> >adapt them to EVPN.   This seems quite valuable to me, and thus I think
>> >the WG should adopt this draft.
>> >
>> >_______________________________________________
>> >BESS mailing list
>> >[email-masked]
>> >https://www.ietf.org/mailman/listinfo/bess
>
>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 2 Sep 2016 21:47:38 +0000

Hi Arun,

It's for EVPN only, but using the same concept that has been developed for L3.

If we have both L2 and L3, it would be "ships in the night", and https://tools.ietf.org/html/draft-lin-bess-evpn-irb-mcast-02 is one way to optimize things. That draft talked about using MVPN when a bridge domain is not connected everywhere.

Jeffrey

> From: Arun Prakash (arprakas) [mailto:[email-masked]]
> Sent: Friday, September 02, 2016 5:17 PM
> To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Swadesh Agrawal
> (swaagraw) <[email-masked]>; Eric Rosen <[email-masked]>; Martin
> Vigoureux <[email-masked]>; [email-masked]
> Cc: [email-masked]; Nikhil Shetty
> (nikshett) <[email-masked]>

---

From: Keyur Patel <[email-masked]>
Date: Tue, 20 Sep 2016 17:25:30 +0000

I am not aware of any IPRs related to the draft.

Apologies for the delayed response.

Best Regards,

Keyur

> From: BESS [mailto:[email-masked]] On Behalf Of Martin Vigoureux
> Sent: Tuesday, August 16, 2016 8:37 AM
> To: [email-masked]
> Subject: [bess] Poll for adoption: draft-zzhang-bess-evpn-bum-procedure-
> updates-03
>
> Hello working group,
>
> This email starts a two-week poll on adopting
> draft-zzhang-bess-evpn-bum-procedure-updates-03 [1] as a Working Group
> Document.
>
> Please state on the list if you support adoption or not (in both cases,
> please also state the reasons).
>
> This poll runs until *the 30th of August*.
>
> We are also polling for knowledge of any undisclosed IPR that applies
> to this Document, to ensure that IPR has been disclosed in compliance
> with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more
> details).
> If you are listed as an Author or Contributor of this Document please
> respond to this email and indicate whether or not you are aware of any
> relevant undisclosed IPR. The Document won't progress without answers
> from all the Authors and Contributors.
> No IPR has been disclosed against this Document
>
> If you are not listed as an Author or Contributor, then please
> explicitly respond only if you are aware of any IPR that has not yet
> been disclosed in conformance with IETF rules.
>
> Thank you
>
> Martin & Thomas
> bess chairs
>
> [1]
> https://datatracker.ietf.org/doc/draft-zzhang-bess-evpn-bum-procedure-
> updates/
>