Subject: [bess] EVPN MH: Backup node behavior in Primary Path Failure

From: Jaikumar Somasundaram <[email-masked]>
Date: Wed, 26 Sep 2018 11:08:51 +0000

Hello Everyone,

I have a question on Primary PE encountering a failure in EVPN multihoming

in single active mode.

RFC7432, section 14.1.1:

<snip>

   If there is more than one backup PE for a given ES, the remote PE

   MUST use the primary PE's withdrawal of its set of Ethernet A-D per

   ES routes as a trigger to start flooding traffic for the associated

   MAC addresses (as long as flooding of unknown unicast packets is

   administratively allowed), as it is not possible to select a single

   backup PE.

</snip>

Questions:

1. Will the node in backup mode forward the packet to CE?

2. Will all the nodes in backup mode forward the packet before DF election?

3. If they forward, how is duplicate packets handled, in this case?

Please help me anwere these questions.

Thanks & Regards

Jaikumar S

---

From: Jaikumar Somasundaram <[email-masked]>
Date: Wed, 3 Oct 2018 10:15:27 +0000

Hello Everyone,

Sorry if it is a duplicate. I repost this query as I did not receive any response yet.
(I was wondering if this mail already reached the group or not)

in single active mode.

RFC7432, section 14.1.1:

<snip>

   backup PE.

</snip>

Questions:

Thanks & Regards

Jaikumar S