Subject: [bess] Document shepherd's review of draft-ietf-bess-evpn-optimized-ir-04

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thu, 11 Oct 2018 10:43:12 +0000

Authors and WG

I am the document shepherd for draft-ietf-bess-evpn-optimized-ir-04. I have reviewed the document and I believe it is ready to progress, subject to fixing the following minor comments. Please treat these as you would WG last call comments.

I also wanted to draw the WG’s attention to the fact that we did not receive a statement during WG last call from Contributor Mudassir Tufail. We intend to proceed with publication since he did respond to an earlier IPR poll on the draft.

  *   Please expand all acronyms on first use.
  *   The ‘terminology’ and ‘conventions used in this document’ are at the end of the document. Please can you move them to the beginning.
  *   Section 2: Solution requirements. I think these are the design requirements for the solution proposed in this draft and which it is claimed to meet, rather than requirements for some future as yet un-published solution. Maybe you can rephrase the first sentence to: “The IR optimization solution specified in this document (referred to as optimized-IR hereafter) meets the following requirements:”. If there are some from this list that it does not meet, then you should call them out.
  *   Section 3: The first paragraph says that you are changing the Inclusive Multicast Ethernet Tag routes and attributes. Are you really changing them or extending them? If you are changing them then I think this document updates RFC7432, otherwise it is probably better to change the wording to ‘extends’.
  *   Section 3: Flags field diagram. ‘reserved’ is usually shortened to ‘rsvd’ rather than ‘resved’ in RFCs.
  *   There are a couple of cases where you say ‘the solution proposes’ (Section 3 and 4.4). This is no longer a proposal, but rather an accepted solution. I suggest you remove the word ‘proposes’ and rephrase those sentences accordingly.

Thanks

Matthew

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 19 Oct 2018 01:39:45 +0000

Hi Matthew,

Thank you very much for reviewing the document.
Version 05 has been posted addressing all your comments. Please see more in-line below.

Thank you.
Jorge

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Thursday, October 11, 2018 at 3:43 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Document shepherd's review of draft-ietf-bess-evpn-optimized-ir-04
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, October 11, 2018 at 3:43 AM

Authors and WG

-          Please expand all acronyms on first use.
[JORGE] done, thx

-          The ‘terminology’ and ‘conventions used in this document’ are at the end of the document. Please can you move them to the beginning.
[JORGE] done, thx

-          Section 2: Solution requirements. I think these are the design requirements for the solution proposed in this draft and which it is claimed to meet, rather than requirements for some future as yet un-published solution. Maybe you can rephrase the first sentence to: “The IR optimization solution specified in this document (referred to as optimized-IR hereafter) meets the following requirements:”. If there are some from this list that it does not meet, then you should call them out.
[JORGE] changed

-          Section 3: The first paragraph says that you are changing the Inclusive Multicast Ethernet Tag routes and attributes. Are you really changing them or extending them? If you are changing them then I think this document updates RFC7432, otherwise it is probably better to change the wording to ‘extends’.
[JORGE] you’re right, “extends” is the right word

-          Section 3: Flags field diagram. ‘reserved’ is usually shortened to ‘rsvd’ rather than ‘resved’ in RFCs.
[JORGE] done, thx

-          There are a couple of cases where you say ‘the solution proposes’ (Section 3 and 4.4). This is no longer a proposal, but rather an accepted solution. I suggest you remove the word ‘proposes’ and rephrase those sentences accordingly.
[JORGE] done, thx

Thanks

Matthew