Subject: [bess] Questions about the EVPN YANG data model draft

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 21 Oct 2018 11:00:25 +0000

Dear Editors of the EVPN YANG data model draft<https://tools.ietf.org/html/draft-ietf-bess-evpn-yang-05>,
I have several questions regarding the draft, and would highly appreciated your responses.

1.       The -05 version of the draft has expired almost two months ago. Do you plan to refresh it any time soon?

2.       The draft consistently uses type uint32 for the Ethernet segment identifier (ESI), while RFC 7432 explicitly defines it as a 10-octet integer. Is this just a typo, or did I miss something substantial here?

3.       The draft states that it covers Integrated Routing and Bridging in EVPN, but I could not find any traces of such coverage. Did I miss something, or is just a forward declaration for the future version of the draft?

4.       RFC 7432 states that "When a customer site is connected to one or more PEs via a set of Ethernet links, then this set of Ethernet links constitutes an Ethernet segment". The Virtual Ethernet Segment draft<https://tools.ietf.org/html/draft-ietf-bess-evpn-virtual-eth-segment-00> expands this definition and, so that virtual Ethernet Segments can be comprised of:

*         Ethernet Virtual Circuits aggregated on an ENNI physical ports

*         Ethernet PWs or even MPLS LSPs.
Can you please clarify the following:

a.       How does the proposed YANG data model differentiate between physical and virtual Ethernet Segments?

b.       Does this data model cover the scenario where the virtual Ethernet segments are represented by EVCs?

5.       RFC 7432 includes recommendations for usage (or non-usage) of the Control Word in the EVPN encapsulation, and RFC 8214 (which is claimed to be covered by this draft) provides a control plane mechanism for exchanging the CW usage information. Can you please clarify whether the draft cover usage of the CW in the EVPN encapsulations?
Your feedback will be highly appreciated.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Tue, 23 Oct 2018 00:19:28 +0000

Hi Alex,

I just refresh the draft. Unfortunately, I just notice your email. I will make sure it is properly handle.

Regards,

Patrice Brissette, Principal Engineer
Cisco Systems
Help us track your SP SR/EVPN Customer Opportunity/Status by filling these forms: Segment Routing<https://app.smartsheet.com/b/form/185833ace35b4894b324dfb8afbd2060> / EVPN<https://app.smartsheet.com/b/form/136bd5c3a22641bf92316523e79d6f22>

From: Alexander Vainshtein <[email-masked]>
Date: Sunday, October 21, 2018 at 7:00 AM
To: Patrice Brissette <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Questions about the EVPN YANG data model draft

4.       RFC 7432 states that “When a customer site is connected to one or more PEs via a set of Ethernet links, then this set of Ethernet links constitutes an Ethernet segment". The Virtual Ethernet Segment draft<https://tools.ietf.org/html/draft-ietf-bess-evpn-virtual-eth-segment-00> expands this definition and, so that virtual Ethernet Segments can be comprised of:

·         Ethernet Virtual Circuits aggregated on an ENNI physical ports

·         Ethernet PWs or even MPLS LSPs.
Can you please clarify the following:

Office: +972-39266302
Cell:      +972-549266302

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 23 Oct 2018 05:35:33 +0000

Patrice,
Lots of thanks for a prompt response.

I have just looked up the diff between -05 and -06 versions of the draft.

It seems that the only change is refresh of references as some of the drafts to which the -05 version referred have been publishesd as RFCs.

So I think that my questions equally apply to the -06 version.

Regards,
Sasha

Thumb typed by Sasha Vainshtein

________________________________
From: Patrice Brissette (pbrisset) <[email-masked]>
Sent: Tuesday, October 23, 2018 3:19:28 AM
To: Alexander Vainshtein; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: Questions about the EVPN YANG data model draft

Hi Alex,

Regards,

Office: +972-39266302
Cell:      +972-549266302