Subject: [bess] Opsdir last call review of draft-ietf-bess-evpn-vpls-seamless-integ-05

From: Linda Dunbar <[email-masked]>
Date: Tue, 18 Dec 2018 15:26:02 -0800

Reviewer: Linda Dunbar
Review result: Ready

Reviewer: Linda Dunbar
Review result: Ready with comments

I have reviewed this document as part of the Operational directorate's
ongoing effort to review all IETF documents being processed by the IESG.  These
comments were written with the intent of improving the operational aspects of
the IETF drafts. Comments that are not addressed in last call may be included
in AD reviews during the IESG review.  Document editors and WG chairs should
treat these comments just like any other last call comments.

The draft describes the procedures for EVPN PEs to handle traffic from VPLS
PEs, to enable smooth transition from VPLS network to EVPN network. The
procedures are written very clear, (although I am not sure why it is a Standard
Track document as the document is mainly in describing the procedures of PEs
that support both EVPN & VPLS).

Question to the authors:

Page 8 Section 3.2: why set up the PW if keep it operationally down?

Best Regards,
Linda Dunbar

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 19 Dec 2018 07:54:35 +0000

Linda,

Thank you for reviewing. 

I think the document has to be Standards Track. Especially for the PEs that support both VPLS _and_ EVPN, the procedures described must be consistent in all the PEs that participate in the seamless integration, otherwise there could be loops or blackholes. Also we are defining procedures to allow PWs and EVPN destinations in the same split-horizon-group. Although there are no changes in BGP or LDP, there are changes in the EVPN procedures. 

"Page 8 Section 3.2: why set up the PW if keep it operationally down?"

The main reason is to avoid having to re-establish the PW if the IMET route is withdrawn. In that case the PW provides a fast backup path if the EVPN destination becomes unavailable. Note this is the case also for manual FEC128 PWs. If the two PEs can successfully establish a PW, there is no reason to not do it and have it ready in case the EVPN connection becomes unavailable. 

If the draft is used for migration purposes only, after the PEs are migrated, the VPLS AD and PW configuration can be removed to release resources.

Thank you.
Jorge

-----Original Message-----
From: Linda Dunbar <[email-masked]>
Date: Wednesday, December 19, 2018 at 12:26 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Opsdir last call review of draft-ietf-bess-evpn-vpls-seamless-integ-05
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, Matthew Bocci <[email-masked]>
Resent-Date: Wednesday, December 19, 2018 at 12:26 AM

    Reviewer: Linda Dunbar
    Review result: Ready
    
    Reviewer: Linda Dunbar

    
    Question to the authors:

    Best Regards,
    Linda Dunbar