Subject: [bess] Fwd: New Version Notification for draft-dawra-bess-srv6-services-01.txt

From: Gaurav Dawra <[email-masked]>
Date: Fri, 5 Jul 2019 12:55:57 -0700

Hi Bess WG,

We have posted a new version of SRv6 Services document.

Cheers,

Gaurav

---------- Forwarded message ---------
From: <[email-masked]>
Date: Fri, Jul 5, 2019 at 12:55 PM
Subject: New Version Notification for draft-dawra-bess-srv6-services-01.txt
To: Jonn Leddy <[email-masked]>, Swadesh Agrawal <
[email-masked]>, Robert Raszuk <[email-masked]>, Dirk Steinberg <
[email-masked]>, [email-masked] <[email-masked]>, Bruno
Decraene <[email-masked]>, Jorge Rabadan <[email-masked]>,
Gaurav Dawra <[email-masked]>, Shunwan Zhuang <
[email-masked]>, [email-masked] <[email-masked]>,
Clarence Filsfils <[email-masked]>, Patrice Brissette <
[email-masked]>, Satoru Matsushima <[email-masked]>

A new version of I-D, draft-dawra-bess-srv6-services-01.txt
has been successfully submitted by Gaurav Dawra and posted to the
IETF repository.

Name:           draft-dawra-bess-srv6-services
Revision:       01
Title:          SRv6 BGP based Overlay services
Document date:  2019-07-03
Group:          Individual Submission
Pages:          28
URL:
https://www.ietf.org/internet-drafts/draft-dawra-bess-srv6-services-01.txt
Status:
https://datatracker.ietf.org/doc/draft-dawra-bess-srv6-services/
Htmlized:
https://tools.ietf.org/html/draft-dawra-bess-srv6-services-01
Htmlized:
https://datatracker.ietf.org/doc/html/draft-dawra-bess-srv6-services
Diff:
https://www.ietf.org/rfcdiff?url2=draft-dawra-bess-srv6-services-01

Abstract:
   This draft defines procedures and messages for SRv6-based BGP
   services including L3VPN, EVPN and Internet services.  It builds on
   RFC4364 "BGP/MPLS IP Virtual Private Networks (VPNs)" and RFC7432
   "BGP MPLS-Based Ethernet VPN".

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Gaurav Dawra <[email-masked]>
Date: Sun, 7 Jul 2019 22:35:22 -0700

Hi Bess WG,

To facilitate the review of latest update - here is some more context.

The new revision addresses all comments received from the WG, including the following.
When Function part of SRv6 SID is unique per NLRI(example EVPN VPWS service), encoding it in SID attribute may introduce some degradation in BGP packing assuming other BGP attributes are shared for set of NLRI’s.

Specifically, in order to address the BGP packing issue, we are proposing the following in the new version:
 
Flexibility of advertising Function and Arguments of SRv6 SID in label field of route NLRI. This addresses BGP packing concern when SID is unique per NLRI(example EVPN VPWS service), assuming other BGP attributes are shared for set of NLRI’s.
Advertisement of SRv6 SID structure sub-sub tlv in SID attribute. It also provides ability to create SRv6 SID when individual fields are available separately.
These updates are completely backward compatible with previous version.

Gaurav

Sent from my iPhone

> On Jul 5, 2019, at 12:55 PM, Gaurav Dawra <[email-masked]> wrote:
> 
> Hi Bess WG,
> 
> To: Jonn Leddy <[email-masked]>, Swadesh Agrawal <[email-masked]>, Robert Raszuk <[email-masked]>, Dirk Steinberg <[email-masked]>, [email-masked] <[email-masked]>, Bruno Decraene <[email-masked]>, Jorge Rabadan <[email-masked]>, Gaurav Dawra <[email-masked]>, Shunwan Zhuang <[email-masked]>, [email-masked] <[email-masked]>, Clarence Filsfils <[email-masked]>, Patrice Brissette <[email-masked]>, Satoru Matsushima <[email-masked]>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-dawra-bess-srv6-services-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-dawra-bess-srv6-services/
> Htmlized:       https://tools.ietf.org/html/draft-dawra-bess-srv6-services-01
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-dawra-bess-srv6-services
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-dawra-bess-srv6-services-01
> 
> Abstract:

---

From: Xiejingrong <[email-masked]>
Date: Mon, 8 Jul 2019 13:24:57 +0000

Hi
I didn't see the reply to my recent comments on the previous rev of this draft……

Thanks
Jingrong
发件人：Gaurav Dawra <[email-masked]>
收件人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>
时间：2019-07-08 13:36:08
主 题：Re: [bess] New Version Notification for draft-dawra-bess-srv6-services-01.txt

Hi Bess WG,

  *   When Function part of SRv6 SID is unique per NLRI(example EVPN VPWS service), encoding it in SID attribute may introduce some degradation in BGP packing assuming other BGP attributes are shared for set of NLRI’s.

  *   Flexibility of advertising Function and Arguments of SRv6 SID in label field of route NLRI. This addresses BGP packing concern when SID is unique per NLRI(example EVPN VPWS service), assuming other BGP attributes are shared for set of NLRI’s.
  *   Advertisement of SRv6 SID structure sub-sub tlv in SID attribute. It also provides ability to create SRv6 SID when individual fields are available separately.
These updates are completely backward compatible with previous version.

Gaurav

Sent from my iPhone

On Jul 5, 2019, at 12:55 PM, Gaurav Dawra <[email-masked]<mailto:[email-masked]>> wrote:

Hi Bess WG,

Cheers,

Gaurav

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Fri, Jul 5, 2019 at 12:55 PM
Subject: New Version Notification for draft-dawra-bess-srv6-services-01.txt
To: Jonn Leddy <[email-masked]<mailto:[email-masked]>>, Swadesh Agrawal <[email-masked]<mailto:swaagraw@cisco..com>>, Robert Raszuk <[email-masked]<mailto:[email-masked]>>, Dirk Steinberg <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Bruno Decraene <[email-masked]<mailto:[email-masked]>>, Jorge Rabadan <[email-masked]<mailto:[email-masked]>>, Gaurav Dawra <[email-masked]<mailto:[email-masked]>>, Shunwan Zhuang <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Clarence Filsfils <[email-masked]<mailto:[email-masked]>>, Patrice Brissette <[email-masked]<mailto:[email-masked]>>, Satoru Matsushima <[email-masked]<mailto:[email-masked]>>

Status:         https://datatracker.ietf.org/doc/draft-dawra-bess-srv6-services/<https://datatracker.ietf..org/doc/draft-dawra-bess-srv6-services/>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools..ietf.org>.

The IETF Secretariat