Subject: [bess] miss import and export policy within routing-policy under vpn-target

From: Qin Wu <[email-masked]>
Date: Thu, 25 Jul 2019 18:35:45 +0000

Hi, folks:

When I walk through draft-ietf-bess-l3vpn-yang draft today,

I see what is missing in routing policy model is import and export policy parameter, the grouping apply-policy defined in routing policy yang model which supports import and export policy is not used in the BGP model,

So I am wondering why we not add import and export policy and take out routing policy leafref.

Also I am wondering whether all the vendors support import-from-global and export-to-global, if the answer is no,

I am wondering if we should add if-feature for import-from-global and export-to-global and take them completely out.

-Qin

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 25 Jul 2019 15:38:09 -0400

Qin: 

Just to make sure I have the context, the "BGP model" is the
draft-bess-l3vpn-yang-draft or the base BGP protocol model? 

Sue 

From: BESS [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Thursday, July 25, 2019 2:36 PM
To: [email-masked]
Cc: [email-masked];
[email-masked]
Subject: [bess] miss import and export policy within routing-policy under
vpn-target

Hi, folks:

I see what is missing in routing policy model is import and export policy
parameter, the grouping apply-policy defined in routing policy yang model
which supports import and export policy is not used in the BGP model,

So I am wondering why we not add import and export policy and take out
routing policy leafref.

Also I am wondering whether all the vendors support import-from-global and
export-to-global, if the answer is no, 

I am wondering if we should add if-feature for import-from-global and
export-to-global and take them completely out.

-Qin

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Jul 2019 21:49:07 +0000

It is the latter, the basic BGP YANG model.

________________________________
吴钦 Qin
Mobile：+86-13914734360<tel:+86-13914734360>(Mobile Number)
Email：[email-masked]<mailto:[email-masked]>

发件人： Susan Hares<[email-masked]<mailto:[email-masked]>>
收件人： Qin Wu<[email-masked]<mailto:[email-masked]>>;bess<[email-masked]<mailto:[email-masked]>>
抄送： draft-ietf-rtgwg-policy-model.all<[email-masked]<mailto:[email-masked]>>;draft-ietf-bess-l3vpn-yang.all<[email-masked]<mailto:[email-masked]>>
主题： RE: [bess] miss import and export policy within routing-policy under vpn-target
时间： 2019-07-25 15:38:29

Qin:

Just to make sure I have the context, the “BGP model” is the draft-bess-l3vpn-yang-draft or the base BGP protocol model?

Sue

From: BESS [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Thursday, July 25, 2019 2:36 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [bess] miss import and export policy within routing-policy under vpn-target

Hi, folks:

-Qin